433MHz, emetteur & recepteur arduino


#82

On dirait que « radioemitter » n’est pas dans la liste des services disponibles. Sous quel nom (slug) as tu enregistré le module ?


#83

Bonjour à tous,

@pierre-gilles,

Si je met le second Arduino avec ton code .ino (compatible avec mes détecteurs de mouvements) sur un autre port usb du Raspberry, Gladys entendra également ce second devise ?


#84

Si tu lis bien, ce n’est pas la même erreur :

Là, la requête de récupération ne retourne rien…

Et là, Gladys ne trouve pas la fonction exec du service (radioemitter) lié à ton devicetype, comme le disais @Boimb.

Vérifie que ton module radioemitter est bien installé dans le dossier “/home/pi/gladys/api/hooks/radioemitter”.


#85

@Pti_Nico @Boimb
Merci de votre aide, vous aviez raison, j’étais aller trop vite lors de la réinstallation, j’avais fait une faute à “radioemitter” :sweat:


#86

Bon bah ça avance :smile:
Et du coup… ça dit quoi maintenant ?


#87

ça dit que ça fonctionne :grin:


#88

Note pour plus tard… relis toi puis Check puis double Check :wink:


#89

Oui :sweat_smile:, mais pour le slug, je l’avais bien écrit la première fois (j’avais fait un copier/coller), mais lorsque j’avais le problème de l’arduino qui ne renvoyait rien à Gladys, j’avais réinstallé le module et je pense que j’ai du faire la faute à ce moment là :sweat_smile:


#90

Mm à tester mais je crois que oui :slight_smile:


#91

Faudrait vérifier mais je crois que serial ne gère qu’un seul arduino. Il Check les ports et écoute le premier qu’il trouve.


#92

Non! Il gère autant d’arduino qu’il peut en réception ! En revanche, en émission tu as raison il prend le premier qu’il trouve :slight_smile:


#93

Il faut que je regarde hier j’ai réussi à rajouter RCSwitch dans le code arduino mais le code n’est détecté qu’au départ quand la carte arduino est branchée mais n’est pas dans la boucle


#94

Ok!

Du coup pour l’instant en l’état le code n’est pas encore bon pour être mergé on est d’accord ? La réception ne fonctionne plus ?

Tenez moi au courant de l’avancement là dessus :slight_smile:


#95

Mybad. Effectivement, j’étais en train de checker sur le code si je disais pas des bêtises… C’est sendCode.js qui envoie par défaut au premier port :smiley:
T’as été plus rapide que moi ^^
… La prochaine fois je checkerai avant de parler…


#96

Bon, et bien je vais tester avec deux Arduino :slight_smile:


#97

Çà fonctionne, (Avec deux Arduino)

Enfin, je commande mes DI-O et je reçois tous mes détecteurs.

Je reçois même deux codes venant du détecteur de fumée ^^

Je passe a la suite :slight_smile:


#98

Bonjour, je suis nouveau ici, et je trouve le projet super.
Mais la j’avoue être perdu. Comment j’installe Arduino Ide sur raspian ?
Et comment j’ajoute les librairies ?

Bref je suis pas doué, alors si on peut me guider dans la marche à suivre pour contrôler les quelques prise DI-O que j’ai.
Mon RFLink est configuré et fonctionnel sur Domoticz.

Merci d’avance.


#99

salut,
pas de soucis, on va t’aider.
l’ide arduino ne doit pas être installé sur raspbian mais sur ton pc, juste pour flasher l’arduino avec le bon code.
ensuite juste connecte l’arduino à la raspberry gladys et c’est bon.

Pour info, j’avance bien sur la nouvelle version compatible rflink. la réception est quasiment finit et l’émission est sur la bonne voie aussi


#100

Oh merci je vais essayer ça alors.
Et j’attends ta version alors.
Désolé je débute vraiment.


#101

Alors je crois avoir réussi à suivre le tutoriel avec Arduino IDE.
Par contre comment je trouve les code de mes prise DI-O ?
J’ai une télécommande mais sans écran pour voir le chiffre.
Et je sais pas quoi lancer comme commande pour voir ce que reçoit Gladys.

Pouvez vous m’aider ?