Alarme Cron


#1

Salut,
J’ai ouvert un ticket sur github car j’ai l’impression, d’après mes tests, qu’une Alarme de type Cron (pas testé les autres) n’est pas schedulée lorsqu’on reboot Gladys.


#2

Hello,

Je rencontre le même problème.

Avec une alarme classique et depuis l’arrivée de Cron idem. ça fonctionne les premières fois mais dès que Gladys redémarre, elles ne sont plus planifiées.


#3

Merci pour le retour je suis dessus !


#4

Bonjour,
Je suis nouvel utilisateur de Gladys , je trouve ça top :+1:.
j’ai bien réussi à créer mes scénarios, démarrer un script sur une alarme Cron, mais malheureusement à chaque redémarrage de Gladys les alarmes Cron ne s’exécute plus. je suis obligé de les supprimer et de les recréer.

une petite idée pour corriger ça? je suis en version 3.9.

Merci :wink:


#5

Salut,

Alors c’est marrant que tu parles de ca, je viens d’avoir un comportement étrange sur les cron, je vérifie ca ce soir chez moi.


#6

Hello @Furiousmax!

Comment as-tu installé Gladys ? Tu lances bien Gladys en mode production (si tu l’as installé en manuel)

Je viens de vérifier chez moi les alarmes cron sont bien relancée à chaque démarrage


#7

Salut,
J’ai installé gladys grâce à l’image en 3.8 que jai updaté en 3.9 par la suite.
Par contre je suis sur un Raspberry 1 (recyclage ON) tout le reste fonctionne bien sur cette première. génération.


#8

Tout devrait fonctionner alors… Pas d’erreur dans les logs au démarrage ?


#9

Bon après vérification, ca marche bien chez moi aussi.
J’ai juste mon réveil du matin qui jeudi a pas démarré, sans explication.


#10

Désolé pour le retard.

voici les avertissements que j’ai au démarrage , je pense que la deuxième partie est en rapport…
mais je ne sais pas pourquoi.

0|gladys | Warning: connect.session() MemoryStore is not
0|gladys | designed for a production environment, as it will leak
0|gladys | memory, and will not scale past a single process.
0|gladys | Warning: connect.session() MemoryStore is not
0|gladys | designed for a production environment, as it will leak
0|gladys | memory, and will not scale past a single process.
0|gladys |
0|gladys | =======================================
0|gladys | WARNING: You currently have your default CORS settings configured to allow
0|gladys | all requests from all origins, with credentials. This may leave your app
0|gladys | open to attack by third-party sites! Consider making your origins setting
0|gladys | more restrictive or setting credentials to false, or else make certain that
0|gladys | none of your routes perform sensitive actions or reveal secure information.
0|gladys | =======================================
0|gladys |

0|gladys   | TypeError: Cannot read property 'slice' of null
0|gladys   |     at Object.schedule (/home/pi/gladys/api/core/alarm/alarm.schedule.js:14:39)
0|gladys   |     at /home/pi/gladys/api/core/alarm/alarm.init.js:12:37
0|gladys   |     at tryCatcher (/home/pi/gladys/node_modules/bluebird/js/release/util.js:16:23)
0|gladys   |     at MappingPromiseArray._promiseFulfilled (/home/pi/gladys/node_modules/bluebird/js/release/map.js:61:38)
0|gladys   |     at MappingPromiseArray.PromiseArray._iterate (/home/pi/gladys/node_modules/bluebird/js/release/promise_array.js:114:31)
0|gladys   |     at MappingPromiseArray.init (/home/pi/gladys/node_modules/bluebird/js/release/promise_array.js:78:10)
0|gladys   |     at MappingPromiseArray._asyncInit (/home/pi/gladys/node_modules/bluebird/js/release/map.js:30:10)
0|gladys   |     at Async._drainQueue (/home/pi/gladys/node_modules/bluebird/js/release/async.js:138:12)
0|gladys   |     at Async._drainQueues (/home/pi/gladys/node_modules/bluebird/js/release/async.js:143:10)
0|gladys   |     at Immediate.Async.drainQueues (/home/pi/gladys/node_modules/bluebird/js/release/async.js:17:14)
0|gladys   |     at runCallback (timers.js:789:20)
0|gladys   |     at tryOnImmediate (timers.js:751:5)
0|gladys   |     at processImmediate [as _immediateCallback] (timers.js:722:5)

Merci encore !:smile:


#11

Ah je comprends!

Je pense qu’il doit y avoir un bug côté Gladys, par curiosité tu as une alarme automatique ? (autoWakeUp?)

J’ai créé une issue pour tracker le bug =>


#12

oui j’ai un autoWakeUp.
Il est déclaré automatiquement? car il ne me semble pas avoir activé l’option quelque part.


#13

@Furiousmax : J’ai fixé le bug! :slight_smile: