[BETA] App Android

beta

#362

Salut @Yota

C’est sympa mais l’app sera publié sur le compte Google Play de l’organisation Gladys pour uniformiser le tout :slight_smile:


#363

Salut @MathieuA , je rencontre un souci sur l’app avec le nom des devices. j’ai un device qui s’appel SPA dans dans lequel j’ai crée plusieurs bouton (pompe, power, bulle, chauffage) le problème c’est que dans l’application , j’ai uniquement le nom du device qui apparait (SPA) pour tout mes boutons. du coup impossible pour moi de savoir si j’active la pompe les bulles, le chauffage ou la mise en route. Y a t-il une solution?

MERCI!!


#364

Salut @alexis

Tu utilise quelle version de l’app ?


#365

j’utilise la 1.4.5 ce n’est pas la dernière ?


#366

Nope ! C’est la 1.5.2 la dernière ! Et dans cette version le dashboard a été revu et il affiche désormais les tag des devicetypes :wink:


#367

Salut @MathieuA,
J’essai d’installer la dernière version(1.5.2) et j’ai un refus sur deux device(mon tel et une tablette). Sur le tel j’avais une ancienne version et ça fonctionnait donc je ne comprend pas. Là je ne peux pas installer, ça me met un refus. Une idée?


#368

Salut @isokar

L’app est conçue pour fonctionner à partir de l’API 19 d’Android (Android 4.4 KitKat) donc si tes appareil ont une version encore antérieure c’est normal.


#369

@isokar il te donne quoi comme message d’erreur quand tu veux installer l’application en version 1.5.2 ?


#370

@MathieuA, sur mon tel, je suis en android 6.0.1 donc je ne pense pas que cela viennent de là.
sinon voici ce que j’ai:

je clic donc sur “Installer” et j’ai ensuite:

et c’est tout. aucune infos.
Pour info, je viens de réinstaller la version 1.4.5 que j’avais et ça fonctionne.


#371

Tu as désinstallé l’ancienne version avant ?
Il me semble que j’avais changé le certificat, c’est bien le seul truc qui pourrait t’empêcher de l’installer sur une version aussi récente :thinking:


#372

Je confirme que si le certificat à changer mais pas le nom du package, ça doit jouer en effet…


#373

merci à vous deux mais j’ai effectivement désinstallé l’ancienne version. comment faire pour supprimer le certificat?


#374

Ah si tu n’avais plus l’ancienne version, ça risque d’être un peu plus chaud… :thinking:
Le certificat est lié à l’apk que tu veux installer, donc tu n’as pas à le gérer toi :wink:
Tu aurais un lien vers la version 1.4.5 stp ?

@MathieuA tu as rajouté des éléments dans le manifest entre la 1.4 et la 1.5 ? (Comme un request feature ou autre )


#375

je n’ai touché à rien. pour le lien, non je ne l’ai pas. j’avais l’apk dans mes download donc j’ai testé


#376

Hum… :thinking:
Et je suppose que oui, mais est-ce que tu as déjà essayé de télécharger à nouveau la version 1.5.2 ? Afin de vérifier qu’il n’y a pas eu une erreur lors du DL du fichier.


#377

Nope le manifest n’a pas changé @Domnis :thinking:

Si tu as désinstallé l’ancienne version avant @isokar je vois pas ce pourrait poser problème ! Comme dit @Domnis essai de re-télécharger l’apk… parce que la j’ai pas d’idée…


#378

bon je viens de retélécharger et toujours pareil. à savoir que sur la tablette sur laquelle j’ai essayé, il n’y a jamais eu d’autre version, c’était la première fois


#379

Bon, je n’ai plus qu’a attendre le déploiement de la nouvelle version :confused:


#380

Juste pour confirmer, tu as bien autorisé l’installation d’application de source inconnue dans les paramètres système ? :thinking:
(Je pense que oui, vu que sinon, tu ne pourrais pas installer le 1.4.5, mais ça vaut le coup de vérifier)


#381

oui, je viens de vérifier. J’ai également enlevé la V1.4.5 du répertoire pour éviter le parasitage.
là je sèche.
personne n’a le souci là?