[BETA] Test du module RFLink

beta

#222

Ok c’était dans paramètres>clé qu’il fallait le créer ou Paramètres utilisateurs

Mais cela ne fonctionne toujours pas.
J’ai l’impression que mon Gladys déconne avec la mémoire qui sature, je me demande si il ne faudrait pas que je recommence tous à zéro.

Merci pour votre aide;
Je quitte pour ce soir.


#223

@isokar, dans le fichier “install.js”, tu ne devrais pas plutôt écrire :

    return gladys.param.getValue(param.name)
        .then((result) => {
            // if it exists, we return it
            return result;
        })
        .catch(() => {
            // if it does not exist, we create it
            return gladys.param.setValue(param);
        });

#224

@pierre-gilles, pourrai-tu mettre le module dans le store?

Je pense que le module est prêt pour intégration


#225

C’est à toi de le poster sur le site développeur ! https://developer.gladysproject.com/fr/


#226

My bad, j’avais zappé qu’il avait déjà été posté et qu’on attendait juste des reviews :slight_smile:

Je le publie


#227

Merci encore pour ton boulot @isokar !

Je viens de publier juste sur le web, j’ai juste quelques remarques sur la dernière ligne droite =>

Le texte n’est pas dispo en français! C’est que de l’anglais! :smiley: Et le formatage est pas top.

Tu peux jeter un oeil @isokar et corriger ? Je publierais ensuite sur les instances Gladys :slight_smile:


Gladys 3.8.1 disponible en beta!
#228

Salut @isokar :slight_smile: !
Juste une question :
avec quel genre de périphérique pourrait être utilisé ton module ?


#229

@spenceur, je pense que tous les périphériques 433MHz de cette liste le sont.


#230

Et en matériel tout prêt (je voudrais pas trop me lancer dans l’arduino) pour commander ça (et pas trop cher), à brancher en usb sur le rpi ?
Tu conseilles quelque chose ?


#231

Tu peux voir sur le site de Nodo qui vend la RFLink les différents coûts selon ta configuration, et avec des shields fonctionnant sans problème. Comme le dit @isokar, il faut bien regarder le matériel compatible, et ça marche tout seul. Pour la pat, j’ai pris le kit a souder. RAS.


#232

Et du coup (je suis un peu perdu dans ce protocole), il faut prendre lequel pour être sûr d’avoir un truc archi complet ?
J’avais déjà croisé ce site mais je m’étais paumé dans les différentes configs…


#233

Ca depend surtout de ce que tu veux pouvoir connecter : du 433 MHz ? Du Milight ?


#234

Je pense du 433.
Mais c’est évolutif ou à chaque fois il faut racheter du kit ?

Edit : sur le site, ils distinguent 2 fréquences 433. Est-ce important pour le module ? Où il gère ces deux fréquences ?
J’ai un volet en RTS Somfy à la maison. Du coup ?
https://www.nodo-shop.nl/en/rflink-gateway/195-rflink-43342-somfy-rts-arduino-antenne-usb-cable.html

Ca le fait ?


#235

En fait, le “433” du RFLink est du “433,92”. Je n’ai pas de somfy à la maison, donc je ne connais pas la fréquence.
A priori, Somfy est en 433,42 (voir ici entre autre). Ca date un peu, mais je pense que c’est toujours d’actualité.
Donc, en standard, je pense que ça ne marche pas.
Sur les forum de Domoticz, ils disent que le rfxcom est compatible avec Somfy (mais pas encore avec Gladys …)
Bref, pas simple ton affaire !


#236

Salut à tous,
Ca y est je reviens sur le forum.
j’ai pas de somfy mais en cherchant dans google certains disent que c’est possible d’écouter les somfy.
@pierre-gilles je regarde ça pour les MaJ


#237

Top @isokar! Dis moi quand tu as mis à jour les textes, je validerais le module sur les instances gladys


#238

Petit bug, suite à une coupure de courant, les devices ne fonctionnent plus, à cause d’une inversion des ports ttyUSB0 et ttyUSB1 après le reboot.

Du coup ma question :
En regardant la doc du RFLInk, j’ai vu qu’il existe une commande PING (10;PING; => a “keep alive” function. Is replied with: 20;99;PONG;), ne serait-il pas possible de l’utiliser pour fixer automatiquement le bon port lors de l’init du module et donc éviter ce problème ?


#239

Why not mais compliqué car ce veux dire que à l’init il faut se connecter à un port, attendre voir si il y a un ping puis recommencer avec le port suivant. Ça peux être long. Et si tu utilise un port pour autre-chose ça va merder.


#240

Une autre piste…

J’ai remarqué que lors du démarrage de Gladys, si le port est OK, j’ai le log suivant :

0|gladys   | Received data from RFLINK 20;00;Nodo RadioFrequencyLink - RFLink Gateway V1.1 - R48;

Du coup, je me demande s’il n’y a pas moyen de mettre une variable dans le fichier “shared.js” pour détecter si le port est correctement défini à l’init et de générer une erreur si aucune donnée n’est reçue dans le temps imparti ?


#241

@isokar, tu peux m’expliquer pourquoi ça peut être long de tester les ports USB ? je ne comprends pas bien, d’autant que c’est comme ça que Domoticz fait pour détecter le RFLink.
Merci d’avance :slight_smile: