Communication gladys

Bonjour , Bonsoir

Cela fait déjà quelques temps que je suit le projet ainsi que son évolution.

Mais bordel , je suis hyper frustré cela fait peut être 7 / 8 fois que j’installe gladys en l’espace de quelques années et je n’ai jamais réussi a la faire parler ou même lui parlé.

Quelqu’un pourrait-il m’aider ? Sachant que j’ai déjà essayer de suivre les tutoriels etc , rien ne marche , ya-t-il personne ayant déjà réussi a faire fonctionner gladys qui pourrait faire un tutoriel 100 % fonctionnel ?
( J’essaye d’utiliser une ps3 eye pour communiquer )
La nouvelle installation de gladys date de ce soir et elle est update.

Merci de votre aide.

Salut @Fabzer

Pour pouvoir communiquer avec GLADYS V3 il faut installer SNIPS avec le module dans SNIPS créer par @Jean-Philippe et installer le modules SPEAK (module GLADYS) sur le forum tu trouvera les quelques paramétrages à faire et la normalement cela devrait fonctionner.

Cordialement

@phoenix3472

Salut @phoenix3472,

J’ai suivi ton conseil , j’ai commencer le tuto de @Jean-Philippe j’ai réussi a déclancher une réaction avec le hey snips etc , je suis actuellement bloqué , dans le tuto du site officiel il disent qu’il faut créer un fichier index.js que j’ai créer avec ce qu’ils ont donner ducoup en activant le fichier avec node index.js

je me retrouve avec ça :

"
[email protected]:~ $ node index.js
/home/pi/index.js:24
** console.log("[Snips Log] " + (listening ? “Start” : “Stop”) + "**
** ^^**

SyntaxError: Invalid or unexpected token
** at createScript (vm.js:80:10)**
** at Object.runInThisContext (vm.js:139:10)**
** at Module._compile (module.js:607:28)**
** at Object.Module._extensions…js (module.js:654:10)**
** at Module.load (module.js:556:32)**
** at tryModuleLoad (module.js:499:12)**
** at Function.Module._load (module.js:491:3)**
** at Function.Module.runMain (module.js:684:10)**
** at startup (bootstrap_node.js:187:16)**
** at bootstrap_node.js:608:3**
"

Et je ne sais plus quoi faire.

Merci pour l’aide !

Salut @Fabzer

Normalement tu n’a rien à créer manuellement, Mais je t’enverrai ce Week-End la marche à suivre comme moi je l’ai faite.

@phoenix3472

Salut @phoenix3472,

J’attend avec plaisir ton tuto sur mesure :stuck_out_tongue:

merci beaucoup !!

Salut @Fabzer,

Désolé quelques problèmes à régler je t’envoie mon tuto ce soir.

Merci @phoenix3472

Salut @Fabzer.

Désolé un peu de retard, Bon
TUTO :smile:

Tuto installation et téléchargement de @Pierre-Gilles :

Installation gladys 3.8.0

Etendre le système de fichier :
sudo raspi-config Puis option 7, puis Option avancé puis 1 pour étendre

Changer mot de passe
sudo raspi-config

Mettre en IP Fixe :
sudo nano /etc/dhcpcd.conf

Commentaire du paragraphe

interface eth0
static ip_address=192.168.1.4/24
static routers=192.168.1.254
static domain_name_servers=192.168.1.254 8.8.8.8

puis on reboot :
sudo reboot

Mise à Jour :
./rpi-update

sudo apt-get update
sudo apt-get upgrade

Passage en HTTPS Important :
./enable-ssl-gladys.sh

Installation de SNIPS :
sam install assistant -i Ton_Projet
Doit être inclus dans ton projet SNIPS le module GLADYS de @Jean-Philippe

sam update-assistant

Les Modules pour Gladys à installer au travers de GLADYS :
Pour installation SPEAK

Ouvrir 2 consol SSH :
1 Pour les logs Gladys Taper : pm2 logs
2 Pour les logs SNIPS Taper : sam watch

Pour Tests dialogues :smile:

Voila j’espere que cela peux d’aider

Amicalement @phoenix3472

1 Like