Configuration Modules - Problème "Le module a été configuré avec succès"


#1

Bonjour!

Je suis nouveau sur Gladys, j’ai donc une installation toute fraîche!
J’ai installé quelques modules et il m’est impossible de les configurer. Le message suivant apparaît:
“Le module a été configuré avec succès”.
J’ai essayé sur différents navigateurs et il y a toujours le même problème.


Auriez-vous une solution ? Merci!


#2

Salut,
il arrive fréquemment que certains modules n’aient pas de page de configuration, mais simplement une commande appelée directement via le bouton “Configuration” qui sait quoi faire en arrière plan, voire même aucune fonction de configuration. Dans ce cas, le bouton reste visible mais le clic n’actionne rien.

En revanche, je sais qu’une page de configuration existe pour le module “rpi-info”…

Quelle est ta version de Gladys ?


#3

Retourne aussi sur la page où tu as installé tes modules, il y a des instructions et parfois il faut renseigner des choses dans les paramètres de Gladys, d’où l’absence de cette page de configuration sur des modules


#4

Merci pour votre aide!

La version de Gladys est la 4.14.30-v7+ installée donc sur un Raspberry Pi 3

J’avais bien lu la marche à suivre pour installer le module Rpi-Info.
"4- Dans la page "Configuration du module", vous trouverez également des informations sur votre Raspberry, ainsi que des statistiques telles que "mémoire" et "réseau"."

J’ai aussi ajouté une Box comme indiqué. Sur ma page d’accueil, aucune infos ne s’affichent:


#5

Version 4 ?
Elle est en cours de dev…
La version de Gladys est affichée en bas de chaque page, vu le screenshot, tu devrais plutot être sur une 3.x.


#6

Je ne sais pas c’est marqué 4.14.30 à Release.

Sinon oui, tout en bas: Gladys 3.8.0


#7

Donc tu as Gladys en 3.8.0.
Il y a eu quelques améliorations sur la partie configuration des modules dans les versions suivantes.
Il te faut donc mettre à jour Gladys.
Pour cela, il existe un script qui s’occupe de tout : https://github.com/GladysAssistant/gladys-update/blob/master/v2/rpi-update.sh

Il te suffit de poser ce script dans le dossier /home/pi de ton RPi, de donner les droit d’exécution avec la commande chmod +x /home/pi/rpi-update.sh et de l’exécuter avec la commande /home/pi/rpi-update.sh

La mise à jour prends un certain temps, redémarre Gladys, et (normalement) tout roule :wink:


#8

J’ai téléchargé le fichier rpi-update.sh que j’ai mis dans le dossier /home/pi/ avec le logiciel WinSCP.
J’ai exécuté les commandes que tu m’as données et j’ai ces erreurs:
prob3


#9

Depuis l’image 3.8 il y a déjà ce fichier dans le pi, mais là, tu viens de l’effacer et de le corrompre avec ta manipulation, donc pour bien faire et en ligne de commande une fois connecté en ssh :

wget https://raw.githubusercontent.com/GladysAssistant/gladys-update/master/v2/rpi-update.sh

Ensuite

chmod +x rpi-update.sh

et pour finir

./rpi-update.sh
Et comme le dit @AlexTrovato, ça prend un petit moment, une fois fini tu verras une ligne avec gladys online, en vert.

ps: supprime ton fichier avant tout ça


#10

Merci mais même en faisant ta manip’ ça me fait la même erreur.
Je vais réinstaller Gladys depuis une install toute fraîche.

Au passage, ne serait-ce pas plus simple de proposer un package avec la dernière version au téléchargement ?
Ou bien avoir une mise à jour directement depuis l’interface ?

Ceci n’est pas une critique, c’est juste une remarque, qui je pense, est plutôt constructive. :slight_smile:
Je ne sais pas quel est le public visé pour Gladys mais j’ai l’impression que c’est assez ardu de s’y mettre!

Dans tous les cas, merci pour votre aide. Je vais persévérer. :wink:


#11

Je réctifie l’URL de @Jean34 afin de récupérer la version “raw” et non hTML :
wget https://raw.githubusercontent.com/GladysAssistant/gladys-update/master/v2/rpi-update.sh


#12

Ah oui, là ça marche mieux. Installation en cours.
Merci!


#13

Merci à toi (c’est rectifié sur me reply), j’ai copié bêtement le lien du github que tu proposes plus haut ^^


#14

Créer une image complète à chaque mises à jour demande un travail de titan ^^
Après c’est vrai qu’il serait peut être bien d’ajouter la petite ligne de commande qui va bien dans la page installation de Gladys ==> https://gladysassistant.com/fr/installation/ @pierre-gilles ?

Ardue, n’étant pas codeur/développeur je trouve que ça va Gladys 3 … Bon j’ai pas mal pataugé le premier mois on va dire, mais la plupart des erreurs rencontrées en ajoutant certains modules, se trouvent sur le forum donc ça va. Une ptite recherche, une bonne lecture et tu trouves ton bonheur :slight_smile:
La communauté est plutôt active, il y a toujours quelqu’un pour aider. Persévère tu as raison :wink:


#15

Oui, je comprends tout à fait.
A vrai dire je ne connaissais rien de Gladys avant ces derniers jours et en voyant l’interface user-friendly je pensais me retrouver avec une solution clé-en-main mais faut juste un peu bidouiller :wink:
En effet, en parcourant le forum je vois que la communauté est très active et que Gladys est en plein développement, c’est cool!
Merci encore à vous deux pour votre aide et à bientôt! :slight_smile:


#16

Toute la procédure de mise à jour est spécifiée dans la deuxième page, “Mettre à jour Gladys”, qui est déjà plutôt visible non? :slight_smile:

Normalement Gladys te prévient quand il y a une mise à jour à effectuer. Le soucis c’est que sur les versions d’avant (3.8.0 notamment), il y avait un petit bug sur la façon dont Gladys comparait les versions, elle ne parsait pas intelligemment les versions et faisait juste une comparaison de type:

SI nouvelleVersion > versionActuelle

Hors comme on est en 3.13, si on compare la string “3.13” a “3.8”, l’évaluateur voit que 8 > 1, donc 3.13 est une ancienne version comparé à 3.8 pour Gladys.

Ce bug a été résolu récemment mais malheureusement la 3.8 qui tourne encore a le bug… ^^

Comme dit @AlexTrovato, ce n’est pas aussi simple que ça de mettre à jour l’image, le process n’est pas automatisé.

Dans Gladys 3 ce n’est pas possible, mais ce sera le cas dans Gladys 4, la prochaine version majeure sur lequel je travaille quotidiennement depuis de nombreux mois :slight_smile: