Crash a tous les etages


#1

salut

deux jour que je cherche la solution a ce probleme (probleme surement lié a mysql )
debutant depuis un mois sur raspberry j ai enfin (avait plutot ) bien avancé ,
voici les logs merci d avance

18:9)
0|gladys   | Unhandled rejection Error: Could not connect to MySQL:
0|gladys   | Error: connect ECONNREFUSED 127.0.0.1:3306
0|gladys   |     at afterwards (/home/pi/gladys/node_modules/sails-mysql/lib/connections/spawn.js:72:13)
0|gladys   |     at /home/pi/gladys/node_modules/sails-mysql/lib/connections/spawn.js:40:7
0|gladys   |     at Handshake.onConnect [as _callback] (/home/pi/gladys/node_modules/mysql/lib/Pool.js:54:9)
0|gladys   |     at Handshake.Sequence.end (/home/pi/gladys/node_modules/mysql/lib/protocol/sequences/Sequence.js:96:24)
0|gladys   |     at Protocol.handleNetworkError (/home/pi/gladys/node_modules/mysql/lib/protocol/Protocol.js:364:14)
0|gladys   |     at PoolConnection.Connection._handleNetworkError (/home/pi/gladys/node_modules/mysql/lib/Connection.js:421:18)
0|gladys   |     at emitOne (events.js:116:13)
0|gladys   |     at Socket.emit (events.js:211:7)
0|gladys   |     at emitErrorNT (internal/streams/destroy.js:64:8)
0|gladys   |     at _combinedTickCallback (internal/process/next_tick.js:138:11)
0|gladys   |     at process._tickDomainCallback (internal/process/next_tick.js:218:9)

#2

Salut, que te réponds cette commande sudo service mysql restart

Après, il faudrait qu’on sache ce que tu as ajouté à Gladys. Pourquoi tu as cette erreur, enfin, savoir ce que tu faisais dessus quoi. Un maximum de détail nous aiderait à t’aider.


#3

salut
voici la reponse
Job for mariadb.service failed because a fatal signal was delivered to the control process.
See “systemctl status mariadb.service” and “journalctl -xe” for details.

dernier module instalé shutdown/reboot (qui n a pas marché )
sinon gladys voice
meteo
spotify
freebox
philips hue
telegram

c est la premiere fois que j arrive a avoir tout ca qui marche !!!
je voulais commencer a comprendre les messages d erreur sans tout reinstaller


#4

Et que te dit systemctl status mariadb.service

A 'linstallation ou bien l’utilisation ? message d’erreur ?


#5

jean34 Une 'installation ou bien l’utilisation? message d’erreur?

l installation qui n a jamais abouti

jean 34 Et qui te dit systemctl status mariadb.service

  [email protected]:~ $ systemctl status mariadb.service
    ● mariadb.service - MariaDB 10.1.37 database server
       Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor preset:
       Active: activating (auto-restart) (Result: signal) since Sat 2019-03-30 23:45
         Docs: man:mysqld(8)
               https://mariadb.com/kb/en/library/systemd/
      Process: 18536 ExecStart=/usr/sbin/mysqld $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_W
      Process: 18457 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VA
      Process: 18453 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_STAR
      Process: 18450 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root -d /var/r
     Main PID: 18536 (code=killed, signal=ABRT)
       Status: "InnoDB: Fatal: Ending processing because of a corrupt database page.

    Mar 30 23:45:50 gladys systemd[1]: Failed to start MariaDB 10.1.37 database serv
    Mar 30 23:45:50 gladys systemd[1]: mariadb.service: Unit entered failed state.
    Mar 30 23:45:50 gladys systemd[1]: mariadb.service: Failed with result 'signal'.
    lines 1-15/15 (END)

merci pour ton aide


#6

en continuant a chercher j en ai deduis que la carte sd devait etre pleine
j ai trouvé cette commande
df -h

ce qui donne 
[email protected]:~ $ /dev/root       3.7G  3.5G   11M 100% /
devtmpfs        460M     0  460M   0% /dev
tmpfs           464M     0  464M   0% /dev/shm
tmpfs           464M   18M  446M   4% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           464M     0  464M   0% /sys/fs/cgroup
/dev/mmcblk0p1   41M   22M   19M  54% /boot
tmpfs            93M  4.0K   93M   1% /run/user/1000
-bash: /dev/root: No such file or directory

ainsi que celle ci

[email protected]:~ $ ls -l
total 60
-rwxr-xr-x  1 pi   pi     773 Mar  3  2018 enable-ssl-gladys.sh
-rw-r--r--  1 root root   485 Mar 29 14:20 etc
drwxr-xr-x  3 pi   pi    4096 Mar 29 15:34 express-admin
-rw-r--r--  1 root root   485 Mar 29 14:19 fstab
drwxr-xr-x 15 pi   pi    4096 Mar 23 03:19 gladys
-rw-r--r--  1 pi   pi       0 Mar 29 14:48 gladys.sql
drwxr-xr-x  6 pi   pi    4096 Mar 25 07:58 gladys-voice
-rw-r--r--  1 pi   pi   11771 Mar 30 17:45 ignal=ABRT)
drwxr-xr-x  2 root root  4096 Mar 29 14:17 log
drwxr-xr-x  2 root root  4096 Mar 29 14:17 nginx
drwxr-xr-x 12 pi   pi    4096 Mar  3  2018 open-zwave
-rwxr-xr-x  1 pi   pi     119 Mar  3  2018 rpi-update.sh
-rw-r--r--  1 pi   pi    1249 Mar 30 17:45 :~ $ systemctl status mariadb.service
drwxr-xr-x  2 root root  4096 Mar 29 14:17 var

comment libere t on de l espace svppp


#7

Tu peux éditer et mettre tes lods dans la balise code stp.


#8

au risque de passer pour un benet c est ca ?


#9

4gb ta carte ? C’est plus que juste


#10

alors etant debutant sur raspberry et j ai commencer directement sur gladys !!!
@VonOx

Va falloir mettre les main dans le cambouis mais pas de raison que ça marche pas.

en vous lisant sur bon nombre de post je viens enfin de faire ceci grace a celui du clonage de carte sd
`

> **expand-rootfs** Expand root partition to fill SD card

ce qui me donne avec la commande
df -h

ceci

> [email protected]:~ $ df -h
> Filesystem      Size  Used Avail Use% Mounted on
> /dev/root        30G  3.4G   25G  13% /
> devtmpfs        460M     0  460M   0% /dev
> tmpfs           464M     0  464M   0% /dev/shm
> tmpfs           464M   12M  452M   3% /run
> tmpfs           5.0M  4.0K  5.0M   1% /run/lock
> tmpfs           464M     0  464M   0% /sys/fs/cgroup
> /dev/mmcblk0p1   41M   22M   19M  54% /boot
> tmpfs            93M  4.0K   93M   1% /run/user/1000

desolé de vous faire perdre du temp par mes betises de debutant
voici mes nouveaux logs

PM2 | App [gladys] with id [0] and pid [2659], exited with code [0] via signal [SIGINT]
PM2 | Starting execution sequence in -fork mode- for app name:gladys id:0
PM2 | App name:gladys id:0 online
0|gladys | Error: Unknown system error -117: Unknown system error -117, stat ‘/home/pi/gladys/node_modules/babel-plugin-syntax-jsx/.npmignore’
0|gladys | at Object.fs.statSync (fs.js:948:11)
0|gladys | at /home/pi/gladys/node_modules/sails/node_modules/include-all/lib/help-include-all-sync.js:197:14
0|gladys | at Array.forEach ()
0|gladys | at _recursivelyIncludeAll (/home/pi/gladys/node_modules/sails/node_modules/include-all/lib/help-include-all-sync.js:174:11)
0|gladys | at /home/pi/gladys/node_modules/sails/node_modules/include-all/lib/help-include-all-sync.js:203:33
0|gladys | at Array.forEach ()
0|gladys | at _recursivelyIncludeAll (/home/pi/gladys/node_modules/sails/node_modules/include-all/lib/help-include-all-sync.js:174:11)
0|gladys | at includeAll (/home/pi/gladys/node_modules/sails/node_modules/include-all/lib/help-include-all-sync.js:292:5)
0|gladys | at helpBuildDictionary (/home/pi/gladys/node_modules/sails/node_modules/include-all/lib/help-build-dictionary.js:43:15)
0|gladys | at Function.module.exports.optional (/home/pi/gladys/node_modules/sails/node_modules/include-all/index.js:67:10)
0|gladys | at Array.nodeModulesFolder (/home/pi/gladys/node_modules/sails/lib/hooks/moduleloader/index.js:487:22)
0|gladys | at /home/pi/gladys/node_modules/sails/node_modules/async/lib/async.js:591:38
0|gladys | at _arrayEach (/home/pi/gladys/node_modules/sails/node_modules/async/lib/async.js:85:13)
0|gladys | at Object.async.auto (/home/pi/gladys/node_modules/sails/node_modules/async/lib/async.js:552:9)
0|gladys | at Hook.loadUserHooks (/home/pi/gladys/node_modules/sails/lib/hooks/moduleloader/index.js:471:13)
0|gladys | at Hook.wrapper [as loadUserHooks] (/home/pi/gladys/node_modules/@sailshq/lodash/lib/index.js:3275:19)
0|gladys | at Hook.initialize (/home/pi/gladys/node_modules/sails/lib/hooks/userhooks/index.js:24:27)
0|gladys | at Hook.wrapper [as initialize] (/home/pi/gladys/node_modules/@sailshq/lodash/lib/index.js:3275:19)
0|gladys | at /home/pi/gladys/node_modules/sails/lib/hooks/index.js:88:16
0|gladys | at /home/pi/gladys/node_modules/sails/node_modules/async/lib/async.js:52:16
0|gladys | at /home/pi/gladys/node_modules/sails/node_modules/async/lib/async.js:548:17
0|gladys | at /home/pi/gladys/node_modules/sails/node_modules/async/lib/async.js:542:17

`