Gladys is currently unavailable - Error 502


#1

Bonjour à tous,

Je n’arrive pas à me connecter à Gladys. Il m’affiche la fameuse erreur : " Gladys is currently unavailable - Error 502"

voici le script :

pi@gladys:~/gladys $ pm2 logs gladys
[TAILING] Tailing last 15 lines for [gladys] process (change the value with --lines option)
/home/pi/.pm2/logs/gladys-out-0.log last 15 lines:
0|gladys   | Category : create : Inserting category Système
0|gladys   | Category : create : Inserting category Maison
0|gladys   | StateType : create : Inserting stateType Maison vide
0|gladys   | StateType : create : Inserting stateType Maison non vide
0|gladys   | StateType : create : Inserting stateType Nuit
0|gladys   | StateType : create : Inserting stateType Jour
0|gladys   | StateType : create : Inserting stateType Utilisateur présent
0|gladys   | StateType : create : Inserting stateType Mode
0|gladys   | StateType : create : Inserting stateType Utilisateur endormi
0|gladys   | Brain trained with success ! Added 56 sentences.
0|gladys   | Brain file saved with success
0|gladys   | Gladys is up to date !
0|gladys   | Brain trained with success ! Added 56 sentences.
0|gladys   | Brain file saved with success
0|gladys   | Gladys is up to date !

/home/pi/.pm2/logs/gladys-error-0.log last 15 lines:
0|gladys   | Hooks should be a function with one argument (`sails`)
0|gladys   | Malformed hook! (.appledouble)
0|gladys   | Hooks should be a function with one argument (`sails`)
0|gladys   | Malformed hook! (.appledouble)
0|gladys   | Hooks should be a function with one argument (`sails`)
0|gladys   | Malformed hook! (.appledouble)
0|gladys   | Hooks should be a function with one argument (`sails`)
0|gladys   | Malformed hook! (.appledouble)
0|gladys   | Hooks should be a function with one argument (`sails`)
0|gladys   | Malformed hook! (.appledouble)
0|gladys   | Hooks should be a function with one argument (`sails`)
0|gladys   | Malformed hook! (.appledouble)
0|gladys   | Hooks should be a function with one argument (`sails`)
0|gladys   | Malformed hook! (.appledouble)
0|gladys   | Hooks should be a function with one argument (`sails`)

0|gladys   | Malformed hook! (.appledouble)
0|gladys   | Hooks should be a function with one argument (`sails`)
0|gladys   | Malformed hook! (.appledouble)
0|gladys   | Hooks should be a function with one argument (`sails`)
0|gladys   | Malformed hook! (.appledouble)
0|gladys   | Hooks should be a function with one argument (`sails`)
0|gladys   | Malformed hook! (.appledouble)
0|gladys   | Hooks should be a function with one argument (`sails`)
0|gladys   | Malformed hook! (.appledouble)
0|gladys   | Hooks should be a function with one argument (`sails`)
0|gladys   | Malformed hook! (.appledouble)
0|gladys   | Hooks should be a function with one argument (`sails`)
0|gladys   | Malformed hook! (.appledouble)
0|gladys   | Hooks should be a function with one argument (`sails`)
0|gladys   | Malformed hook! (.appledouble)
0|gladys   | Hooks should be a function with one argument (`sails`)

Je n’arrive pas à trouver le problème. Des idées ?


#2

Salut @ROBIN115,
Je pense que ton problème vient du fait que tu utilises un Mac et que tu as créé (peut être sans le vouloir) un dossier “.appledouble” (comme l’indique l’erreur).

En le supprimant, ça devrait corriger le problème.


#3

Oui c’est un dossier que j’ai créé pour pouvoir accéder aux dossier du raspberry pi depuis mon ordinateur.
Je crois que je vais recommencer de zéro