Gladys offline/online en fonction présence user


#1

Bonjour,
Je me demandais s’il était possible que Gladys puisse quand même faire des actions sans réseau ?
L’idee est d’eteindre Ma box quand je ne suis pas là et de la rallumer dès que j’arrive.
J’utilse pour ça une prise pilotée rf 433.


#2

Ca doit être faisable, mais après je ne suis pas sur que la box kiffe quand tu lui fais ça ^^

Perso je clique sur un interrupteur 433MHz pour dire que je m’en vais ou que je reviens, donc si tu as une méthode similaire c’est bon, par contre tu ne pourra pas utiliser la détection de ton téléphone par le wifi…

Gladys fonctionne hors ligne sinon :slight_smile:


#3

Salut,
La box elle supporte car elle est free :slight_smile: j’utilise mon bracelet bluetooth donc ca va à ce niveau là.
En fait j’ai l’impression que comme je n’ai pas de réseau le module bluetooth ne peut pas communiquer avec gladys, est-ce bien ca ?
Voici mes logs de Gladys-bluetooth

Error while sending data to Gladys
1|gladys-b | { RequestError: Error: connect ECONNREFUSED 127.0.0.1:8080
1|gladys-b | at new RequestError (/home/pi/gladys/gladys-bluetooth/node_modules/request-promise-core/lib/errors.js:14:15)
1|gladys-b | at Request.plumbing.callback (/home/pi/gladys/gladys-bluetooth/node_modules/request-promise-core/lib/plumbing.js:87:29)
1|gladys-b | at Request.RP$callback [as _callback] (/home/pi/gladys/gladys-bluetooth/node_modules/request-promise-core/lib/plumbing.js:46:31)
1|gladys-b | at self.callback (/home/pi/gladys/gladys-bluetooth/node_modules/request/request.js:185:22)
1|gladys-b | at emitOne (events.js:116:13)
1|gladys-b | at Request.emit (events.js:211:7)
1|gladys-b | at Request.onRequestError (/home/pi/gladys/gladys-bluetooth/node_modules/request/request.js:881:8)
1|gladys-b | at emitOne (events.js:116:13)
1|gladys-b | at ClientRequest.emit (events.js:211:7)
1|gladys-b | at Socket.socketErrorListener (_http_client.js:387:9)
1|gladys-b | at emitOne (events.js:116:13)
1|gladys-b | at Socket.emit (events.js:211:7)
1|gladys-b | at emitErrorNT (internal/streams/destroy.js:64:8)
1|gladys-b | at _combinedTickCallback (internal/process/next_tick.js:138:11)
1|gladys-b | at process._tickDomainCallback (internal/process/next_tick.js:218:9)
1|gladys-b | name: ‘RequestError’,
1|gladys-b | message: ‘Error: connect ECONNREFUSED 127.0.0.1:8080’,
1|gladys-b | cause:
1|gladys-b | { Error: connect ECONNREFUSED 127.0.0.1:8080
1|gladys-b | at Object._errnoException (util.js:1022:11)
1|gladys-b | at _exceptionWithHostPort (util.js:1044:20)
1|gladys-b | at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1182:14)
1|gladys-b | code: ‘ECONNREFUSED’,
1|gladys-b | errno: ‘ECONNREFUSED’,
1|gladys-b | syscall: ‘connect’,
1|gladys-b | address: ‘127.0.0.1’,
1|gladys-b | port: 8080 },
1|gladys-b | error:
1|gladys-b | { Error: connect ECONNREFUSED 127.0.0.1:8080
1|gladys-b | at Object._errnoException (util.js:1022:11)
1|gladys-b | at _exceptionWithHostPort (util.js:1044:20)
1|gladys-b | at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1182:14)
1|gladys-b | code: ‘ECONNREFUSED’,
1|gladys-b | errno: ‘ECONNREFUSED’,
1|gladys-b | syscall: ‘connect’,
1|gladys-b | address: ‘127.0.0.1’,
1|gladys-b | port: 8080 },
1|gladys-b | options:
1|gladys-b | { method: ‘POST’,
1|gladys-b | uri: ‘http://localhost:8080/user/1/house/1/seen?token=608dbfc108890e96b7ac2af609f6d56cb5fa1f05’,
1|gladys-b | json: true,
1|gladys-b | callback: [Function: RP$callback],
1|gladys-b | transform: undefined,
1|gladys-b | simple: true,
1|gladys-b | resolveWithFullResponse: false,
1|gladys-b | transform2xxOnly: false },
1|gladys-b | response: undefined }
1|gladys-b | undefined
1|gladys-b | (node:870) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 disconnect listeners added. Use emitter.setMaxListeners() to increase limit
1|gladys-b | (node:870) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 disconnect listeners added. Use emitter.setMaxListeners() to increase limit
1|gladys-b | (node:870) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 disconnect listeners added. Use emitter.setMaxListeners() to increase limit


#4

Ah oui c’est embêtant du coup… Par contre je ne comprends pas le problème, la connexion est censée être locale et donc pas besoin du net ?? Bizarre

Quand tu es branché à la box, no problemo ?
Si tu débranche le câble ça fait le même effet ?


#5

La résolution est locale donc réseau ou pas ça doit fonctionner


#6

Je suis en wifi, peut être cela pose problème.
J’essaye demain avec un cable voir ce que ca donne.


#7

Ok VonOx, je vais creuser un peu tout ca.
hum c’est louche faut que je refouille dans les logs.


#8

Bon et bien après avoir retester ca fonctionne :slight_smile:
Je crois que ca n’était qu’une erreur dans mon script back-home ^^
Merci de votre aide en tout cas.