Gladys-voice ne démarre plus


#1

Salut ! Je rencontre depuis hier soir un problème au démarrage de gladys-voice.
Voici l’erreur dans les logs :

1|gladys-voice  | (node:1426) DeprecationWarning: grpc.load: Use the @grpc/proto-loader module with grpc.loadPackageDefinition instead
PM2             | App [gladys-voice:1] exited with code [0] via signal [SIGINT]
PM2             | App [gladys-voice:1] starting in -fork mode-
PM2             | App [gladys-voice:1] online
1|gladys-voice  | (node:1445) DeprecationWarning: grpc.load: Use the @grpc/proto-loader module with grpc.loadPackageDefinition instead
PM2             | Stopping app:gladys-voice id:1
PM2             | App [gladys-voice:1] exited with code [0] via signal [SIGINT]
PM2             | pid=1445 msg=process killed

Comme vous pouvez le voir, avec pm2 le module redemarre en boucle…
Le problème est apparu subitement hier soir alors que j’utilise le module depuis début novembre sans problèmes.
Le problème est quand même survenu après quelques manips de ma part : j’ai désinstallé Jarvis (installé deux semaines auparavant, que je n’utilisais pas) et aussi ses dépendances dont SOX. Je l’ai ensuite réinstallé quand je me suis rendu compte qu’il était nécessaire à gladys-voice.
J’ai continué mon menage avec un sudo apt autoremove, sudo apt update et sudo apt upgrade et j’ai même mis a jour le firmware du raspberry pi (je suis sur raspbian, j’ai installé gladys manuellement).

Au redémarrage une erreur est survenue, j’ai donc sauvé ma config gladys-voice, et j’ai tout réinstallé en suivant à la lettre le tuto d’install du module comme la première fois. Sauf que maintenant, impossible de démarrer le module !
J’ai essayé tout ce que j’ai pu sans succès, et je ne vois personne ayant le même problème sauf une “issue” du repo git de gladys-voice, sans réponse.

Auriez vous des solutions, des tests a faire ? Pour le module gladys-voice, j’ai sauvé la config, mais ça m’embêterai vraiment de devoir réinstaller et reconfigurer entièrement gladys, car en dehors de ce module, gladys fonctionne très bien !
J’ai songé a désinstaller npm ect. mais je ne souhaite pas casser toute mon installation…

Voila je crois avoir tout mentionné :slight_smile: j’espere que ce n’est pas trop grave docteur

EDIT : J’ai exactement le même problème si je n’execute pas la ligne npm rebuild --build-from-source grpc après npm install et j’ai un raspberry pi 3B+.


#2

Hey !

J’ai le même problème sur un RPI3b+ également ! J’avais créé une issue sur github mais pas de réponses ici:

J’ai pas de RPI3 “normal” pour tester si ça marche dessus :confused:

Si quelqu’un en a un et peut essayer, ça serait top ! :slight_smile:


#3

Ce module a besoin d’un “rafraichissement” j’ai pas eu le temps de m’y plonger donc un peu de patience :wink:


#4

J’en ai un de coté prêté par mon IUT pour un projet :smiley: Je vais essayer mais bon je pense que ça va faire pareil
Je pense pas que ça nous aide car comme je le dis, j’ai eu le module de fonctionnel pendant 3 semaines avant que ça ne déconne sur un pi 3B+

D’accord @VonOx , c’est “compliqué” d’après toi de rendre cette version fonctionnelle ? A priori c’est un souci avec des dépendances puisque ça survient après mes MAJ, mais mon message d’erreur ne m’a pas aidé a savoir.

Je viens de tester l’installation avec yarn install
Module qui boot tjr en boucle mais sans erreurs dans les logs :kissing_closed_eyes:


#5

Bonjour quelqu un peu m aider s’il vous plait 3jours que je suis dessus HELP ME !!!

/home/pi/.pm2/logs/gladys-voice-error-1.log last 15 lines:
1|gladys-v | at Object.Module._extensions…js (module.js:654:10)
1|gladys-v | at Module.load (module.js:556:32)
1|gladys-v | at tryModuleLoad (module.js:499:12)
1|gladys-v | at Function.Module._load (module.js:491:3)
1|gladys-v | Error: Cannot find module ‘/home/pi/gladys-voice/node_modules/snowb oy/lib/node/binding/Release/node-v57-linux-arm/snowboy.node’
1|gladys-v | at Function.Module._resolveFilename (module.js:538:15)
1|gladys-v | at Function.Module._load (module.js:468:25)
1|gladys-v | at Module.require (module.js:587:17)
1|gladys-v | at require (internal/module.js:11:18)
1|gladys-v | at Object. (/home/pi/gladys-voice/node_modules/snowb oy/lib/node/index.js:8:29)
1|gladys-v | at Module._compile (module.js:643:30)
1|gladys-v | at Object.Module._extensions…js (module.js:654:10)
1|gladys-v | at Module.load (module.js:556:32)
1|gladys-v | at tryModuleLoad (module.js:499:12)
1|gladys-v | at Function.Module._load (module.js:491:3)