Impossible de passer en HTTPS


#1

Attention débutant en approche

je voulait installer le module météo
cela ne fonctionne pas
j’au vu qu’il fallait passer en HTTPS en faisant /home/pi/enable-ssl-gladys.sh
Là impossible de passer en https apparemment le certificat n’est pas accepter par chrome
j’ai refait plusieurs fois la procédure mais cela ne fonctionne pas

à la fin sur putty il me marque ces lignes est ce normal?

Using new configuration in Nginx
ln: failed to create symbolic link ‘/etc/nginx/sites-enabled/gladys-ssl’: File e
rm: cannot remove ‘/etc/nginx/sites-enabled/gladys’: No such file or directory
Restarting Nginx
HTTPS is now active on Gladys ! Congrats :slight_smile:

merci de votre aide


#2

Salut @akinari

Quel version de gladys a tu ?

@phoenix3472


#3

@akinari salut :slight_smile:

tu n’aurais pas eu ce genre de message sur ton navigateur ?


#4

@phoenix3472 je vient d’installer gladys donc 3.8.0

@Jean34 oui j’ai eut ce message. Je comprend que je ne suis pas en https. Mais je ne comprend pas pourquoi vu que la commande /home/pi/enable-ssm-gladys.s’y devrait créer un certificat valide non?


#5

Pour avoir un certificat valide il faut te diriger vers let’s encrypt (il y a un tuto ici) mais il te faudra un nom de domaine qui pointe sur ton raspi ainsi qu’une ip fixe, ta Gladys sera visible de tout le monde.

Mais là cette erreur ce n’est rien, on l’a tous eu :slight_smile:
si tu ne sait pas comment l’accepter suit ce lien ==> https://www.digital-dynamics.fr/FR/tutos/ajouter-exception-site-certificat-non-fiable-google-chrome.html

Ensuite tu n’as pas mit entièrement les erreurs de ta console donc difficile de savoir…

ps: utilise les balises code quand tu insères du code où des lignes d’erreurs, merci :wink:


#6

@Jean34 J’ai utilisé ton lien je suis en https mais il est marqué en rouge barré et a coté non sécurisé
et dans la box météo je n’ai rien !!
faut il paramétrer la box météo?? Je pensez qu’en rentrant les coordonnées gps dans les paramètres du logement cela suffisait.

Du coup j’ai essayé un script:

var options = {
latitude: 44.3582,
longitude: 2.46967
};

gladys.weather.get(options)
.then((result) => {
console.log(result);
console.log(result.temperature);
console.log(result.weather);
console.log(result.humidity);
})
.catch(console.log);

résultat quand je le lance:

TypeError: Cannot read property ‘getAsync’ of null

la je séche :sweat:


#7

Ça y est enfin

J’ai trouvé mon erreur je n’ai pas créer FORECAST_UNITS une fois créer et redémarrer gladys cela fonctionne

ouf