Installation Gladys sur Raspbian


#23

Personne connait un programmeur retraiter ? Qui comprendrais toute l’importance du projet raspberry.


#24

A quelle mise à jour fais-tu allusion ?

Je pense que la plus part d’entre nous sont à jour, après il existe aussi parfois certaines limitations qui ne permettent pas de mettre à jour en 2 clics. Par exemple NodeJS, il faut faire des vérifications, des ajustement dans le code, etc…

Tu peux développer ?


#25

@LaurentR,

En complément, je viens d’upgrade mon raspi, plus à jour ya pas !

Gladys tourne comme une horloge, donc ton problème ne vient pas de là :slight_smile: c’est déjà une bonne nouvelle !


#26

Ok bon les gas c’est reparti

installation du Raspbien refaite et maj OK :

pi@raspberrypi:~ $ uname -a
Linux raspberrypi 4.9.56-v7+ #1044 SMP Fri Oct 13 15:23:13 BST 2017 armv7l GNU/Linux

ok donc on attaque l’intallation de gladys :

sudo apt-get update
sudo apt-get upgrade -y
curl -sL https://deb.nodesource.com/setup_6.x | sudo -E bash -
sudo apt-get install -y nodejs

voila donc ici c’est la commande pour installé le serveur mysql
bon je pense que cette commande n’est pas bonne car cela install mariadb …

sudo apt-get install mysql-server --fix-missing

pi@raspberrypi:~ $ sudo mysql -u root -p
Enter password: ici votre pwd
Welcome to the MariaDB monitor. Commands end with ; or \g.
Your MariaDB connection id is 2
Server version: 10.1.23-MariaDB-9+deb9u1 Raspbian 9.0
Copyright © 2000, 2017, Oracle, MariaDB Corporation Ab and others.
Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input statement.
MariaDB [(none)]>CREATE DATABASE gladys;

on vient de créer la base gladys.

bref on va continuer je pense que c’est la même chose une base SQL c’est une base SQL …

pi@raspberrypi:~ $ sudo mysql -u root -p Enter password: "ICI votre pwd" Welcome to the MariaDB monitor. Commands end with ; or \g. Your MariaDB connection id is 6 Server version: 10.1.23-MariaDB-9+deb9u1 Raspbian 9.0

Copyright © 2000, 2017, Oracle, MariaDB Corporation Ab and others.

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input statement.

MariaDB [(none)]> SHOW DATABASES;
±-------------------+
| Database |
±-------------------+
| gladys |
| information_schema |
| mysql |
| performance_schema |
±-------------------+
4 rows in set (0.00 sec)

MariaDB [(none)]>

ici le login de la base de donnée est root, mais le mdp n’est pas root !!!
mais c’est le même password que pour sudo ou le login PI.

#il faudra bien faire qlq chose pour indiqué a gladys que le password de la base de données n’est pas root …

poursuivons :
ceci est inutile avec la dernier version il est déjà présent

sudo apt-get install build-essential

on copy les fichiers de gladys dans le répertoire de gladys --> ici /home/PI/gladys :

git clone https://github.com/GladysProject/Gladys.git gladys
cd gladys

voila c’est la que sa commence a devenir drole :
on fait ces trucs la, mais je vois pas a quoi cela peut bien servir…

sudo npm install && npm install -g sails && npm install -g grunt-cli

ici deja il y a des Warning et surtout des erreur, toujours les même en faite :
npm ERR! Linux 4.9.56-v7+
npm ERR! argv “/usr/local/bin/node” “/usr/local/bin/npm” “install”
npm ERR! node v4.5.0
npm ERR! npm v2.15.9
npm ERR! code ELIFECYCLE

npm ERR! bcrypt@1.0.3 install: node-pre-gyp install --fallback-to-build
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the bcrypt@1.0.3 install script ‘node-pre-gyp install --fallback-to-build’.
npm ERR! This is most likely a problem with the bcrypt package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-pre-gyp install --fallback-to-build
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs bcrypt
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR!
npm ERR! npm owner ls bcrypt
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /home/pi/gladys/npm-debug.log

voila après ceci rien ne fonctionne .

#conclusion bas faut utilisé l’iso de gladys.
perso je n’arrive pas a installer cette S…p…E si mon PI

sans doute que j’ai pas fait les bonnes choses …
avez vous des pistes un autre tuto je sais pas, sinon bas c’est l’abandonware pour gladys lol


Error: ER_NOT_SUPPORTED_AUTH_MODE: Client does not support authentication protocol requested by server; consider upgrading MySQL client
#27

Non, c’est pas pour les noobs, c’est une machine comme un autre, après c’est sous linux voilà. Faut des connaissances.


#28

Nope Nope nope !
à l’origine il n’y a rien dedans :wink:
Tu peux y installer IoT si ça te chante :slight_smile:


#29

Ah daccord! J’avoue je ne l’ai pas encore reçu :slight_smile:


#30

ha ok pour raconter des bétise il y a du monde…
mais alors pour dépanné mon problème il y a plus personnes… :confused:


#31

On parle de Raspi, il n’y a pas de bêtise ici :slight_smile:

Concernant ton problème j’avais pas vu ton Edit de post, tu n’a mentionné personne dedans donc personne n’est averti que tu as ajouté du contenu.

Ce n’est pas parce qu’il y a des erreurs que cela ne fonctionne pas, en l’occurrence celle que tu as concernant node-pre-gyp se résout toute seule dans 90% des cas.

  • Supprime ton dossier node_modules
  • Mets à jour ta version de node avec les deux commandes suivantes :
curl -sL https://deb.nodesource.com/setup_6.x | sudo -E bash -
sudo apt-get install -y nodejs
  • Vérifie que tu es bien en 6.x avec node -v
  • Mets à jour npm avec npm install npm@latest -g
  • Puis refait la procédure à partir de la ligne cd gladys
    et laisse bien se dérouler jusqu’à la fin la commande : sudo npm install && npm install -g sails && npm install -g grunt-cli même si tu as des erreurs en cours de route

Poste ensuite si tu as toujours des problèmes le résultat de pm2 logs --lines 200


#32

BOnjour

alors voila j’ai de nouveau refait toute l’installation

voici le résultat de pm2 logs --lignes 200 :

pi@raspberrypi:~/gladys $ pm2 logs --lines 200
[TAILING] Tailing last 200 lines for [all] processes (change the value with --li nes option)
/home/pi/.pm2/pm2.log last 200 lines:
PM2 | 2017-10-18 06:33:51: ============================================== =================================
PM2 | 2017-10-18 06:33:51: — New PM2 Daemon started ------------------- ---------------------------------
PM2 | 2017-10-18 06:33:51: Time : Wed Oct 18 2017 06:33:5 1 GMT+0000 (UTC)
PM2 | 2017-10-18 06:33:51: PM2 version : 2.7.1
PM2 | 2017-10-18 06:33:51: Node.js version : 6.11.4
PM2 | 2017-10-18 06:33:51: Current arch : arm
PM2 | 2017-10-18 06:33:51: PM2 home : /home/pi/.pm2
PM2 | 2017-10-18 06:33:51: PM2 PID file : /home/pi/.pm2/pm2.pid
PM2 | 2017-10-18 06:33:51: RPC socket file : /home/pi/.pm2/rpc.sock
PM2 | 2017-10-18 06:33:51: BUS socket file : /home/pi/.pm2/pub.sock
PM2 | 2017-10-18 06:33:51: Application log path : /home/pi/.pm2/logs
PM2 | 2017-10-18 06:33:51: Process dump file : /home/pi/.pm2/dump.pm2
PM2 | 2017-10-18 06:33:51: Concurrent actions : 2
PM2 | 2017-10-18 06:33:51: SIGTERM timeout : 1600
PM2 | 2017-10-18 06:33:51: ============================================== =================================
PM2 | 2017-10-18 06:33:51: Starting execution sequence in -fork mode- for app name:gladys id:0
PM2 | 2017-10-18 06:33:51: App name:gladys id:0 online

/home/pi/.pm2/logs/gladys-out-0.log last 200 lines:
/home/pi/.pm2/logs/gladys-error-0.log last 200 lines:
0|gladys | A hook (orm) failed to load!
0|gladys | A hook (controllers) failed to load!
0|gladys | Warning: connect.session() MemoryStore is not
0|gladys | designed for a production environment, as it will leak
0|gladys | memory, and will not scale past a single process.
0|gladys | include-all attempted to require(/home/pi/gladys/api/models/User .js), but an error occurred::
0|gladys | Details:Error: Cannot find module ‘bcrypt’
0|gladys | at Function.Module._resolveFilename (module.js:469:15)
0|gladys | at Function.Module._load (module.js:417:25)
0|gladys | at Module.require (module.js:497:17)
0|gladys | at require (internal/module.js:20:19)
0|gladys | at Object. (/home/pi/gladys/api/models/User.js:17:14 )
0|gladys | at Module._compile (module.js:570:32)
0|gladys | at Object.Module._extensions…js (module.js:579:10)
0|gladys | at Module.load (module.js:487:32)
0|gladys | at tryModuleLoad (module.js:446:12)
0|gladys | at Function.Module._load (module.js:438:3)
0|gladys | at Module.require (module.js:497:17)
0|gladys | at require (internal/module.js:20:19)
0|gladys | at /home/pi/gladys/node_modules/sails/node_modules/include-all/ lib/help-include-all-sync.js:271:33
0|gladys | at Array.forEach (native)
0|gladys | at _recursivelyIncludeAll (/home/pi/gladys/node_modules/sails/n ode_modules/include-all/lib/help-include-all-sync.js:174:11)
0|gladys | at includeAll (/home/pi/gladys/node_modules/sails/node_modules/ include-all/lib/help-include-all-sync.js:292:5)
0|gladys | at helpBuildDictionary (/home/pi/gladys/node_modules/sails/node _modules/include-all/lib/help-build-dictionary.js:43:15)
0|gladys | at Function.module.exports.optional (/home/pi/gladys/node_modul es/sails/node_modules/include-all/index.js:67:10)
0|gladys | at Hook.loadModels (/home/pi/gladys/node_modules/sails/lib/hook s/moduleloader/index.js:396:18)
0|gladys | at Hook.wrapper [as loadModels] (/home/pi/gladys/node_modules/@ sailshq/lodash/lib/index.js:3250:19)
0|gladys | at Array.models (/home/pi/gladys/node_modules/sails-hook-orm/li b/load-models-and-custom-adapters.js:38:21)
0|gladys | at /home/pi/gladys/node_modules/async/lib/async.js:596:38


#33

et ca ne fonctionne toujours pas.

lorsque je vais sur http://localhost/ rien du tout !!


#34

et pour la version de node :

pi@raspberrypi:~/gladys $ node -v
v6.11.4


#35

et pour la 3eme fois , la base SQL utilise le login root #mais le password c’est autre chose !!!
ou peut on changer le pwd de la base de données pour que gladys utilise mon mots de passe et pas root/root?


#36

alors je veux bien essayer encore, comme je suis un fou mais je pense que ce truc de gladys ne fonctionne que lorsque nous installons depuis l’ISO gladys.

ce qui est dommage car le raspberry peut faire plien de choses et c’est relativement limité d’utilisé le raspberry juste pour gladys.

du moins cela ne correspond pas a mes besoin.


#37

je test aussi des fonctionnalités du forum :wink: je n’avais pas compris qu’il fallait ajouter des personnes :slight_smile:
@C4rlit0 @pierre-gilles


#38

Salut @beuzz

Alors rassures toi l’utilisation du mot de passe root pour la base sql n’est pas une faille de sécurité dans la mesure ou la base de donnée est locale donc si quelqu’un essayait de se connecter à ta base ça voudrait dire qu’il est déjà connecté à ton raspberry et qu’il a donc accès à tes données…

Il est evidemment possible de changer le mot de passe doit mais pour moins de manipulation étant données les problemes que tu as pour l’instant je te conseille de recommencer en suivant les étapes que je t’ai données et de laisser root en mot de passe pour le moment


#39

Salut @beuzz
A tout hasard as tu essayer de te connecter à Gladys non pas par http://localhost/ mais plutôt par http://IPRaspberry:8080/ ?


#40

oui mais toujours rien


#41

Permettre a la jeune génération d’apprendre, j’ai acheter un Raspberry pour apprendre à mon fils.


#42

Faut vas voir sur le site officiel