[Installation] - Module milight


#21

Salut tout le monde,

Je rencontre également un problème avec le module.

J’ai installé ce dernier, redémarré Gladys puis appuyé sur le bouton Config.

Dans mes Devices, j’ai bien 7 Devices qui se sont créés (cf image ci dessous), mais quel que soit le Device choisi, je n’arrive pas à piloter mes lampes…

J’ai essayé le binary de toutes les zones et du bridges, mais rien n’y fait, je n’arrive ni a allumer, ni à éteindre les lampes (aucun soucis avec l’application sur mon tel par contre)

Je n’ai rien dans les logs… Sauf ça à chaque fois que je clique sur un binary :

0|gladys   | Event : create : new Event with code : devicetype-new-value
0|gladys   | Scenario : Trigger : New event : devicetype-new-value
0|gladys   | Scenario : Trigger : Found 23 launchers with code devicetype-new-value.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.
0|gladys   | Scenario : Trigger : Condition not verified.

Mon installation : Lampes Milight et bridge ibox2

Milight%203


#22

Salut,
A priori, on a exactement la même installation « Mi-Light », sauf que chez moi, ça fonctionne bien.
Quand tu changes l’etat depuis la telecommande, ca le change également dans Gladys ?


#23

Salut piznel.

Je n’ai pas la télécommande, juste 2 ampoules, le bridge et mon smartphone.

Mais si je change l’état des lampes avec mon smartphone, leur état ne change pas dans Gladys.


#24

Tu as un PC windows ?
Si oui, exécute le fichier du zip que tu peux télécharger ici.
(tu peux avoir une fausse alerte de sécurité, ne pas en tenir compte).
Clic sur le bouton de scan :


(si le firewall t’alerte, autorise l’utilisation du réseau).
Tu obtiens alors un truc comme ça :

Clic alors sur le bouton “Show light Commands”. Tu auras alors une fenêtre de ce genre :

En modifiant la zone et en cliquant sur les boutons “Light ON” et “Light OFF”, déjà, tes lampes devraient s’allumer.
Si c’est le cas, du coup, peux-tu faire une copie d’écran de cette dernière fenêtre et nous l’envoyer ?


[résolu] Problème controle mi ligth
#25

Ça fonctionne avec le logiciel.


#26

Bon, alors supprime les devices milight, desinstalles le module et réinstalles le.
Je voulais voir les codes ON et OFF. Ils sont conformes à ceux du modules. (Des fois, ils sont differents)


#27

Alors, je viens de faire ceci :

Devices supprimés, module supprimé, Gladys redémarré, module réinstallé, Gladys redémarré, clic sur configuration effectué, Gladys redémarré (sait-on jamais… :wink: )

Le problème persiste… :thinking:


#28

Tu installes bien celui du store ?


#29

Oui, c’est pour ça que je ne comprends pas où ça pêche… (Le module Milight v6)


#30

Il y a un truc à essayer, qui à mon avis va marcher :slight_smile:


Gladys et Imperihome
#31

Alors, je viens de modifier le fichier, j’ai ensuite redémarré Gladys.

Et là… Je dois te remercier car je n’aurais jamais trouvé !! :+1:

Il ne me reste plus qu’à configurer tout ça pour intéragir avec mes boutons Xiaomi.

Encore merci @piznel !! :ok_hand:

Si @pierre-gilles passe par là, il y a peut être quelque chose à faire pour éviter à d’autres le même problème… :wink:


#32

De rien :blush:
C’est quel modèle d’ampoule que tu as ?
(Je pense que c’est le pb en fait)


#33

ah? Vous pouvez me faire un petit recap ? ^^ il faut modifier quelque chose dans le module milight ? :slight_smile:


#34

Salut @pierre-gilles,
Avec le protocole V6 de Milight, il y a plusieurs types de code possible (comme indiqué dans le fichier commandsV6.js.
Certains sont clairement identifiés selon le modèle de lampe, mais pour d’autre, c’est moins clair.
En particulier pour les modèles répondants soit à rgbw, soit à fullColor.
J’ai eu beau chercher, je n’ai rien vu permettant de savoir le modeles de code à utiliser.
En plus, je pense que le problème sera de plus en plus recurrent.


#35

Celui ci :

(Hein ? Quoi ? Qui a dit que je suis chiant de prendre des modèles non géré nativement par le module ?!? Si si, au fond là bas… Il me semble que… Ah ? Non ? Bon, appelez moi Jeanne alors ! :yum: :rofl: )
si%20vous


#36

Alors tout s’explique :slight_smile:
Je pense que nativement, le module ne gère pas les RGB+CCT, qui utilisent, selon le programmeur de la librairie utilisée par le module, un code différent des autres.
La question est de savoir comment les détecter à l’install du module.


#37

Ton modèle (FUT013) est compatible avec le RFLink :wink:

Voilà, je pose ça là…


#38

Là, ça dépasse de très loin mes connaissances !

Salut Pti-Nico ! C’est toujours bon à savoir !
Mais pour le coup, mon besoin avec Gladys est juste de pouvoir allumer éteindre via un bouton Xiaomi ou à distance pour simuler une présence. Et grâce à piznel, ça fonctionne parfaitement !

Pour le reste (changement de couleur & Co) c’est plus pour faire la blague en soirée ou lors d’évènements spéciaux, donc l’application de Xiaomi sera, je pense, plus adaptée :wink:


#39

Bonsoir,

je me permet de réutiliser ce topic car ma config est quasi la même pour ne pas dire la même, et j’ai le même type de problème sauf que je bloque sur la solution.

j’ai chez moi 5 ampoules milight et le pont ibox2 de connecté. J’ai installé le module milightv6 et créé via la bouton configuration les devices pour les lampes chez moi, mais impossible de les contrôler depuis le pc/gladys (changé les valeurs des devicetypes des lampes ne fait rien).

les ampoules sont celles ci : https://community.gladysassistant.com/uploads/default/optimized/2X/b/b3af43eca0c346f726286c18a3f1ea202d70b38a_1_375x500.jpg

le pont celui ci : https://community.gladysassistant.com/uploads/default/original/2X/2/2093aae130c39ababce3db3c3ba72df37b453ce5.png

Au niveau des devices créé ça donne ça :


si j’ai bien compris le device ID 15 c’est le pont, 16 17 19 20 et 21 ce sont les 5 ampoules, le 18 je sais pas ce qu’il représente. J’essaye de modifié les valeurs des devicetypes des device 16 /17/… mais aucun changement chez moi.
les devices types ressemble à ça :

J’ai testé mon installation via le logiciel LimitessLedv6 proposé par Piznel, et quand je clique sur “lightON/OFF” rien ne se passe .


Quelqu’un aurait une idée pour solutionner le porblème car là je suis perdu :confused:

merci de votre aide !


#40

Merci pour cette information essentielle, ça a résolu mon problème de commande des ampoules milight RGB+CCT Led:smile::+1:.