Nouveau module disponible pour béta testeurs : Information sur votre Raspberry


#101

Salut @piznel, juste pour savoir si tu compte mettre les codes couleurs aussi dans la box ?


#102

Salut @Jean34,

Cette box fait partie du Core de Gladys : il est donc impossible de la modifier depuis un module.

La seule solution serait de créer une box spécifique, et de la déclarer dans le core, comme je l’ai fait pour le module Livebox.
C’est faisable donc. :slight_smile:


#103

Super alors, mais il n’y a pas le feu :wink:


#104

Salut, petite question d’un noob, j’ai un petit problème, j’ai essayé d’installer ton module en passant par “Module” --> “Avancé” et dans les logs j’ai l’impression d’avoir un problème de permission mais je n’en comprends pas trop la cause…

Ci joint les logs pm2 de Gladys :

0|gladys   | Cloning module rpi-info...
0|gladys   | Installing NPM dependencies for module rpi-info
0|gladys   | Copying assets...
0|gladys   | Module installation failed! Cleaning folder
0|gladys   | (node:1161) UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejection id: 2): Error: EACCES: permission denied, mkdir './www/hooks/rpi-info'
0|gladys   | (node:1161) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

#105

Salut,

Peux-tu nous dire comment tu as installé Gladys, sa version ?


#106

J’ai installé l’image Raspbian gladys en revision 3.8.0 que j’ai mis à jour en 3.11.6.
Après j’ai aussi fait des update, upgrade et dist-upgrade sur Raspbian , le problème pourrait venir des MAJ ?

Edit 1 :
Après quelque test je me suis rendu compte que le dossier hooks dans /gladys/www avait pour propriétaire “root” et non pi comme les autres dossiers :

~/gladys/www $ ls -al
total 48
drwxr-xr-x 10 pi   pi   4096 janv. 28 00:07 .
drwxr-xr-x 14 pi   pi   4096 déc.   7 01:37 ..
drwxr-xr-x  2 pi   pi   4096 déc.   7 01:37 concat
-rw-r--r--  1 pi   pi   1150 déc.   7 01:02 favicon.ico
drwxr-xr-x  2 pi   pi   4096 déc.   7 01:37 fonts
drwxr-xr-x  2 root root 4096 janv. 28 00:07 hooks
drwxr-xr-x  2 pi   pi   4096 déc.   7 01:37 icons
drwxr-xr-x  6 pi   pi   4096 déc.   7 01:37 img
drwxr-xr-x  4 pi   pi   4096 déc.   7 01:37 js
drwxr-xr-x  2 pi   pi   4096 déc.   7 01:37 min
-rw-r--r--  1 pi   pi    272 déc.   7 01:02 robots.txt
drwxr-xr-x  5 pi   pi   4096 déc.   7 01:37 styles

Edit 2 : en fait il y a plusieurs dossiers qui ont changés de propriétaires…

Donc en faisant un bête “sudo chown -R pi:pi ~/gladys/” ça a résolu mon problème ^^

Désolé du dérangement :slight_smile:


#107

Félicitation @piznel !!! trop bien ton module !


#108

Nickel :slight_smile: je me doutais bien d’un truc comme ça, d’ou Ma demande de détails sur ton installation.


#109

salut à tous,
A la demande de @Jean34 (mais @MathieuA avait déjà eu l’idée :slight_smile: ), je vous propose la box suivante :
image
Vous voyez d’autres choses à y mettre, qui nécessite un suivi particulier ?


#110

Salut :slight_smile:

trop trop, mais trop bien :+1:

Oui tu pourrais ajouter la ram


#111

Comme avec mon VDD, la RAM en plus ça serait nickel ! :slight_smile:


#112

Ok pour la RAM alors !


#113

Et voilà :
image

Pour ceux qui maîtrisent Raspbian et leur système, merci de vérifier que ce sont les bonnes info que j’affiche :slight_smile:


#114

Autre question au passage, j’ai suivi le tuto pour installer un ssl et avoir donc le fameux https, ton module fonctionne super en https donc sur le port 443, par contre sur le port 8080 j’ai cette erreur d’affichage, c’est normal ?


#115

Tu dois avoir des erreurs en console du navigateur, je pense, genre “impossible de trouver le fichier blablabla”…
tu peux regarder ?
Tu peux aussi purger le navigateur, pour voir si le fichier de config est bien renvoyé.


#116

En purgeant le navigateur j’ai toujours les mêmes erreurs et effectivement en console du navigateur j’ai un problème de chargement de certains fichiers :


#117

Salut @piznel tu as mit tes modifs en publique ? Je viens de faire la mise à jour et je n’ai rien.


#118

Salut @Jean34,
Oui, c’est publié. Quand tu vas dans “paramètres”, “box”, tu devrais voir ça :

image


#119

Salut,

j’ai installé le module hier soir, et je n’ai pas non plus la box :cry:


#120

J’ai retravaillé depuis hier soir :wink: