Nouvelle install erreur


#1

Hello tout le monde,

Je suis en train de faire des tests de tout les coté et je fais des réinstall de gladys via la dernières images dispo. Sauf que y’a pas mal d’erreur au niveau SSL/TLS

J’ai essayer dans plusieurs sens possible, mais la première configuration de Gladys ne passe plus. Il reste à l’étape de configuration des modules, mais ne fait rien vu qu’il a un soucis TLS

You have triggered an unhandledRejection, you may have forgotten to catch a Promise rejection:
Error: certificate is not yet valid
    at TLSSocket.<anonymous> (_tls_wrap.js:1103:38)
    at emitNone (events.js:106:13)
    at TLSSocket.emit (events.js:208:7)
    at TLSSocket._finishInit (_tls_wrap.js:637:8)
    at TLSWrap.ssl.onhandshakedone (_tls_wrap.js:467:38)
Warning: connect.session() MemoryStore is not
designed for a production environment, as it will leak
memory, and will not scale past a single process.
Warning: connect.session() MemoryStore is not
designed for a production environment, as it will leak
memory, and will not scale past a single process.

=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=
WARNING: You currently have your default CORS settings configured to allow
all requests from all origins, with credentials.  This may leave your app
open to attack by third-party sites!  Consider making your `origins` setting
more restrictive or setting `credentials` to false, or else make certain that
none of your routes perform sensitive actions or reveal secure information.
=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=

Error: ENOENT: no such file or directory, chmod '/home/pi/gladys/config/../rpi-update.sh'
No brain file detectedError: ENOENT: no such file or directory, open './cache/classifier.json'
-------------------------------------------------------
:: Sun Apr 08 2018 13:24:15 GMT+0000 (UTC)
Environment : production
Port        : 8080
-------------------------------------------------------
You have triggered an unhandledRejection, you may have forgotten to catch a Promise rejection:
Error: certificate is not yet valid
    at TLSSocket.<anonymous> (_tls_wrap.js:1103:38)
    at emitNone (events.js:106:13)
    at TLSSocket.emit (events.js:208:7)
    at TLSSocket._finishInit (_tls_wrap.js:637:8)
    at TLSWrap.ssl.onhandshakedone (_tls_wrap.js:467:38)

Si on veux faire un rpi-update :

[email protected]:~ $ ./rpi-update.sh 
rm: cannot remove 'gladys-v3.12.1-Linux-armv6l.tar.gz': No such file or directory
--2018-04-08 13:30:01--  https://mirror-fr-2.gladysassistant.com/upgrades/gladys-v3.12.1-Linux-armv6l.tar.gz
Resolving mirror-fr-2.gladysassistant.com (mirror-fr-2.gladysassistant.com)... 104.24.110.63, 104.24.111.63, 2606:4700:30::6818:6e3f, ...
Connecting to mirror-fr-2.gladysassistant.com (mirror-fr-2.gladysassistant.com)|104.24.110.63|:443... connected.
ERROR: The certificate of ‘mirror-fr-2.gladysassistant.com’ is not trusted.
ERROR: The certificate of ‘mirror-fr-2.gladysassistant.com’ is not yet activated.
The certificate has not yet been activated

Quelqu’un a eu les même erreurs ?


#2

Rah j’ai honte !
L’erreur venait d’un truc con, mais qui pourra servir pour d’autre eventuellement.
Je suis un peu restrictif sur mon parefeu, et temporairement je fais tout sortir sur mon deuxième lien. Et le protocole NTP est bloquer donc… le raspberry n’était pas a l’heure, mais à l’heure de l’image !

Donc forcément des erreurs sur tous les certificats SSL !

Par contre, j’ai remarquer que j’ai des petites erreurs suiv.ant dans l’ordre ou je réinstalle les modules que j’utilise, je sais pas trop d’ou ça vient

Pour le moment je refais dans cette ordre la :

  • Réinstallation de l’image
  • Premier paramétrage de gladys
  • upgrade de gladys
  • upgrade du système

Pour les modules je vais le faire dans cet ordre :

  • milight
  • philips hue
  • yeelight

Je metterais si j’ai eu des erreurs ou autres


#3

th


#4

Ah non mais c’est ce que je me suis dis quand j’ai compris d’ou ça venait. J’ai passer de 6h à 8h :smiley:

J’ai eu un soucis sur l’adsl, du coup j’ai tout router sur la 4G, mais j’avais oublier que le parefeu est un peu restrictif par cette connexion.

Par contre, j’ai quand même eu quelques soucis avec des modules que j’avas avant, et suivant l’ordre j’ai eu des choses bizarre. Type avec le module milight, je n’avais pas le binary mais tout le reste oui