[Présentation] SergeP

Bonjour,
Je suis nouveau sur ce forum et contributeur par mon adhésion au prélèvement mensuel pour ce projet :grin:
Je ne connais pas Raspbian, ni l’étendue de ses possibilités, au même titre que GladysAssistant. J’ai décidé de supporter ce projet à la suite de la visualisation d’une vidéo sur YT de @pierre-gilles. J’ai ensuite acheté et reçu un tout nouveau Pi4, et j’y ai installé la dernière version de Raspbian en version full. J’ai tenté d’installer GladysAssistant dessus, et je dois dire que c’est ici que les choses se gâtent. Malheureusement, c’est un peu fouillis pour trouver des informations et des instructions d’installation manuelle. Celles données sur Ghithub ne permettent pas de le faire car il manque des “bouts” et elles ne sont pas à jour. Le forum n’épingle pas les posts des personnes qui ont fait des tutos à ce sujet, l’accès au slack ne permet pas de trouver des infos supplémentaires, et peu de personnes sur celui-ci semblent actives. Mais l’entraide est malgré tout présente.
Ce projet semble prometteur car j’ai cru comprendre qu’il permettait d’interfacer un nombre grandissant et de piloter des objets au sein d’une seule et même application, et de les faire agir entre eux.
Malheureusement, je crains que celui-ci ne soit promis à un avenir lointain car le père de ce projet, qui souhaite récolter des fonds pour s’y consacrer à temps plein, ce qui est louable, ne propose pas d’instructions fiables pour l’installation, et a décidé de ne plus fournir de pack d’information depuis quelques mois. Je suppose donc que des personnes novices comme moi ne peuvent pas profiter de cette application par manque d’informations claires.
Vous l’aurez compris, je suis un peu dépité par le barrage de l’installation, mais je vais continuer de supporter ce projet grâce à mes prélèvements mensuels et je vais essayer de l’installer par tous moyens à ma disposition.
En espérant que ma diatribe puisse faire prendre conscience @pierre-gilles des difficultés que je rencontre qui sont une source de découragement pour des personnes comme moi qui souhaitent se lancer, et lui permettre d’orienter des améliorations qui lui permettront d’augmenter le nombre de supporters pour ce projet.

1 Like

Quelle version de Gladys à tu essayé d’installer (V3 ou l’alpha V4) ?

La V3 en installation manuelle.

Le problème c’est que l’image Gladys V3 que Pierre Gilles à mis en place est basé sur raspbian strecht lite.

Et je ne sais pas si tu peux installer raspbian strecht sur un raspberry pi 4 ?:thinking:

Sinon, il faut installer node.js, MySQL, etc… manuellement

Je n’ai pas essayé l’image, mais l’installation manuelle sur un Raspian Buster Full.

Sauf que toi tu pars avec raspbian buster, les manipulations après sont les mêmes

Salut aide toi de ce tutoriel

Et dès que tu rencontre un soucis fait nous en part ici avec les erreurs si tu ne trouve pas sur le forum…

1 Like

Merci, mais ça ne fonctionnait pas. Le problème est résolu grâce à @damalgos.

Hello @SergeP! Merci pour ta contribution et pour tes retours :slight_smile:

Pour les difficultés que tu as rencontré, c’est un peu un concours de circonstances ^^

Tu as commencé avec le nouveau Raspberry Pi 4 qui est nouveau depuis à peine 10 jours. Il faut savoir que chaque Raspberry Pi sur le marché est différent, et non compatible avec les OS des précédentes générations. A chaque sortie d’un nouveau Raspberry Pi, il y a un travail non négligeable d’adaptation pour faire fonctionner Gladys sur la nouvelle version. La sortie d’un Raspberry Pi est une surprise autant pour toi que pour moi, je ne reçois rien en avance!

Pour l’instant ni moi, ni la plupart des contributeurs d’autres projets open-source n’ont eu le temps de sortir des build spécifique pour cette version toute nouvelle (Raspbian buster)! J’ai personnellement tout juste reçu mon Pi 4, je suis au même stade que toi :slight_smile:

Je te confirme que:

  • L’image Raspbian Gladys 3 fournit sur le site ne fonctionne pas sur Raspberry Pi 4 car elle est basée sur Stretch, compatible uniquement jusqu’au Raspberry Pi 3 B+. Il faut savoir que créer une image ça ne se fait pas comme ça en 5 minutes ^^
  • Toutes les dépendances open-source que l’on utilise n’ont pas encore fait ce travail non plus, je parle notamment de Docker par exemple qui n’a pas encore de version compatible Raspbian Buster. On doit donc attendre / trouver des solutions pour chaque dépendance système que l’on utilise.

Je comprend tout à fait les problèmes que tu as rencontré, je pense qu’il s’agit principalement d’un problème de communication, il faut que je rajoute un bandeau pour préciser que pour l’instant Gladys n’est pas compatible Raspberry Pi 4. Je communiquerais dès que le build Raspberry Pi 4 sera fonctionnel!

Il faut savoir que l’on est en pleine période de transition. Je travaille à presque temps plein depuis 6 mois sur Gladys 4, et pour l’instant on en est au stade alpha, c’est à dire une version destiné à un public avancé, et non pour le consommateur final.

La documentation est donc entrain de progressivement migrer de celle de la v3 à la nouvelle documentation pour Gladys v4. Je travaille d’arrache pied pour maintenir une doc v3 pour ceux qui tournent encore sur la v3, et remplacer progressivement le site à la v4, tout en essayant de garder tout ça clair pour ceux qui arrivent sur le projet: ce n’est pas simple.

:warning:Les tutoriels que tu as essayé d’appliquer ont été écris sur Raspbian Stretch eux aussi, et ne fonctionnent pas non plus pour Raspberry Pi 4. C’est tout nouveau pour nous aussi!

J’espère que tu comprends toutes les implications et que tu feras preuve d’indulgence avec moi sur ces issues, je fais de mon mieux :slight_smile: Une version simple à installer est bien entendu prévue pour Raspberry Pi 4.

N’hésite pas si tu as d’autres questions, et encore merci pour ton soutien :pray:

Merci pour ce retour et ton travail.
C’est effectivement un souci de documentation et de communication, notamment de centralisation de doc et de communication sur l’avancement.
Ce doit être mon côté déformation professionnelle. (Chef de Projet)
Avec @damalgos, nous avons un peu avancé sur le sujet. De mon côté, ce n’est pas encore fonctionnel, mais grâce à son travail et son aide, j’ai bon espoir.

1 Like

@SergeP Je te confirme que j’ai ajouté un message au dessus du lien de téléchargement de l’image Raspbian Gladys!