Problème entre Gladys et GVoice


#1

Bonjour,
J’ai bien suivi le tuto de @C4rlit0 pour installer Gladys Voice, cependant lorsque je demande “quel temps fait il” il ne comprend pas alors qu’elle est bien dans mon Brain gladys


J’ai bien sûr verifier mes config de gladys voice
Si quelqu’un aurait une idée ? Merci ! :slight_smile:


#2

Tu peux lancer un re-entrainement du brain? (Dans l’onglet du brain)

C’est peut-être juste ça.


#3

Maintenant elĺe me dis qu’une erreur est survenue je suppose donc que c’est la commande weather.get-weather qui ne fonctionne pas, à vrai dire je sais pas encore où sont modifiables ces commandes


#4

Pour calculer la météo, Gladys a besoin de plusieurs choses:

  • Ta position
  • Un module de météo

Est-ce que Gladys a un moyen de savoir où tu es?

1/ Est-ce que ta maison a la latitude + longitude de précisé?
2/ Sinon, est-ce que Gladys sait ou tu es toi? (Owntracks/ ou géoloc via le navigateur – fonctionne uniquement en HTTPS

3/ Est-ce que tu as configuré un module de météo? (forecast)


#5

D’accord celà répond à mes questions, merci pierre gilles !


#6

Ce serait top aussi que tu colles tes logs entre les balises “code” de l’éditeur, où bien de faire des captures d’écrans appropriées histoire d’éviter les torticolis :crazy_face::joy:


#7

C’est vrai j’y pense pas assez :slight_smile:


#9

1/ Ne publie pas ta clé d’API sur internet en public :sweat_smile:

2/ Sans logs, ça va être dur de t’aider. Si tu pouvais faire un copier coller ça serait top !

3/ Quelle version de Gladys es-tu? ( tu devrais être en v3.13.0, si non mets à jour!)


#10

Effectivement je suis en gladys 3.8 je pensais avoir la dernière comme je les installer il y a 1 semaine problème lors de la commande pour update:

Je peux juste glisser mon dossier gladys (/root) dans le /home/pi ?


#11

Tu ne dois pas être en root pour effectuer ces commandes mais en utilisateur pi!


#12

J’ai envoyé le fichier gladys sur /home/pi/ mais cela me dis que la supression de /tmp/gladys_hooks est impossible car je n’ait pas la permission et si je met sudo avant celà à marcher


#13

Maintenant voici ce qu’il y a:
page de connexion


et dans les pm2 logs:
1|gladys | Warning: connect.session() MemoryStore is not 1|gladys | designed for a production environment, as it will leak 1|gladys | memory, and will not scale past a single process. 1|gladys | Warning: connect.session() MemoryStore is not 1|gladys | designed for a production environment, as it will leak 1|gladys | memory, and will not scale past a single process. 1|gladys | 1|gladys | =*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*= 1|gladys | WARNING: You currently have your default CORS settings configured to allow 1|gladys | all requests from all origins, with credentials. This may leave your app 1|gladys | open to attack by third-party sites! Consider making youroriginssetting 1|gladys | more restrictive or settingcredentialsto false, or else make certain that 1|gladys | none of your routes perform sensitive actions or reveal secure information. 1|gladys | =*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*= 1|gladys |

On me conseille de tout reprendre à zéro ?


#14

Je comprend avoir fais n’importe quoi depuis le début je vais donc recommencer et tout exécuter en pi, juste une question si un accès m’ait refusé, est-ce que utiliser sudo est “grave” ?


#15

J’ai tout remis à zéro et celà fonctionne


#16

Faut déjà comprendre pourquoi, pas de raison à priori d’avoir un accès refusé dans home/pi ( sauf si on a tous cassé)

Pour remettre les bon droits:

sudo chown -R pi:pi /home/pi
Sudo chmod -R u+rwX,go+rX-w /home/pi

#17

Comme le dit plus haut Pierre Gilles il ne faut surtout pas exécuter l’update de Gladys avec sudo, mais rien ne t’empêche d’exécuter une commande avec sudo, d’ailleurs pour mettre ta machine à jour tu es obligé de faire avec sudo, exemple: sudo apt update && sudo apt upgrade -y :wink: pour installer certains paquets qui feront fonctionner les modules Gladys…


#18

@VonOx étant débutant j’ai touché énormément et j’ai dû tout casser oui, j’ai tout réinstallé proprement je n’ait qu’un petit bug car tout marche bien (j’enverrai ça demain)

@Jean34 C’est vrai, merci !