Probleme installation playstation eye


#1

Bonjour,

Je viens de recevoir ma playstation eye que je voulais installer en micro. J’ai voulu suivre le super tuto de Carlito mais je galère dès le début. Il ne veut pas installer la dépendance suivante visiblement

pi@gladys:~ $ sudo apt-get install gstreamer0.10-pulseaudio libao4 libasound2-pl ugins libgconfmm-2.6-1c2 libglademm-2.4-1c2a libpulse-dev libpulse-mainloop-glib 0 libpulse-mainloop-glib0-dbg libpulse0 libpulse0-dbg libsox-fmt-pulse paman pap refs pavucontrol pavumeter pulseaudio pulseaudio-dbg pulseaudio-esound-compat pu lseaudio-esound-compat-dbg pulseaudio-module-bluetooth pulseaudio-module-gconf p ulseaudio-module-jack pulseaudio-module-lirc pulseaudio-module-lirc-dbg pulseaud io-module-x11 pulseaudio-module-zeroconf pulseaudio-module-zeroconf-dbg pulseaud io-utils oss-compat -y
Lecture des listes de paquets… Fait
Construction de l’arbre des d▒pendances
Lecture des informations d’▒tat… Fait
Aucune version du paquet libgconfmm-2.6-1c2 n’est disponible, mais il existe dan s la base
de donn▒es. Cela signifie en g▒n▒ral que le paquet est manquant, qu’il est deven u obsol▒te
ou qu’il n’est disponible que sur une autre source
Cependant les paquets suivants le remplacent▒:
libgconfmm-2.6-1v5

Aucune version du paquet libglademm-2.4-1c2a n’est disponible, mais il existe da ns la base
de donn▒es. Cela signifie en g▒n▒ral que le paquet est manquant, qu’il est deven u obsol▒te
ou qu’il n’est disponible que sur une autre source
Cependant les paquets suivants le remplacent▒:
libglademm-2.4-1v5

Aucune version du paquet pulseaudio-module-x11 n’est disponible, mais il existe dans la base
de donn▒es. Cela signifie en g▒n▒ral que le paquet est manquant, qu’il est deven u obsol▒te
ou qu’il n’est disponible que sur une autre source
Cependant les paquets suivants le remplacent▒:
pulseaudio

E: Le paquet ▒▒libgconfmm-2.6-1c2▒▒ n’a pas de version susceptible d’▒tre instal l▒e
E: Le paquet ▒▒libglademm-2.4-1c2a▒▒ n’a pas de version susceptible d’▒tre insta ll▒e
E: Impossible de trouver le paquet libpulse-mainloop-glib0-dbg
E: Impossible de trouver le paquet libpulse0-dbg
E: Impossible de trouver le paquet pulseaudio-dbg
E: Impossible de trouver le paquet pulseaudio-esound-compat-dbg
E: Impossible de trouver le paquet pulseaudio-module-lirc-dbg
E: Le paquet ▒▒pulseaudio-module-x11▒▒ n’a pas de version susceptible d’▒tre ins tall▒e
E: Impossible de trouver le paquet pulseaudio-module-zeroconf-dbg

Merci de votre aide


#2

Salut @jerome :slight_smile:

Ton problème étant quand même assez simple, tu aurais pu tester par toi même :wink: mais bon je comprends aussi que tu ne veule pas tout casser :stuck_out_tongue:
N’ayant pas de grandes connaissances je vais te dire ça avec mes mots ^^

Comme tu l’as dit plus haut il ne veut pas installer certaines dépendances car elles ne sont plus maintenues où ont changées de version, mais là réponse de ta ligne de commande te donne toutes les infos nécessaires :slight_smile:

     Aucune version du paquet libgconfmm-2.6-1c2 n’est disponible, mais il existe dan s la base
de donn▒es. Cela signifie en g▒n▒ral que le paquet est manquant, qu’il est deven u obsol▒te
ou qu’il n’est disponible que sur une autre source
Cependant les paquets suivants le remplacent▒:
libgconfmm-2.6-1v5

Donc tu modifies libgconfmm-2.6-1c2 par libgconfmm-2.6-1v5.

Aucune version du paquet libglademm-2.4-1c2a n’est disponible, mais il existe da ns la base
de donn▒es. Cela signifie en g▒n▒ral que le paquet est manquant, qu’il est deven u obsol▒te
ou qu’il n’est disponible que sur une autre source
Cependant les paquets suivants le remplacent▒:
libglademm-2.4-1v5

Idem : tu modifies libglademm-2.4-1c2a par libglademm-2.4-1v5
Ensuite,

Aucune version du paquet pulseaudio-module-x11 n’est disponible, mais il existe dans la base
de donn▒es. Cela signifie en g▒n▒ral que le paquet est manquant, qu’il est deven u obsol▒te
ou qu’il n’est disponible que sur une autre source
Cependant les paquets suivants le remplacent▒:
pulseaudio

Vu que le paquet pulseaudio est déjà dans la commande d’installation tu supprime simplement pulseaudio-module-x11 de ta commande ( avec l’espace :wink: ).

Pour finir, tu supprimes de la ligne de commande d’installation les paquets suivants:

libpulse-mainloop-glib0-dbg
libpulse0-dbg
pulseaudio-dbg
pulseaudio-esound-compat-dbg
pulseaudio-module-lirc-dbg
pulseaudio-module-x11
pulseaudio-module-zeroconf-dbg

Et ça devrait rouler :wink:

Faudrait voir si @C4rlit0 pourrait modifier son tuto en conséquence :slight_smile:

PS: passe Putty en utf-8 pour éviter d’avoir des sigles bizarres sur tes accents :wink:


#3

Merci pour la réponse @Jean34 je suis au stade du débutant, et dernier de la classe en plus :grin:. Avec la réponse c’est vrai que c’est simple. Je vais tester cela rapidement. Et la prochaine fois j’essaierai de réfléchir un petit peu plus.


#4

Ahhh c’était toi au fond, au radiateur de gauche ??? Moi c’était celui de droite :stuck_out_tongue: .
T’inquiète on est tous passé par là, il n’y avait rien de méchant dans mes propos et t’en mieux que tu l’es prit ainsi :wink:

Tiens nous au jus de ton avancement.


#5

Bonjour à tous,

Bon les résultats ne sont pas concluant @Jean34, je galère encore. Je précise avant que je suis bien en UTF-8 sous petit malgré les symboles.
Mon problème : Je n’entends rien après la phase de test. le problème vient certainement du fichier .asoundrc mais je ne vois pas ou.

Je pense que le micro est bien reconnu :

**Bus 001 Device 004: ID 1415:2000 Nam Tai E&E Products Ltd. or OmniVision Technologies, Inc. Sony Playstation Eye**
Bus 001 Device 005: ID 0424:7800 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

 Liste des P▒riph▒riques Mat▒riels CAPTURE ****
carte 1: **CameraB409241 [USB Camera-B4.09.24.1], p▒riph▒rique 0: USB Audio [USB Audio]**
  Sous-p▒riph▒riques: 1/1
  Sous-p▒riph▒rique #0: subdevice #0

Fichier :

pcm.array {
    type plug
    slave.pcm "hw:1,0"
}

pcm.array_gain {
    type softvol
    slave {
        pcm "array"
    }
    control {
        name "Mic Gain"
        count 2
    }
    min_dB -10.0
    max_dB 5.0
}

pcm.cap {
    type plug
    slave {
        pcm "array_gain"
        channels 4
    }
    route_policy sum
}

pcm.!default {
    type asym

    ### Playback object ###
    playback.pcm {
        type plug
        slave.pcm "hw:0,1"
    }

    ### Capture object ###
    capture.pcm {
        type plug
        slave.pcm "cap"
    }
}

ctl.!default {
    type hw
    card 0
}

ctl.cap {
    type hw
    card 1
}

Voila j’espère que vous aurez les infos nécessaires pour m’aider.

Si il existe un livre GLADYS pour les nuls je suis preneur @pierre-gilles (le starter pack m’a déjà bien aidé pourtant)

Merci


#6

Bon j’ai réglé mon problème sous putty pour les caractères.

pi@gladys:~ $ lsusb
Bus 001 Device 004: ID 1415:2000 Nam Tai E&E Products Ltd. or OmniVision Technologies, Inc. Sony Playstation Eye
Bus 001 Device 005: ID 0424:7800 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
pi@gladys:~ $ arecord -l
**** Liste des Périphériques Matériels CAPTURE ****
carte 1: CameraB409241 [USB Camera-B4.09.24.1], périphérique 0: USB Audio [USB Audio]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0

Sinon Je pense que mon souci vient du fichier .asoundrc car dans alsamixer je ne vois pas ma camera ps3 eye et quand je fais un F6 il me réponds :

les commandes de mixage ne peuvent pas être chargés: Argument invalide

@Pti_Nico ou @C4rlit0 malgré tout vos conseils sur le tuto je galère toujours. Auriez- vous une idée ?

Merci :slight_smile: