Problème lancement docker [résolu]

Bonjour à tous,

Tout d’abord merci à Pierre-Gilles et à tout ceux qui participe à ce projet dont je suis les évolution depuis le début.

Je cherche à installer la v4 via docker comme indiquer dans les tutos.
Je viens d’installer une raspbian buster pour le besoin puis installer docker.

Mais quand je lance la commande suivante ça plante

[email protected]:~ $ docker run -d
-v /var/run/docker.sock:/var/run/docker.sock
-v /var/lib/gladysassistant:/var/lib/gladysassistant \

–privileged
-p 80:1443
–network=host
–name gladys
-e NODE_ENV=production
-e TZ=Europe/Paris
-e SQLITE_FILE_PATH=/var/lib/gladysassistant/gladys-production.db
-v /var/run/docker.sock:/var/run/docker.sock
-v /var/lib/gladysassistant:/var/lib/gladysassistant
-v /dev:/dev
gladysassistant/gladys:4.0.0-alpha-arm
docker: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?.
See ‘docker run --help’.
[email protected]:~ $

Je débute avec Docker c’est l’occasion pour moi de m’y mettre :slight_smile:

Docker ne tourne pas chez toi :slight_smile: Il y a un problème lors de ton installation!

Sur quel version du Raspberry Pi tourne tu? Comment as tu installé docker?

C’est un RPI 3 j’ai suivi le tuto de SergeP -> [TUTO] Installation Buster Full et Gladys V4 sur Raspberry PI4 sans écran ni clavier

Voici les commandes que j’ai lancé pour docker :

> sudo apt install libltdl7
> sudo wget https://download.docker.com/linux/debian/dists/buster/pool/stable/armhf/docker-ce-cli_18.09.7~3-0~debian-buster_armhf.deb
> sudo wget https://download.docker.com/linux/debian/dists/buster/pool/stable/armhf/docker-ce_18.09.7~3-0~debian-buster_armhf.deb
> sudo wget https://download.docker.com/linux/debian/dists/buster/pool/stable/armhf/containerd.io_1.2.6-3_armhf.deb
> sudo dpkg -i containerd.io_1.2.6-3_armhf.deb
> sudo dpkg -i docker-ce-cli_18.09.7~3-0~debian-buster_armhf.deb
> sudo dpkg -i docker-ce-cli_18.09.7~3-0~debian-buster_armhf.deb

Je vais essayer d’installer en manuel sans docker.

Je te conseille vivement de passer par docker! Tu n’es pas loin, c’est juste le docker dameon qui n’est pas lancé! Tape l’erreur sur internet tu devrais trouver des solutions :slight_smile:

Alors j’ai persévéré et en fait il semble y avoir des petits soucis avec la raspbian buster (surement trop jeune :stuck_out_tongue: je suis pas expert)

J’ai utilisé les packages de Stretch et c’est ok pour docker

wget https://download.docker.com/linux/debian/dists/buster/pool/stable/armhf/containerd.io_1.2.6-3_armhf.deb
wget https://download.docker.com/linux/debian/dists/buster/pool/stable/armhf/docker-ce-cli_18.09.7~3-0~debian-buster_armhf.deb
wget https://download.docker.com/linux/debian/dists/buster/pool/stable/armhf/docker-ce_18.09.7~3-0~debian-buster_armhf.deb

dpkg -i containerd.io_1.2.6-3_armhf.deb
dpkg -i docker-ce-cli_18.09.7~3-0~debian-buster_armhf.deb
dpkg -i docker-ce_18.09.7~3-0~debian-buster_armhf.deb
sudo usermod pi -aG docker

Raspbian buster venant de sortir, Docker n’a pas encore adapté ces paquets, donc effectivement c’est le bazar :slight_smile: Mais c’est pareil pour tous les programmes, il faut donc attendre un peu que les mise à jours arrivent…

Cool! :slight_smile:

Salut,

J’ai eu le même soucis, problème résolu en passant sur Rasbian Stretch.
Du coup docker bien installé, Gladys aussi, enfin je pense car je n’arrive pas à accéder à Gladys via son adresse IP, j’ai tenté en http, https rien. pouvez vous m’aider :pleading_face:

[email protected]:~ $ docker info
Client:
 Debug Mode: false

Server:
 Containers: 1
  Running: 1
  Paused: 0
  Stopped: 0
 Images: 1
 Server Version: 19.03.1
 Storage Driver: overlay2
  Backing Filesystem: extfs
  Supports d_type: true
  Native Overlay Diff: true
 Logging Driver: json-file
 Cgroup Driver: cgroupfs
 Plugins:
  Volume: local
  Network: bridge host ipvlan macvlan null overlay
  Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
 Swarm: inactive
 Runtimes: runc
 Default Runtime: runc
 Init Binary: docker-init
 containerd version: 894b81a4b802e4eb2a91d1ce216b8817763c29fb
 runc version: 425e105d5a03fabd737a126ad93d62a9eeede87f
 init version: fec3683
 Security Options:
  seccomp
   Profile: default
 Kernel Version: 4.19.58-v7+
 Operating System: Raspbian GNU/Linux 10 (buster)
 OSType: linux
 Architecture: armv7l
 CPUs: 4
 Total Memory: 926.1MiB
 Name: raspberrypi
 ID: 3T3D:UPDL:KEDP:274Z:XOJJ:2HAF:Q23L:32YC:HPUQ:ZABX:IYUY:RSCW
 Docker Root Dir: /var/lib/docker
 Debug Mode: false
 Registry: https://index.docker.io/v1/
 Labels:
 Experimental: false
 Insecure Registries:
  127.0.0.0/8
 Live Restore Enabled: false

WARNING: No swap limit support
WARNING: No cpu cfs quota support
WARNING: No cpu cfs period support

Je n’ai pas réussi à résoudre les warning :confused:

[email protected]:~ $ docker ps -a
CONTAINER ID        IMAGE                                    COMMAND                  CREATED             STATUS              PORTS               NAMES
f9620d9ab911        gladysassistant/gladys:4.0.0-alpha-arm   "docker-entrypoint.s…"   2 days ago          Up 2 days                               gladys
[email protected]:~ $

Problème résolu. j’ai install le docker portnair pour essayer d’y voir plus claire.

j’ai réussi à accéder à Gladys avec @IP:1443 en http.