Problème reboot après installation speak


#1

Bonsoir a tous, de retour après quelques jours d’absences et de nouveau sur Gladys. je rencontre un problème avec le module speak.
apres l’installation de celui-ci avec succès, tout ce passe bien dans les logs jusqu’au moment ou je pose une question a gladys en vocale : ex quelle est la météo? gladys me repond bien par le chat mais pas par le hp et elle reboot quelques instants plus tard. elle reboot uniquement quand je lui parle.
voila ce qu’il se passe dans les logs lorsque je lui parle:

1|gladys-v | [{“message”:{“text”:“quelle heure est-il”,“label”:“get-time”,“scope”:{“deviceTypes”:[],“rooms”:[],“houses”:[],“times”:[],“replacedText”:“quelle heure est-il”,“language”:“fr”,“user”:{“firstname”:“alexis”,“lastname”:“morsilli”,“email”:“[email protected]”,“birthdate”:“1986-04-21T00:00:00.000Z”,“gender”:0,“language”:“fr-FR”,“password”:"$2a$10$3jSRzUCobhnMf3UpgzYiq.qM.40pt.PTOXQZQKZtQkYIHS1GUdSJS",“assistantName”:“Gladys”,“preparationTimeAfterWakeUp”:null,“role”:“admin”,“id”:1,“createdAt”:“2017-09-14T17:27:04.000Z”,“updatedAt”:“2017-09-14T17:27:04.000Z”},“label”:“get-time”,“conversationMessages”:[]}},“response”:{“label”:“say-time”,“scope”:{"%TIME%":“20:19”,"%USER_FIRSTNAME%":“alexis”,"%USER_LASTNAME%":“morsilli”,"%USER_EMAIL%":“[email protected]”},“text”:“Voici l’heure : 20:19 !”}}]
0|gladys | […/deps/mpg123/src/output/alsa.c:165] error: cannot open device default
0|gladys | Error: open() failed: -1
0|gladys | at Speaker._open (/home/pi/gladys/api/hooks/speak/node_modules/speaker/index.js:168:11)
0|gladys | at Speaker._write (/home/pi/gladys/api/hooks/speak/node_modules/speaker/index.js:242:21)
0|gladys | at doWrite (/home/pi/gladys/api/hooks/speak/node_modules/speaker/node_modules/readable-stream/lib/_stream_writable.js:406:64)
0|gladys | at writeOrBuffer (/home/pi/gladys/api/hooks/speak/node_modules/speaker/node_modules/readable-stream/lib/_stream_writable.js:395:5)
0|gladys | at Speaker.Writable.write (/home/pi/gladys/api/hooks/speak/node_modules/speaker/node_modules/readable-stream/lib/_stream_writable.js:322:11)
0|gladys | at Decoder.ondata (/home/pi/gladys/api/hooks/speak/node_modules/readable-stream/lib/_stream_readable.js:572:20)
0|gladys | at emitOne (events.js:96:13)
0|gladys | at Decoder.emit (events.js:188:7)
0|gladys | at readableAddChunk (/home/pi/gladys/api/hooks/speak/node_modules/readable-stream/lib/_stream_readable.js:195:16)
0|gladys | at Decoder.Readable.push (/home/pi/gladys/api/hooks/speak/node_modules/readable-stream/lib/_stream_readable.js:162:10)
0|gladys | at Decoder.Transform.push (/home/pi/gladys/api/hooks/speak/node_modules/readable-stream/lib/stream_transform.js:145:32)
0|gladys | at handleRead (/home/pi/gladys/api/hooks/speak/node_modules/lame/lib/decoder.js:134:12)
0|gladys | at afterRead (/home/pi/gladys/api/hooks/speak/node_modules/lame/lib/decoder.js:121:7)
PM2 | App [gladys] with id [0] and pid [2844], exited with code [255] via signal [SIGINT]
PM2 | Starting execution sequence in -fork mode- for app name:gladys id:0
PM2 | App name:gladys id:0 online
0|gladys | undefined
0|gladys | Warning: connect.session() MemoryStore is not
0|gladys | designed for a production environment, as it will leak
0|gladys | memory, and will not scale past a single process.
0|gladys | Warning: connect.session() MemoryStore is not
0|gladys | designed for a production environment, as it will leak
0|gladys | memory, and will not scale past a single process.
0|gladys | =======================================
0|gladys | WARNING: You currently have your default CORS settings configured to allow
0|gladys | all requests from all origins, with credentials. This may leave your app
0|gladys | open to attack by third-party sites! Consider making your origins setting
0|gladys | more restrictive or setting credentials to false, or else make certain that
0|gladys | none of your routes perform sensitive actions or reveal secure information.
0|gladys | =======================================
0|gladys | Gladys version : 3.6.2
0|gladys | Gladys brain loaded with success !
0|gladys | Scheduled sunrise to 9/19/2017, 5:24:18 AM.
0|gladys | Scheduled sunset to 9/19/2017, 5:45:31 PM.
0|gladys | .-…-.
0|gladys | Sails <| .-…-.
0|gladys | v0.12.13 |
0|gladys | /|.
0|gladys | / ||
0|gladys | ,’ |’
0|gladys | .-’.-==|/
–’
0|gladys | --'-------' 0|gladys | __---___--___---___--___---___--___ 0|gladys | ____---___--___---___--___---___--___-__ 0|gladys | Server lifted in/home/pi/gladys`
0|gladys | To see your app, visit http://localhost:8080
0|gladys | To shut down Sails, press + C at any time.
0|gladys | -------------------------------------------------------
0|gladys | :: Tue Sep 19 2017 20:19:58 GMT+0000 (UTC)
0|gladys | Environment : production
0|gladys | Port : 8080
0|gladys | -------------------------------------------------------
0|gladys | Gladys is up to date !

j’ai essayé de desinstaller le module et de le reinstaller mais le problème persiste. A noter que quand je desinstalle gladys ne reboot pas elle me repond normalement dans le chat. c’est uniquement lorsque le module speak est installé …
Merci pour votre aide


#2

Effectivement il y a un problème avec le module speak chez toi. C’est du à ta configuration de lecture de l’audio sur ton Raspberry Pi visiblement :slight_smile:

Je te conseille d’aller jeter un oeil à ce thread => [TUTORIEL] - Gladys et la reconnaissance vocale

Même si il parle de reconnaissance vocale il y a toute les configurations pour la gestion de l’audio!