Recherche de testeurs (Android v1.0-Alpha01)

android

#82

Amis du soir, bonsoir…
Retour des tests sur la partie HTTPS:
Après configuration de l IP publique, bon ben ça marche po… :confused:
J’ai tenté en laissant HTTPS activé, puis en désactivant et en mettant le port manuellement mais rien n’y fait…
L’appli plante.
Si je tente de la redémarrer, j’ai l’écran blanc avec ce splendide, que dis-je, ce magnifique logo!!!
Puis écran noir et Re plantage…
Une idée @MathieuA ???


#83

C’est effectivement l’explication que tu as donné. Pas super logique effectivement!


#84

Bravo @MathieuA j’en suis également !


#85

Hello,

J’ai eu un petit mauvais retour expérience utilisateur.
Dans la vue discussion, lorsque je clique sur le bouton envoyer il n’y a pas de “visuel” donnant l’impression d’appuyer ET le message mets parfois jusqu’à 10 secondes à passer de l’entrée de texte à la conversation.
Comme il n’y avait pas de "visuel de clic, les premières fois j’ai cru que j’avais cliqué à côté du bouton, je spammais donc le BOUTON 3-4 fois. Et du coup le message apparaît 3-4 fois dans la conversation. (Gladys le reçois aussi 3-4 fois et répond 3-4 fois ^^)

Je ne sais pas si ça vient d’une lenteur sur mon téléphone ou de l’application donc je partage, si ça vient de mon téléphone, my bad pour ce post inutile ^^

L’application reste quand même génial :heart_eyes:


#86

Hello !

Alors ça ça m’est arrivé une fois ahah
En faite c’est quand Gladys met du temps a répondre, ça peut venir du raspberry qui est un peu lent comme du réseau en soit donc c’est assez chiant.

Qui plus est j’ai fais en sorte que le message n’apparaisse dans la liste uniquement quand Gladys atteste de la bonne réception de celui-ci, ce qui crée ce comportement en cas de lenteur réseau ou autre ^^

Mais effectivement il faudrait placer un petit retour visuel quelque part histoire de le faire comprendre à l’user quand l’envoi un est peu long !


#87

Alors, je viens de voir un truc : Depuis que je teste l’application, ma timeline est polluée par des “Nouvelles valeurs DeviceType”… :thinking: Et Gladys est ralentie… :face_with_raised_eyebrow:

Une idée du pourquoi du comment @MathieuA ?

Note importante : Je n’ai absolument rien touché à Gladys. la dernière fois que j’ai modifié quelque chose dans Gladys remonte à avant le début du test.

Ex de ma timeline :

Je vais re-re-jeter un oeil, mais après reboot du téléphone (mise à jour de sécurité hebdomadaire) , la timeline est désormais en temps réel… Mais en revanche, le problème ci dessus est apparu…


#88

Ça ça n’a rien à voir avec l’app ^^
Peut-être que tu le remarque que maintenant mais c’était déjà comme ça avant. C’est Gladys qui déclenche ces événements quand un devicetype change d’état. Le comportement est un peu bizarre car si tu refresh la page ces événements devraient disparaître (comme les événements Alarm aussi) mais ils sont quand même affiché quand ils sont déclenché et que tu es sur cette vue (à cause des websockets) :slightly_smiling_face:

Si tu en as beaucoup d’un coup c’est que tu dois avoir un scénario qui agit sur beaucoup de devicetype en même temps ! Ou alors que tu t’es amusé a cliquer quinze mille fois sur tes devicetypes sur l’app :sweat_smile:

Il doit y avoir un soucis avec les websockets… on dirait qu’ils ne s’activent pas à la première utilisation :thinking:


#89

Bonjour :slight_smile:

Bon après plusieurs essais de configuration, j’ai réussi a connecter Gladys sur l’app. Perso je la trouve bien sympa, simple et épuré tout ce que j’aime ^^ …

Configuration faite avec nom de domaine + https = :+1:

Bon je n’ai encore aucuns devices / scénarios sur Gladys pour le moment mais je voulait quand même mettre cela en place :sweat_smile:

Le seule chose pour l’instant que je vois, quand j’écris à Gladys il faut que je change de menu puis revenir sur le chat pour voir la réponse de Gladys, pourtant le websocket est bien actif, sur mon navigateur ça fonctionne nickel.

Sinon, cette appli est vraiment top, good job :clap:


#90

Hello !

Merci ^^

Tu peux essayer quelque chose pour que je sois sur ?

Quand tu dis ça c’est que tu as fais la config puis tu es revenu dans la vue des messages et tu as ce problème ?
Si c’est le cas Tu peux fermer l’app, la relancer et réessayer ?


#91

Que veux tu que j’essaie ???

Bah voilà, des fois jsuis un peu con/noob :rofl: j’aurais pu essayer lol, du coup merci ça marche nickel


#92

C’était juste ça ahah

Bah c’est une bonne nouvelle ! Ça confirme ce que je pensais ! Et du coup je vais fixer ça tout de suite ! Merci :smile:


#93

Tu peux faire comme Facebook ou What’s App, tu mets le message dans la liste directement, mais tu mets une indication que le message est en cours d’envoi (soit un checkmark quelque part, soit juste le message avec un filtre fondu sur blanc). Quand le message est envoyé, tu retire le fondu/tu coche la checkbox

ça serait cool de faire ça coté gladys d’ailleurs je me dis aha :wink:

C’est un bug ça :sweat_smile: Normalement les événements pas liés à un user devraient pas être affiché dans cette vue! Bien vu!


#94

Carrément ! L’idée du checkmark me plais :smile:


#95

Hello tout le monde !

L’app est passé en version 1.2-Alpha03 cette après midi ! Elle corrige les bugs répertorié ici et prend en compte la remarque de @Jojo concernant les messages !

Le changelog est sur la page du play store et le lien n’a pas changé ! Donc mettez vous à jour :kissing_heart:


#96

Salut, super tout ça, je vais m’empresser de faire la mise à jour …

Sinon, est-ce que tu envisage d’ajouter la page des scripts ?

Je viendrais faire un petit retour sur ta nouvelle version, bon par contre ça sera un retour d’utilisateur lambda hein ^^


#97

La page des scripts ? C’est-à-dire ?


#98

Bah quand tu es sur l’interface Gladys ==> https://mon_gladys.net/dashboard/script

EDIT: ta version plante chez moi dès que je veux tchatter avec gladys, par contre là je ne saurais pas te donner de log


#99

Aaaaahhhhh ^^
Non pas du tout ! L’app n’est pas destiné à remplacer le front de Gladys, elle deviendra plutôt une extension (ou un module) qui lui permettra de récolter des infos que le front ne peux pas avoir :slight_smile:

Elle permet aussi a l’user de contrôler ses devices plus rapidement mais les prochaines vues ne seront donc pas des vues dérivée de celles du front !

Tu as désinstallé la version d’avant ou pas ?


#100

Hello !

Je viens de trouver (enfin !) un peu de temps pour tester l’app et j’ai un petit soucis… Je configuré l’app uniquement pour un accès local (ma Gladys n’est pas accessible depuis l’extérieur en même temps :stuck_out_tongue: ) mais impossible d’avoir des informations qui s’affichent, j’ai toujours “une erreur est survenue” sur toutes les pages.
J’ai donné les identifiants d’utilisateur et de maison (1 et 1), l’IP local, le port 8080 (sachant que j’ai passé Gladys en HTTPS avec le script qui va bien) et le token que j’ai créé pour l’occasion (deuxième token).

J’ai raté quelque chose niveau configuration dans l’app, ou je dois chercher la cause ailleurs ? (comme un pb avec mon smartphone ou quoi)

En tout cas, j’aime beaucoup le design que j’ai pu voir de l’app ainsi que les images des états vides des différentes pages, ça fait super classe :sunglasses:


#101

On passe en MP pour que tu me montre ta config @Domnis ?