[RÉSOLU] - Erreur Gladys voice


#1

Bonjour, je viens d’installer gladys-voice et j’ai un code d’erreur lors ce que je fait “pm2 logs gladys-voice” :

1|gladys-v | Error: libcblas.so.3: cannot open shared object file: No such file or directory
1|gladys-v | at Error (native)
1|gladys-v | at Object.Module._extensions…node (module.js:597:18)
1|gladys-v | at Module.load (module.js:487:32)
1|gladys-v | at tryModuleLoad (module.js:446:12)
1|gladys-v | at Function.Module._load (module.js:438:3)
1|gladys-v | at Function._load (/usr/local/lib/node_modules/pm2/node_modules/pmx/lib/transaction.js:62:21)
1|gladys-v | at Module.require (module.js:497:17)
1|gladys-v | at require (internal/module.js:20:19)
1|gladys-v | at Object. (/home/pi/gladys-voice/node_modules/snowboy/lib/node/index.js:8:29)
1|gladys-v | at Module._compile (module.js:570:32)

Merci


#2

Salut @Bap ,

Dans un premier temps essaye juste de redémarrer.

Sinon, en principe ceci devrait résoudre ton problème :

sudo apt-get install libatlas-base-dev


#3

Merci @C4rlit0 je n’ai plus le message d’erreur “libatlas-base-dev” mais j’en ai un autre :sweat_smile: :
Error: spawn rec ENOENT
1|gladys-v | at exports._errnoException (util.js:1018:11)
1|gladys-v | at Process.ChildProcess._handle.onexit (internal/child_process.js:193:32)
1|gladys-v | at onErrorNT (internal/child_process.js:367:16)
1|gladys-v | at _combinedTickCallback (internal/process/next_tick.js:80:11)
1|gladys-v | at process._tickDomainCallback (internal/process/next_tick.js:128:9)
1|gladys-v | at Module.runMain (module.js:606:11)
1|gladys-v | at run (bootstrap_node.js:390:7)
1|gladys-v | at startup (bootstrap_node.js:150:9)
1|gladys-v | at bootstrap_node.js:505:3

Merci


#4

@Bap, as-tu suivi le très bon tuto de @C4rlit0 :wink:

et exécuté la commande suivante ?
sudo apt-get install sox libsox-fmt-all libatlas-base-dev mpg321


#5

@Pti_Nico Oui, j’ai bien suivi ce tuto. Par contre je n’avais pas du effectué cette commande car maintenant je n’ai plus d’erreur. Merci :smiley: .


#6

Bonjour,

Je réveille ce post :wink:

J’ai la même erreur que Bap mais lorsque je test la commande suivante, le package semble introuvable.

sudo apt-get install libatlas-base-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package libatlas-base-dev

idem pour l’autre commande:
sudo apt-get install sox libsox-fmt-all libatlas-base-dev mpg321
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package sox
E: Unable to locate package libsox-fmt-all
E: Unable to locate package libatlas-base-dev
E: Unable to locate package mpg321

Dois-je définir des repo spécifiques ?

Merci :slight_smile:


#7

oups j’avais pas vu une certaine manipulation… sudo apt-get update

Désolé du dérangement :slight_smile: