[RESOLU] Erreur mise à jour Raspberry


#1

Bonjour à tous et meilleurs voeux et la santé.

@pierre-gilles

Gladys 3.11.6

Je vous expose mon problème Voila j’ai effectuer un sudo rpi-update et gladys ne redémarre pas donc un petit coup de pm2 logs gladys et là ceci :

:slight_smile:

 pi@gladys:~ $ pm2 logs gladys
[TAILING] Tailing last 15 lines for [gladys] process (change the value with --lines option)
/home/pi/.pm2/logs/gladys-out-0.log last 15 lines:
0|gladys   |     at Promise._settlePromises (/home/pi/gladys/node_modules/bluebird/js/release/promise.js:689:18)
0|gladys   |     at Async._drainQueue (/home/pi/gladys/node_modules/bluebird/js/release/async.js:133:16)
0|gladys   |     at Async._drainQueues (/home/pi/gladys/node_modules/bluebird/js/release/async.js:143:10)
0|gladys   |     at Immediate.Async.drainQueues [as _onImmediate] (/home/pi/gladys/node_modules/bluebird/js/release/a
0|gladys   |     at runCallback (timers.js:789:20)
0|gladys   |     at tryOnImmediate (timers.js:751:5)
0|gladys   |     at processImmediate [as _immediateCallback] (timers.js:722:5)
0|gladys   | House : checkUsersPresence
0|gladys   | Using cache, file already exist
0|gladys   | Using cache, file already exist
0|gladys   | Using cache, file already exist
0|gladys   | Using cache, file already exist
0|gladys   | Using cache, file already exist
0|gladys   | House : checkUsersPresence
0|gladys   | undefined
/home/pi/.pm2/logs/gladys-error-0.log last 15 lines:
0|gladys   | Environment : production
0|gladys   | Port        : 8080
0|gladys   | -------------------------------------------------------
0|gladys   | Getting conversation 6752a71a-baae-4a2c-8f01-c9c524d3f5e8, found 1 messages.
0|gladys   | Brain : answer : Found 3 possible.
0|gladys   | brain : classify : Answered in 0s, 948.587 ms
0|gladys   | Getting conversation 4a17b75b-9b32-4b40-afd0-37bbd71204e3, found 1 messages.
0|gladys   | Brain : answer : Found 3 possible.
0|gladys   | brain : classify : Answered in 0s, 799.625 ms
0|gladys   | Getting conversation ca49f2fe-1ebc-4e30-82c4-36206ebce035, found 1 messages.
0|gladys   | Brain : answer : Found 3 possible.
0|gladys   | brain : classify : Answered in 0s, 730.695 ms
0|gladys   | ALSA lib pcm_direct.c:1605:(_snd_pcm_direct_get_slave_ipc_offset) Invalid value for card
0|gladys   | [../deps/mpg123/src/output/alsa.c:165] error: cannot open device default
0|gladys   | node /home/pi/gladys/app.js: pcm_params.c:2290: snd_pcm_hw_refine: Assertion `pcm && params' failed.

0|gladys   | undefined
0|gladys   | ALSA lib pcm_direct.c:1605:(_snd_pcm_direct_get_slave_ipc_offset) Invalid value for card
0|gladys   | [../deps/mpg123/src/output/alsa.c:165] error: cannot open device default
0|gladys   | node /home/pi/gladys/app.js: pcm_params.c:2290: snd_pcm_hw_refine: Assertion `pcm && params' failed.
0|gladys   | undefined
0|gladys   | ALSA lib pcm_direct.c:1605:(_snd_pcm_direct_get_slave_ipc_offset) Invalid value for card
0|gladys   | [../deps/mpg123/src/output/alsa.c:165] error: cannot open device default
0|gladys   | node /home/pi/gladys/app.js: pcm_params.c:2290: snd_pcm_hw_refine: Assertion `pcm && params' failed.
0|gladys   | undefined
0|gladys   | ALSA lib pcm_direct.c:1605:(_snd_pcm_direct_get_slave_ipc_offset) Invalid value for card
0|gladys   | [../deps/mpg123/src/output/alsa.c:165] error: cannot open device default
0|gladys   | node /home/pi/gladys/app.js: pcm_params.c:2290: snd_pcm_hw_refine: Assertion `pcm && params' failed.
0|gladys   | undefined
0|gladys   | ALSA lib pcm_direct.c:1605:(_snd_pcm_direct_get_slave_ipc_offset)
0|gladys   | Invalid value for card
0|gladys   | [../deps/mpg123/src/output/alsa.c:165] error: cannot open device default
0|gladys   | node /home/pi/gladys/app.js: pcm_params.c:2290: snd_pcm_hw_refine: Assertion `pcm && params' failed.
0|gladys   | undefined
0|gladys   | ALSA lib pcm_direct.c:1605:(_snd_pcm_direct_get_slave_ipc_offset) Invalid value for card
0|gladys   | [../deps/mpg123/src/output/alsa.c:165] error: cannot open device default
0|gladys   | node /home/pi/gladys/app.js: pcm_params.c:2290: snd_pcm_hw_refine: Assertion `pcm && params' failed.
0|gladys   | undefined
0|gladys   | ALSA lib pcm_direct.c:1605:(_snd_pcm_direct_get_slave_ipc_offset)
0|gladys   | Invalid value for card
0|gladys   | [../deps/mpg123/src/output/alsa.c:165] error: cannot open device default
0|gladys   | node /home/pi/gladys/app.js: pcm_params.c:2290: snd_pcm_hw_refine: Assertion `pcm && params' failed.
0|gladys   | undefined
0|gladys   | ALSA lib pcm_direct.c:1605:(_snd_pcm_direct_get_slave_ipc_offset) Invalid value for card
0|gladys   | [../deps/mpg123/src/output/alsa.c:165] error: cannot open device default
0|gladys   | node /home/pi/gladys/app.js: pcm_params.c:2290: snd_pcm_hw_refine: Assertion `pcm && params' failed.
0|gladys   | undefined
0|gladys   | ALSA lib pcm_direct.c:1605:(_snd_pcm_direct_get_slave_ipc_offset) Invalid value for card
0|gladys   | [../deps/mpg123/src/output/alsa.c:165] error: cannot open device default
0|gladys   | node /home/pi/gladys/app.js: pcm_params.c:2290: snd_pcm_hw_refine: Assertion `pcm && params' failed.
0|gladys   | undefined
0|gladys   | ALSA lib pcm_direct.c:1605:(_snd_pcm_direct_get_slave_ipc_offset) Invalid value for card
0|gladys   | [../deps/mpg123/src/output/alsa.c:165] error: cannot open device default
0|gladys   | node /home/pi/gladys/app.js: pcm_params.c:2290: snd_pcm_hw_refine: Assertion `pcm && params' failed.
0|gladys   | undefined
0|gladys   | ALSA lib pcm_direct.c:1605:(_snd_pcm_direct_get_slave_ipc_offset)
0|gladys   | Invalid value for card
0|gladys   | [../deps/mpg123/src/output/alsa.c:165] error: cannot open device default
0|gladys   | node /home/pi/gladys/app.js: pcm_params.c:2290: snd_pcm_hw_refine: Assertion `pcm && params' failed.

Pouvez-vous me dire si quelqu’un a déjà eut cela et si il a pu le corriger ou si je peux revenir en arrière

Merci par avance

@phoenix3472


#2

Une piste ( alsa / sortie son )


#3

Il me semble que l’update ne doit pas se faire avec sudo


#4

Il parle pas de Gladys à priori


#5

Bonjour @VonOx et @Exilon62,

Alors si je parle de gladys qui ne démarre plus mais le sudo rpi-update c’est pour faire le mise à jour firmware de Rasbian stretch et là je pense que je n’aurais pas dû !!! je pense que cette nouvelle version de firmware n’est pas compatible soit avec gladys et/ou soit avec le code du respeaker 6 Mic qui modifie Alsa.

Je ne sait pas si je peux revenir en arrière ou si je doit tous réinstaller ?

Et quel est la différence entre sudo ./rpi-update.sh et sudo rpi-update.sh ?

Car quand j’ai fait la mise à jour Gladys j’ai fait sudo ./rpi-update.sh et j’ai pas eut de problème je suis passé de la version 3.11.3 à 3.11.6.

Merci à vous @phoenix3472


#6

Mais comme dit plus haut, on ne fait pas la mise à jour Gladys avec sudo. ton problème doit venir de là


#7

@Jean34 relis son post c’est pas Gladys qu’il a mis à jour mais le rpi


#8

Salut @VonOx
Alors c’est ce que je voulais faire mais est-ce bien comme cela qu’il faut faire.

Merci


#9

Sur un Linux base Debian pour mettre à jour le systeme on fait ça plutôt

sudo apt update && sudo apt upgrade

Mon point de vue, si tu n’as pas besoin de nouvelle fonctionnalités et que ton raspberry n’est pas accessible depuis l’extérieur, pas besoin de s’embêter avec les updates. 1 fois par mois c’est bon.

Ensuite la commande sudo rpi-update fait aussi la mise à jour du kernel, vue que ton problème est hardware l’origine de ton problème viens sûrement de là

Refait l’installation complète de ton respeaker et/ou oriente tes recherches dans ce sens.


#10

Merci @VonOx je vais faire cela je revient si j’ai des problèmes

Merci


#11

Bon je réinstalle je passe en résolu
Merci
@phoenix3472