(RÉSOLU) Gladys ne répond pas


#15

Bonjour, je reviens vers vous car j’ai toujours le souci que le son ne sors pas de mon enceinte qui est branchée sur la prise jack du raspberry, par contre j’ai réussi à régler la sensibilité du micro beaucoup moins de déclenchement intenpestif.
Et mon fichier asound.conf est toujours le même
Je viens de faire un test en disant à glagys joue la musique et elle met en route la musique j’ai juste un souci de sortie de son avec gladys voice elle est peut être muette :roll_eyes:
Merci d’avance pour votre aide


#16

Peut être un soucis dans les priorités des notifications ?
Quelle est ta configuration ?


#17

Bonsoir elysium, la configuration au niveau de quoi? merci


#18

Je suis encore un newbie avec Gladys mais voilà ce que j’ai compris en installant snips :
Dans paramètres -> notifications, tu gères l’ordre des priorités que Gladys utilise pour te répondre. Pour ma part, j’ai attribué la priorité 0 à snips et 1 pour websocket.
Ensuite, gladys ne parle que si ton utilisateur est vu à la maison. Il faut donc que tu créés un événement ‘back at home’ pour que galdys sache que tu es là et qu’elle te parle.

Est ce que quelqu’un de plus expérimenté avec Gladys peut confirmer mes dires histoire de savoir si j’ai bien compris son fonctionnement… Merci !


#19

Je devrais plus installer snips alors !! car moi j’ai essayé uniquement gladys-voice ou il faut les 2 j’avoue je m’y perds de plus en plus …


#20

Le module gladys-voice permet de donner des ordres a Gladys par la voix, en passant par l’API Google (et son quota gratuit).

Je n’avais pas bien lu lors de ma première réponse, mais ce module ne permet pas de faire de la réponse Vocale, c’est à dire du Text To Speech, donc c’est normal qu’elle comprenne, agisse mais ne réponde pas.

En somme, le module semble pleinnement fonctionnel.

@elysium concernant Snips, c’est un autre module, autre fonctionnement, que j’ai pour ma part adopté pour le moment, car avec gladys-voice, je n’avais pas la fiabilité escompté, et de plus, je me retrouvais facturé.


#21

Jean-Philippe ma lumière vient de s’éclairer dans ma tête en voyant le message de elysium et effectivement je viens d’installer speak et enfin elle me parle :joy:


#22

merde je viens de redémarrer mon raspberry et il me mets dans les logs ça

PM2 | App [gladys-voice] with id [1] and pid [1057], exited with code [0] via signal [SIGINT]
PM2 | Starting execution sequence in -fork mode- for app name:gladys-voice id:1
PM2 | App name:gladys-voice id:1 online
1|gladys-v | (node:1192) DeprecationWarning: grpc.load: Use the @grpc/proto-loader module with grpc.loadPackageDefinition instead
PM2 | App [gladys-voice] with id [1] and pid [1192], exited with code [0] via signal [SIGINT]
PM2 | Starting execution sequence in -fork mode- for app name:gladys-voice id:1
PM2 | App name:gladys-voice id:1 online
1|gladys-v | (node:1235) DeprecationWarning: grpc.load: Use the @grpc/proto-loader module with grpc.loadPackageDefinition instead
0|gladys | House : checkUsersPresence
PM2 | App [gladys-voice] with id [1] and pid [1235], exited with code [0] via signal [SIGINT]
PM2 | Starting execution sequence in -fork mode- for app name:gladys-voice id:1
PM2 | App name:gladys-voice id:1 online
1|gladys-v | (node:1438) DeprecationWarning: grpc.load: Use the @grpc/proto-loader module with grpc.loadPackageDefinition instead


#23

Salut, tape ton erreur dans la recherche du forum “DeprecationWarning: grpc.load:” tu vas voir qu’il y a solution à ton problème.


#24

ok merci je vais voir


#25

heu !! je trouve pas de solution le seul qui correspondrait à mon problème est resté sans réponse Installation Gladys Voice


#26

Désolé de faire le pénible mais je n’ai rien trouvé, toujours le même souci, il me demande d’utiliser le module grpc/proto-loader mais on le trouve où ce module :cold_sweat:
Merci d’avance


#27

Salut :slight_smile: ==> [Résolu] Erreur installation gladys-voice


#28

Bonsoir tout le monde, Jean34 j’ai été sur le lien et fait la manip effectivement j’ai plus le souci grpc, mais là j’ai d’autres lignes en rouge

PM2 | App name:gladys-voice id:1 online
1|gladys-v | Error: Cannot find module ‘./src/client.js’
1|gladys-v | at Function.Module._resolveFilename (module.js:538:15)
1|gladys-v | at Function.Module._load (module.js:468:25)
1|gladys-v | at Module.require (module.js:587:17)
1|gladys-v | at require (internal/module.js:11:18)
1|gladys-v | at Object. (/home/pi/gladys-voice/node_modules/grpc/src/node/index.js:45:14)
1|gladys-v | at Module._compile (module.js:643:30)
1|gladys-v | at Object.Module._extensions…js (module.js:654:10)
1|gladys-v | at Module.load (module.js:556:32)
1|gladys-v | at tryModuleLoad (module.js:499:12)
1|gladys-v | at Function.Module._load (module.js:491:3)
PM2 | App [gladys-voice] with id [1] and pid [1192], exited with code [1] via signal [SIGINT]
PM2 | Starting execution sequence in -fork mode- for app name:gladys-voice id:1
PM2 | App name:gladys-voice id:1 online
Apparemment une erreur de client.js si j’ai bien compris mais je trouve rien sur le forum
Merci de votre aide


#29

Salut, as tu fait une mise à jour de gladys/rpi après avoir installer le module “grpc” ? Qu’on me dise si je dit une “connerie” mais je pense que ça ne mange pas de pain …

Autre chose … Pour ma part (je ne sais pas si c’est le cas des autres membres de la communauté), j’ai vraiment du mal à t’aider parce que tu ne donnes pas trop de détails sur ce que tu fais sur ta machine, à part mettre les erreurs que te log Gladys. Donc du coup c’est un peu à nous de faire les recherches pour tenter de t’aider et surtout d’essayer de comprendre par où tu es allé :crazy_face: imagine ^^…


#30

Bonjour, tout le monde effectivement Jean34 je comprends mieux pourquoi c’est dur pour vous de me dépanner si je ne donne pas tout les éléments, je suis tellement dans mon problème que j’en oubli l’essentiel :sweat_smile:
Alors je vais essayer de tout vous dire pour espérer enfin résoudre le problème.
Pour réinstaller le “grpc” j’ai fait la commande suivante :

sudo yarn install

ensuite j’ai fait une mise à jour gladys/rpi dans le root :slight_smile:

rpi-update

j’ai redémarré mon raspberry et je suis allé dans le dossier gladys-voice et lancé:


puis

pm2 logs

Voilà l’erreur en espérant que ça sera mieux pour la compréhension.
Merci encore de votre travail


#31

Bonsoir, après avoir tout formaté et tout réinstaller gladys voice ne fonctionne toujours pas, pourtant j’ai bien respecté les étapes du tuto > [TUTORIEL] - Gladys et la reconnaissance vocale
par contre j’ai gardé le même fichier gladys-speech.json est-ce bon ?
une fois tout installé je lance gladys-voice via

pm2 start app.js --name gladys-voice
cela me donne

et là je constate que je n’ai pas d’ID en name et mode est-ce normal?

puis je fais

pm2 logs

et j’obtiens

PM2 | App [gladys-voice] with id [1] and pid [18993], exited with code [1] via signal [SIGINT]
PM2 | Starting execution sequence in -fork mode- for app name:gladys-voice id:1
PM2 | App name:gladys-voice id:1 online
1|gladys-v | Error: Cannot find module ‘/home/pi/gladys-voice/node_modules/snowboy/lib/node/binding/Release/node-v57-linux-arm/snowboy.node’
1|gladys-v | at Function.Module._resolveFilename (module.js:538:15)
1|gladys-v | at Function.Module._load (module.js:468:25)
1|gladys-v | at Module.require (module.js:587:17)
1|gladys-v | at require (internal/module.js:11:18)
1|gladys-v | at Object. (/home/pi/gladys-voice/node_modules/snowboy/lib/node/index.js:8:29)
1|gladys-v | at Module._compile (module.js:643:30)
1|gladys-v | at Object.Module._extensions…js (module.js:654:10)
1|gladys-v | at Module.load (module.js:556:32)
1|gladys-v | at tryModuleLoad (module.js:499:12)
1|gladys-v | at Function.Module._load (module.js:491:3)

Merci encore de votre aide et je voudrais savoir où je merde :sweat:


#32

Salut regarde par là :


#33

Merci Jean34 cela fonctionne enfin je te dois une bonne bière :hugs: j’ai tout supprimé et repartie de zéro et étudié les erreurs et il ma solution s’était ça

sudo apt-get install sox libsox-fmt-all libatlas-base-dev mpg321

Je peux enfin profiter de gladys et passer aux étapes supérieurs donc à très très bientot sur le forum.
Et encore un grand merci à tous pour votre patience surtout toi Jean34


#34

Content que ça fonctionne pour toi :wink:

Si tu peux ajouter [Résolu] au début de ton titre ce serait le top :slight_smile: