[RESOLU] Installation / Usage jekyll


#1

Je n’arrive pas à l’installer en local :confused:
Quand je fais “bundle install” il me dit qu’il ne trouve pas mon fichier GemFile alors qu’il existe bien.
J’ai essayé avec plusieurs versions de ruby.

Il faut une version spécifique ?


Page d'accueil documentation Gladys
#2

Si tu es sous windows tu peux l’utiliser sous WSL ça marche du tonerre:


#3

j’ai bien suivi le tuto, j’arrive à lancer jekyll avec un nouveau projet et le theme par défaut. Mais il ne me reconnait pas le GemFile de ce projet en fait…


#4

Tu es sur quel OS @Exilon62 ?


#5

je suis sur ubuntu 18.04
les droits sur le fichier sont bons, quand je fais un ls le fichier est bien là mais pas reconnu par ruby…


#6

T’as installé ruby-dev ?


#7

Oui c’est bien installé


#8

@Exilon62 J’ai créé une nouvelle discussion pour pas polluer l’autre sujet


#9

Je crois que tu l’avais posté sur Slack mais tu peux remettre l’erreur ici ?


#10

en effet, voici le screen :


#11

Tente avec ça:

BUNDLE_GEMFILE="./GemFile" bundle install

Edit, je viens de tester sur 18.04 avec succès:

$> sudo gem install jekyll bundler
Fetching: jekyll-3.8.5.gem (100%)
Successfully installed jekyll-3.8.5
Parsing documentation for jekyll-3.8.5
Installing ri documentation for jekyll-3.8.5
Done installing documentation for jekyll after 1 seconds
Successfully installed bundler-1.17.1
Parsing documentation for bundler-1.17.1
Done installing documentation for bundler after 3 seconds
2 gems installed

$> bundle exec jekyll serve
Could not locate Gemfile or .bundle/ directory

$> jekyll serve
Configuration file: /home/wkvkk/documentation.gladysproject.com.jekyll/_config.yml
            Source: /home/wkvkk/documentation.gladysproject.com.jekyll
       Destination: /home/wkvkk/documentation.gladysproject.com.jekyll/_site
 Incremental build: disabled. Enable with --incremental
      Generating...
       Jekyll Feed: Generating feed for posts
                    done in 0.689 seconds.
 Auto-regeneration: enabled for '/home/wkvkk/documentation.gladysproject.com.jekyll'
    Server address: http://127.0.0.1:4000
  Server running... press ctrl-c to stop.
[2018-12-03 15:35:50] ERROR `/favicon.ico' not found.
[2018-12-03 15:35:50] ERROR `/assets/image/gladys-logo.png' not found.

#12

super ça fonctionne merci !

et pour lancer je fais :
BUNDLE_GEMFILE="./GemFile" bundle exec jekyll serve


#13

normalement juste jekyll serve ça suffit