[RESOLU] Lancement de scripts automatique

scripts

#1

Bonjour à tous
je voudrais lancer à heures régulières un script qui va chercher la météo ( Wheather ) et qui me renvoie le résultat sur Télégram.
Ce script fonctionne bien en le lançant manuellement mais je voudrais utiliser Alarmes ou Cron pour le lancer automatiquement à heures régulières.
D’avance merci de vos conseils.
Christian


#2

Salut @Christian,
tu fais une alarme, qui déclenche un scénario, qui déclenche ton script.
Voilà pour la réponse courte :slight_smile:
Si tu as besoin d’une réponse plus longue, n’hésite pas à le demander.


#3

Salut @piznel
Je te remercie pour ta réponse rapide
Je vais essayer cela rapidement
Je tiens au courant
:blush:


#4

Salut @piznel
Je reviens vers toi car j’ai bien essayé ce que tu m’as dit.
J’ai créé une alarme cron “Temperature”

Capture d’écran 2019-01-12 à 15.29.23.png
Puis j’ai créé un scénario déclenché par cette alarme Capture d’écran 2019-01-12 à 15.29.58.png
Ce scénario déclenche un script Capture d’écran 2019-01-12 à 15.30.20.png
Mais rien ne se passe ???
J’ai l’impression que le service cron ne le pas prend en compte31 Capture d’écran 2019-01-12 à 15.35.31.png
Pourtant, dans les logs Gladys je vois bien mes alarmes: Capture d’écran 2019-01-12 à 15.27.28.png
J’avoue, je ne sais plus quoi faire.
Un grand éclairage me serais d’un grand secours
Merci encore
Amitiés


#5

Salut,

Alors le cron de Gladys n’est pas accessible depuis le cron système
Donc c’est normal que tu ne vois rien en crontab.

Par ailleurs, dans ton screenshot, j’ai l’impression que ton alarme est erronée.
Tu sembles avoir mis :

/10 * * * * *

au lieu de

0 */10 * * * *

Tous les jours, à la seconde 0 toute les 10min


#6

Salut @Jean-Philippe

J’ai modifié l’alarme comme tu me l’avais indiqué mais toujours rien
Je désespère :sleepy::sleepy::sleepy:
Merci tout de même
Amitiés


#7

Juste un détail, quand tu as créé ton alarme, il faut choisir “Cette alarme n’est pas un réveil”.
C’est bien ce que tu as fait ?


#8

Salut @piznel
J’ ai bien choisi “Cette alarme n’est pas un réveil” et cela n’avait rien donné.
Mais par miracle, à 1heure du matin, les scripts se sont déclenchés… allez savoir pourquoi ?
Comme paramètre j’avais mis 00**** et le script se déclenche toutes les minutes ??
Il faudrait que je revois ce paramètre pour qu’il se déclenche que toutes les heures.
Je suis un peu perdu avec ces paramètres cron.
Amitiés


#9

@Christian , toute les heures ?.. Bah c’est écrit sur l’interface quand tu est dans le menu alarme :slight_smile:

Règles cron

Vous pouvez définir ici des règles cron. Le format est classique, si vous vouler effectuer une tâche toutes les heures, simplement tapez : ‘0 0 * * * *’. Plus d’infos ici : https://github.com/node-schedule/node-schedule.

Donc tu mets 0 0 * * * * :wink:

PS: d’ailleurs il y a une petite faute dans la phrase : si vous vouler ==> si vous voulez @pierre-gilles @MathieuA


#10

Ca sent un problème d’heure sur ton RPI.
En console, fait sudo raspi-config, puis localization option, puis change Timezone, puis sélectionne Europe, puis Paris, puis finish.


#11

Salut @Jean34 @Jean-Philippe @piznel
Merci à vous pour vos réponses
Je suis allé vérifier Timezone dans raspi-config Ok
Dans la règle Cron j’ai mis “0 0 * * * *” avec un espace entre chaque valeur et c’était peu-être là l’erreur.
Depuis tout à l’air de fonctionner normalement.
Super et merci encore à vous
Christian
ps: je ne sais pas clôturer le post.


#12

Tu édites juste le titre de ton premier post, et rajoutes [RESOLU] devant :slight_smile: