[Resolu] Module Panasonic smart viera

#1

Bonjour,

Je viens de découvrir Gladys.
J’essaie d’installer le module panasonic smart viera.
Dans les conseils d’installation : il est dit : " * Ajouter un paramètre VIERA_TV_LIST avec les ip de vos télévision Viera avec comme séparateur un pipe « | » (si vous n’avez qu’une seule TV mettez tout simplement l’ip sans rien d’autre) "
Je n’arrive pas à trouver où je dois mettre ce paramètre ( dans quel onglet ? … ).
Pour moi débutant ce n’est pas assez explicite.
Pouvez-vous me dire où je dois mettre ce paramètre, svp ?

Merci.
Lionel.

#2

Salut c’est dans le menu paramètres à gauche et ensuite l’onglet paramètres. À gauche tu insères VIERA_TV_LIST et à droite ton ip et tu cliques sur le bouton à droite de la ligne.

#3

Merci de t’intéresser à mon problème.

J’ai fait ce que tu as dit ( voir photo ). Mais cela ne fonctionne toujours pas ( lorsque je lance manuellement un script j’ai l’erreur : ReferenceError: DEVICE_ID is not defined

Pourtant, j’ai scrupuleusement suivi le processus d’installation.

Que faire ?

#4

A Jean34

J’ai trouvé. En fait le module s’est correctement installé. J’arrive à piloter certaines fonctionnalités maois pas toutes. Je vais signaler le bug au créateur du module.

Bonne soirée.

1 Like
#5

Salut @Lio !
Hésite pas a me taguer quand tu as besoin (spenceur1) :-).

Peux tu me fournir des informations complémentaire (log, version gladys, modele TV) ?

#6

Bonjour et merci de regarder le problème,

version de gladys : 3.13.0

modele de TV : PANASONIC TX-P42ST60E

voici le log lorsque j’ai éteint ( la télé s’éteint ) puis rallumé ( la télé ne s’allume plus ).

A bientôt.

Lionel.

#7

Bonjour,

@spenceur : un autre bug je crois.
J’ai déclaré ma télé dans le salon. Lorsque je veux la piloter à partir de la console gladys dans mes périphériques j’ai ceci
image

Est-ce normal de voir Salon en haut comme titre, ce ne serait pas plutôt “Viera…” qui est attendu ?

Merci.

Lionel

#8

Non c’est normal, tu va retrouver tous les périphériques du salon dans cette box.

1 Like
#9

@VonOx D’accord.

Merci.

#10

Tu peux aussi créer une pièce Viera… Si avoir tous les périphériques mélanger te dérange

#11

Salut @Lio ton problème ressemble a celui ci :

Peux tu tenter de faire cette étape :
Check that the “TV Remote” of VIERA TV is set to “On”. (Network > TV Remote App Settings > TV Remote) ?

Pour info je n’ai pas de viera.

#12

Bonjour @spenceur,

Tout à fait, mon problème est le même. Malheureusement, j’ai regardé les réglages indiqués et ma “TV Remote” of VIERA TV est déjà sur On.
Depuis, j’ai exploré cette piste ( le prob vient de ma télé et non du module ) et je suis tombé sur cette discussion : https://github.com/TG908/homebridge-panasonictv/issues/2
qui parle du même problème.
D’après ce que j’ai compris, il semblerait que ma télé bien qu’étant viera soit trop “vieille” en l’état actuel du module.

Après, ce n’est pas grave de ne pas pouvoir l’allumer. Cela me fera lever de mon canapé ;-).

.

#13

Mince j’en suis désolé.
Peux tu éditer ton post en résolu stp?
En revanche jai peut-être une idée pour ton cas.
Ta télé est elle relier en rj45?
Ta télé est elle compatible hdmi cec ?

#14

Non uniquement en wifi et non elle n est pas compatible hdmi cec.
Je passe le sujet en résolu. Je te remercie pour t être penché sur mon problème.

1 Like
#15

ah triple mince ^^’,
j’allais te dire de coupler le module avec soit HDMI cec soit un module pour executer des commande WOL.
Tant pis ^^.
Bon courage a toi :slight_smile: