(resolu)Netatmo station meteo


#21

quand je redémarre l’appli j’ai ça
ca aide a dire si elle marche ou pas???


#22

Ca veut dire que l’app est lancée et enregistrée dans pm2.
Cette commande sert juste une fois. Après tu peux utiliser celle-ci pour la gérer au cas où :

pm2 restart gladys-netatmo-weather (pour faire un redémarrage quand elle tourne)
pm2 start gladys-netatmo-weather (pour la démarrer quand complètement à l’arrêt)
pm2 stop gladys-netatmo-weather (pour la stopper)

pm2 list (sert à voir si elle tourne)
pm2 monit (même chose en plus poussé)

Tout ça va changer et être plus simple quand je vais passer le module dans une autre version. :wink:

Du coup, tu as de nouveaux périphériques d ns gladys ?


#23

si ces bien ici je ne crois pas ou alors je les est renomer en me trompent mais normalement non


#24

Non…

On reprend :

  • tu as bien créé une app sur la plateforme dev de Netatmo ? Netatmo te donne pour cette app deux codes : Client id et client secret que tu dois renseigner au bon endroit dans le fichier config.js

  • il faut également avoir un compte normal Netatmo (mais ça tu as, vu que tu as le matériel) dont tu renseignes les infos dans ce même fichier.
  • il faut créer un accès à Gladys pour le module en demandant un token dans Paramètres > Sécurité

  • tu prends ce fameux token que tu renseignes dans config.js

Toutes les variables dans le fichier token sont à laisser entre ’ ', tu as juste à remplacer le texte en capital à droite YOUR-CLIENT-ID etc par les bonnes infos. Tu sauvegardes le fichier et tu lances le module.

Tu peux mettre les logs après ici ?


#25

je voulais savoir dans le config il y a moyen de faire du copier coller ou pas
???


#26

Bien sûr, tu te mets au bon endroit avec les flèches et bingo.


#27

bien j’ai tou coller copier bien rentrer les vrai identifient

[email protected]:~/gladys-netatmo-weather $ pm2 start /home/pi/gladys-netatmo-weather/app.js --name gladys-netatmo-weather
[PM2][ERROR] Script already launched, add -f option to force re-execution
┌────────────────────────┬──────┬─────────┬────┬─────┬───────────┐
│ Name                   │ mode │ status  │ ↺  │ cpu │ memory    │
├────────────────────────┼──────┼─────────┼────┼─────┼───────────┤
│ gladys                 │ fork │ online  │ 2  │ 0%  │ 96.8 MB   │
│ gladys-bluetooth       │ fork │ errored │ 15 │ 0%  │ 0 B       │
│ gladys-netatmo-weather │ fork │ online  │ 0  │ 0%  │ 34.5 MB   │
└────────────────────────┴──────┴─────────┴────┴─────┴───────────┘
 Use `pm2 show <id|name>` to get more details about an app
[email protected]:~/gladys-netatmo-weather $ pm2 logs gladys-netatmo-weather
[TAILING] Tailing last 15 lines for [gladys-netatmo-weather] process (change the value with --lines option)
/home/pi/.pm2/logs/gladys-netatmo-weather-error-1.log last 15 lines:
1|gladys-n | Netatmo threw an error: Error: Authenticate error: invalid_client
1|gladys-n | (node:19222) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 authenticated listeners added. Use emitter.setMaxListeners() to increase limit
1|gladys-n | Netatmo threw an error: Error: Authenticate error: invalid_client
1|gladys-n | (node:25461) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 authenticated listeners added. Use emitter.setMaxListeners() to increase limit
1|gladys-n | Netatmo threw an error: Error: Authenticate error: invalid_client
1|gladys-n | (node:1536) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 authenticated listeners added. Use emitter.setMaxListeners() to increase limit
1|gladys-n | Netatmo threw an error: Error: Authenticate error: invalid_client

/home/pi/.pm2/logs/gladys-netatmo-weather-out-1.log last 15 lines:
1|gladys-n | Request from Netatmo API...
1|gladys-n | Request from Netatmo API...
1|gladys-n | Request from Netatmo API...
1|gladys-n | Request from Netatmo API...
1|gladys-n | Request from Netatmo API...
1|gladys-n | Request from Netatmo API...
1|gladys-n | Request from Netatmo API...
1|gladys-n | Request from Netatmo API...
1|gladys-n | Request from Netatmo API...
1|gladys-n | Request from Netatmo API...
1|gladys-n | Request from Netatmo API...
1|gladys-n | Request from Netatmo API...
1|gladys-n | Request from Netatmo API...
1|gladys-n | Request from Netatmo API...
1|gladys-n | Request from Netatmo API...

#28

Est-ce que dans le fichier app.js tu peux décommenter la ligne avec
// console.log(devices[0]);

Tu enlèves les // :wink:

Et ensuite tu restart l’app et me colle le résultat de
pm2 logs gladys-netatmo-weather --lines 50


#29

excuse moi mais je comprend pas ou et ce app.js
vraiment désolé


#30

Dans le terminal, tu fais ça
nano /home/pi/gladys-netatmo-weather/app.js

Comme pour le config.js et tu enlèves les // sur la ligne de code que je t’ai donné plus haut.
//console.log(devices[0]);


#31
[TAILING] Tailing last 50 lines for [gladys-netatmo-weather] process (change the value with --lines option)
/home/pi/.pm2/logs/gladys-netatmo-weather-error-1.log last 50 lines:
1|gladys-n | Netatmo threw an error: Error: Authenticate error: invalid_client
1|gladys-n | (node:19222) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 authenticated listeners added. Use emitter.setMaxListeners() to increase limit
1|gladys-n | Netatmo threw an error: Error: Authenticate error: invalid_client
1|gladys-n | (node:25461) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 authenticated listeners added. Use emitter.setMaxListeners() to increase limit
1|gladys-n | Netatmo threw an error: Error: Authenticate error: invalid_client
1|gladys-n | (node:1536) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 authenticated listeners added. Use emitter.setMaxListeners() to increase limit
1|gladys-n | Netatmo threw an error: Error: Authenticate error: invalid_client
1|gladys-n | (node:17440) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 authenticated listeners added. Use emitter.setMaxListeners() to increase limit

/home/pi/.pm2/logs/gladys-netatmo-weather-out-1.log last 50 lines:
1|gladys-n |     at modules.forEach.element (/home/pi/gladys-netatmo-weather/app.js:45:9)
1|gladys-n |     at Array.forEach (<anonymous>)
1|gladys-n |     at netatmo.getStationsData (/home/pi/gladys-netatmo-weather/app.js:38:13)
1|gladys-n |     at emitTwo (events.js:126:13)
1|gladys-n |     at netatmo.emit (events.js:214:7)
1|gladys-n |     at netatmo.<anonymous> (/home/pi/gladys-netatmo-weather/node_modules/netatmo/netatmo.js:224:10)
1|gladys-n |     at Request.self.callback (/home/pi/gladys-netatmo-weather/node_modules/request/request.js:185:22)
1|gladys-n |     at emitTwo (events.js:126:13)
1|gladys-n |     at Request.emit (events.js:214:7)
1|gladys-n |     at Request.<anonymous> (/home/pi/gladys-netatmo-weather/node_modules/request/request.js:1161:10)
1|gladys-n |     at emitOne (events.js:116:13)
1|gladys-n |     at Request.emit (events.js:211:7)
1|gladys-n |     at IncomingMessage.<anonymous> (/home/pi/gladys-netatmo-weather/node_modules/request/request.js:1083:12)
1|gladys-n |     at Object.onceWrapper (events.js:313:30)
1|gladys-n |     at emitNone (events.js:111:20)
1|gladys-n |     at IncomingMessage.emit (events.js:208:7),
1|gladys-n |   error: Error: Invalid URI "https:192.168.0.32//localhost:8080/device?token=e74cc920d280ab4c2ba53d6c104dda7853448427"
1|gladys-n |     at Request.init (/home/pi/gladys-netatmo-weather/node_modules/request/request.js:273:31)
1|gladys-n |     at Request.RP$initInterceptor [as init] (/home/pi/gladys-netatmo-weather/node_modules/request-promise-core/configure/request2.js:45:29)
1|gladys-n |     at new Request (/home/pi/gladys-netatmo-weather/node_modules/request/request.js:127:8)
1|gladys-n |     at request (/home/pi/gladys-netatmo-weather/node_modules/request/index.js:53:10)
1|gladys-n |     at createDevice (/home/pi/gladys-netatmo-weather/lib/createDevice.js:12:12)
1|gladys-n |     at createModule (/home/pi/gladys-netatmo-weather/lib/createModule.js:49:5)
1|gladys-n |     at modules.forEach.element (/home/pi/gladys-netatmo-weather/app.js:45:9)
1|gladys-n |     at Array.forEach (<anonymous>)
1|gladys-n |     at netatmo.getStationsData (/home/pi/gladys-netatmo-weather/app.js:38:13)
1|gladys-n |     at emitTwo (events.js:126:13)
1|gladys-n |     at netatmo.emit (events.js:214:7)
1|gladys-n |     at netatmo.<anonymous> (/home/pi/gladys-netatmo-weather/node_modules/netatmo/netatmo.js:224:10)
1|gladys-n |     at Request.self.callback (/home/pi/gladys-netatmo-weather/node_modules/request/request.js:185:22)
1|gladys-n |     at emitTwo (events.js:126:13)
1|gladys-n |     at Request.emit (events.js:214:7)
1|gladys-n |     at Request.<anonymous> (/home/pi/gladys-netatmo-weather/node_modules/request/request.js:1161:10)
1|gladys-n |     at emitOne (events.js:116:13)
1|gladys-n |     at Request.emit (events.js:211:7)
1|gladys-n |     at IncomingMessage.<anonymous> (/home/pi/gladys-netatmo-weather/node_modules/request/request.js:1083:12)
1|gladys-n |     at Object.onceWrapper (events.js:313:30)
1|gladys-n |     at emitNone (events.js:111:20)
1|gladys-n |     at IncomingMessage.emit (events.js:208:7),
1|gladys-n |   options:
1|gladys-n |    { method: 'POST',
1|gladys-n |      uri: 'https:192.168.0.32//localhost:8080/device?token=e74cc920d280ab4c2ba53d6c104dda7853448427',
1|gladys-n |      body: { device: [Object], types: [Array] },
1|gladys-n |      json: true,
1|gladys-n |      callback: [Function: RP$callback],
1|gladys-n |      transform: undefined,
1|gladys-n |      simple: true,
1|gladys-n |      resolveWithFullResponse: false,
1|gladys-n |      transform2xxOnly: false },
1|gladys-n |   response: undefined }

voila j’espere que ces que tu voulais


#32

Salut @cyril,
J’ai pas tout suivi de ce que te faisais faire @Hamtaro, mais le truc en rouge dans tes logs signifie qu’il y a un problème avec l’url Mise dans ton config.
Tu peux nous le mettre pour voir ?


#33

merci d’aider hamtaro je doit le désespérer mdr


#34

Tu as oublié l’apostrophe après le 32 de l’adresse, et il manque les //.
Met simplement :

’http://192.168.0.32:8080’


#35

dit moi ces quoi ce"8080"


#36

si je rajoute les deux // ca passe en violer au lieu d’etre en jaune


#37

Imagines tu habites un immeuble ; l’adresse seule de l’immeuble ne permet pas de trouver ton appartement. Il faut aussi ton étage.
Le 192.168.0.32, c’est l’adresse de l’immeuble, et le 8080, c’est ton numéro de porte dans l’immeuble. Comme ça, on est sûr que c’est toi qui reçois le message.
Sinon, tu as testé comme ça ?

Après, je ne connais pas ce module, mais pas sûr qu’il faille le ‘http://‘ devant l’adresse. Si ça marche pas, essaye sans !


#38

je ces pas comment once sert de cette appli mais on dirais bien que cela marche j’ai des périphérique supplémentaire il me semble et tout et dans le vert…
tu ces comment je peu obtenir un résultat ???



/home/pi/.pm2/logs/gladys-netatmo-weather-out-1.log last 50 lines:
1|gladys-n |     at modules.forEach.element (/home/pi/gladys-netatmo-weather/app.js:45:9)
1|gladys-n |     at Array.forEach (<anonymous>)
1|gladys-n |     at netatmo.getStationsData (/home/pi/gladys-netatmo-weather/app.js:38:13)
1|gladys-n |     at emitTwo (events.js:126:13)
1|gladys-n |     at netatmo.emit (events.js:214:7)
1|gladys-n |     at netatmo.<anonymous> (/home/pi/gladys-netatmo-weather/node_modules/netatmo/netatmo.js:224:10)
1|gladys-n |     at Request.self.callback (/home/pi/gladys-netatmo-weather/node_modules/request/request.js:185:22)
1|gladys-n |     at emitTwo (events.js:126:13)
1|gladys-n |     at Request.emit (events.js:214:7)
1|gladys-n |     at Request.<anonymous> (/home/pi/gladys-netatmo-weather/node_modules/request/request.js:1161:10)
1|gladys-n |     at emitOne (events.js:116:13)
1|gladys-n |     at Request.emit (events.js:211:7)
1|gladys-n |     at IncomingMessage.<anonymous> (/home/pi/gladys-netatmo-weather/node_modules/request/request.js:1083:12)
1|gladys-n |     at Object.onceWrapper (events.js:313:30)
1|gladys-n |     at emitNone (events.js:111:20)
1|gladys-n |     at IncomingMessage.emit (events.js:208:7),
1|gladys-n |   error: Error: Invalid URI "https:192.168.0.32//localhost:8080/device?token=e74cc920d280ab4c2ba53d6c104dda7853448427"
1|gladys-n |     at Request.init (/home/pi/gladys-netatmo-weather/node_modules/request/request.js:273:31)
1|gladys-n |     at Request.RP$initInterceptor [as init] (/home/pi/gladys-netatmo-weather/node_modules/request-promise-core/configure/request2.js:45:29)
1|gladys-n |     at new Request (/home/pi/gladys-netatmo-weather/node_modules/request/request.js:127:8)
1|gladys-n |     at request (/home/pi/gladys-netatmo-weather/node_modules/request/index.js:53:10)
1|gladys-n |     at createDevice (/home/pi/gladys-netatmo-weather/lib/createDevice.js:12:12)
1|gladys-n |     at createModule (/home/pi/gladys-netatmo-weather/lib/createModule.js:49:5)
1|gladys-n |     at modules.forEach.element (/home/pi/gladys-netatmo-weather/app.js:45:9)
1|gladys-n |     at Array.forEach (<anonymous>)
1|gladys-n |     at netatmo.getStationsData (/home/pi/gladys-netatmo-weather/app.js:38:13)
1|gladys-n |     at emitTwo (events.js:126:13)
1|gladys-n |     at netatmo.emit (events.js:214:7)
1|gladys-n |     at netatmo.<anonymous> (/home/pi/gladys-netatmo-weather/node_modules/netatmo/netatmo.js:224:10)
1|gladys-n |     at Request.self.callback (/home/pi/gladys-netatmo-weather/node_modules/request/request.js:185:22)
1|gladys-n |     at emitTwo (events.js:126:13)
1|gladys-n |     at Request.emit (events.js:214:7)
1|gladys-n |     at Request.<anonymous> (/home/pi/gladys-netatmo-weather/node_modules/request/request.js:1161:10)
1|gladys-n |     at emitOne (events.js:116:13)
1|gladys-n |     at Request.emit (events.js:211:7)
1|gladys-n |     at IncomingMessage.<anonymous> (/home/pi/gladys-netatmo-weather/node_modules/request/request.js:1083:12)
1|gladys-n |     at Object.onceWrapper (events.js:313:30)
1|gladys-n |     at emitNone (events.js:111:20)
1|gladys-n |     at IncomingMessage.emit (events.js:208:7),
1|gladys-n |   options:
1|gladys-n |    { method: 'POST',
1|gladys-n |      uri: 'https:192.168.0.32//localhost:8080/device?token=e74cc920d280ab4c2ba53d6c104dda7853448427',
1|gladys-n |      body: { device: [Object], types: [Array] },
1|gladys-n |      json: true,
1|gladys-n |      callback: [Function: RP$callback],
1|gladys-n |      transform: undefined,
1|gladys-n |      simple: true,
1|gladys-n |      resolveWithFullResponse: false,
1|gladys-n |      transform2xxOnly: false },
1|gladys-n |   response: undefined }


#39

je confirme je vois le périphérique de ma station maintenant


#40

Alors c’est résolu ? Si c’est le cas, tu cliques sur le petit crayon à côté du titre de ton premier message et tu mets devant [RESOLU]