[RESOLU] PulseAudio change la config Alsamixer après reboot


#1

Bonjour,
j’ai un petit problème avec gladys… j’ai suivi le tuto pour l’installer, elle détecte bien ce que je dis. En revanche elle est incapable de me répondre autrement que par les logs…
Si quelqu’un peut m’éclairer…
Merci d’avance pour votre aide

EDIT: Je me sens débile … J’avais oublier qu’il fallait dire a gladys qu’on est a la maison pour qu’elle puisse nous parler… J’ai cependant un autre problème : Quand je règle mon alsamixer et que je reboot il se remet comme il était avant… c’est assez problématique surtout qu’il se remet a 100…


#2

Salut @REDox,

J’adore !! J’ai fais exactement la même ! Une fois que tu as compris c’est vrai que tu te sens très con :wink:

Pour ALSAmixer je ne sais pas car j’ai pas modifié les paramètres.


#3

Salut,
Ahah, je suis rassuré alors xD
Sinon si quelqu’un a une idée… si ça peut aider j’ai suivie la step 1 et 2 de ce tuto pour mon micro (un re speaker 2 mic) : https://www.hackster.io/idreams/build-your-own-amazon-echo-using-a-rpi-and-respeaker-hat-7f44a0


#4

Salut,
Bon après avoir essayé pas mal de trucs qui ne fonctionnaient pas à base de alsactl store/restore le service etc etc … j’ai finalement trouvé pourquoi je n’arrivais pas à enregistrer mes paramètres d’alsamixer.
Si jamais ca peut aider https://forum.snips.ai/t/respeaker-2-mics-pi-hat-save-alsamixer-settings/1300/3

En gros le “seeed service” réécrit les paramètres au démarrage avec ceux contenus dans /etc/voicecard/wm8960_asound.state

Du coup j’ai fait ca :

sudo mv /etc/voicecard/wm8960_asound.state /etc/voicecard/wm8960_asound.state.old

Fais mes configurations avec alsamixer puis

sudo alsactl store -f /etc/voicecard/wm8960_asound.state

Si ca peut aider !


#5

Salut, merci beaucoup (pas pu apporter de réponses plutôt car très occupé) je passe le sujet en résolu !.


#6

Salut, peut être aussi modifier le titre de ton article en ajoutant ReSpeaker, parce que direct en jack et via bluetooth on a pas ce problème :wink:


#7

Enfaîte, ça ne concerne pas le respeaker mais plutôt PulseAudio (qui est nécessaire pour gérer le respeaker) qui met le volume du speaker a 100%… du coup je vais mettre PulseAudio dans le titre :smiley: merci de me le rappeler .


#8

@REDox , j’utilise aussi pulseaudio et je n’ai pas ce soucis :slight_smile:

lqqqqqqqqqqqqqqqqqqqqqqqqqqqqqq AlsaMixer v1.1.3 qqqqqqqqqqqqqqqqqqqqqqqqqqqqqqk
x    Carte: PulseAudio                               F1:  Aide                 x
x     Puce: PulseAudio                               F2:  Informations Système x
x      Vue: F3:[Lecture] F4: Capture  F5: Tout       F6:  Choisir la carte son x
x Contrôle: Master                                   Esc: Quitter              x 

Je règle le niveau que je veux, je reboot et rien ne change :wink:


#9

Ah… le principale c’est que ça marche et pour toi et pour moi (et pour les autres au passage hein :rofl: )