[RESOLVED] - Probleme de serveur front V4

Bonjour,
Cela fait un moment que j’avais mis de coté Gladys (l’appel de la v4 à été plus fortes que moi) et je m’y remet petit a petit.
Je suis dev web et j’avais commencé un petit module sur ma v3 donc je me disait que je pourrais le recommencer en v4, malheureusement, bien que j’ai pu installer la v4 sur mon windows (sans docker pcq windows pas pro :’( ) le serveur front refuse de démarer et le back me retourne une page écrit "Cannot Get / "

Pour le front c’est étrange, on dirait une erreur :

`

c:\wamp\www\gladys\V4\gladysassistant\front (master -> origin) (gladys-front)
λ npm start

[email protected] start c:\wamp\www\gladys\V4\gladysassistant\front
per-env
`

puis plus rien.

Je ne sais pas si ça viens de ma config ou autre :confused: je suis sur node 10 et npm 6.
J’aimerais développer en local avant de réinstaller Gladys sur mon RPI.

Merci d’avance :slight_smile:

Bon, part soucis de validation, j’ai passé le npm test et c’est pas top :confused: donc je suppose qu mon install a foirée…

Je ne vois rien de mal dans ce que tu décris!

Tu as bien suivi les instructions? (npm install et cie?)

le npm start semble bien commencer, par contre bizarre que ça bloque comme ça…

Salut, j’ai pour souvenir que le module open-zwave pose problème sous windows, WSL est fortement recommandé pour développer la v4 sous windows.

1 Like

wamp peut aussi poser problème ( conflit de port)

@AlexTrovato En effet, WSL est la solution, ça marche nickel merci beaucoup.
ça règle pas vraiment le probleme du developpement sous windows en soit mais c’est pas compliquer a installer ou configurer donc parfait :slight_smile:
Si pas de docker, WSL ^^ fun parce que dans tous les cas c’est pas windows qui est utilisé mais une machine virtuel
bref merci beaucoup :slight_smile:

Oui et performant, je conseil vraiment pour ceux qui sont “bloqués” sous Windows.

Salut, moi je dev avec WSL, et VisualStudio Code en WSL aussi, tout roule parfaitement.

1 Like