Spotify Connect! disponible sur le Gladys Store!


#21

Rectification, je ne pense pas être là ce soir. Si je ne suis pas dispo faites sans moi :). Mais je suis toujours le sujet


#22

@C4rlit0 tu es dispo quand ?


#23

Quand je part du taf ^^
j’y suis encore là :stuck_out_tongue:
je devrais pas tarder :slight_smile:
jte skype en rentrant :wink:


#24

Voici l’Alpha et L’Omega ou plutôt la beta… bref une presque fini, enjoy ! :joy:

https://adriendesola.github.io/gladys-spotify/

@C4rlit0 si tu veux confirmé que tout est clair se serait top !


#25

Arrrgh faut pas release ce genre de choses aussi tard, je vais devoir attendre demain soir avant de tester ça :tired_face:


#26

En installant spotify sur gladys au moment ou il faut cliquer sur configurer pour recevoir une notification. Après avoir cliquer se message apparait:

qu’est que je doit faire???


#27

Je pense que ce n’est pas grave si ?


#28

mais je ne reçois pas de notification


#29

Ah ok. Tu as bien renseigné les paramètres ?


#30

Oui j’ai mis les paramètre demandé


#31

As tu la Box chat de configure sur ton Dashboard ? Ou telegram ?

Sinon connecte toi en ssh à ton RPI et fait la commande

pm2 logs gladys

l’url sera dans les logs


#32

Petite question, j’ai bien tout installé cependant voilà ce que j’ai dans les logs.
Pour info j’ai désinstallé le module Mopidy qui ne fonctionnait pas :

Error: Music : Module mopidy does not exist or does not handle music.
0|gladys   |     at getDeviceType.then (/home/pi/gladys/api/core/music/music.sendCommand.js:9:39)
0|gladys   |     at tryCatcher (/home/pi/gladys/node_modules/bluebird/js/release/util.js:16:23)
0|gladys   |     at Promise._settlePromiseFromHandler (/home/pi/gladys/node_modules/bluebird/js/release/promise.js:512:31)
0|gladys   |     at Promise._settlePromise (/home/pi/gladys/node_modules/bluebird/js/release/promise.js:569:18)
0|gladys   |     at Promise._settlePromise0 (/home/pi/gladys/node_modules/bluebird/js/release/promise.js:614:10)
0|gladys   |     at Promise._settlePromises (/home/pi/gladys/node_modules/bluebird/js/release/promise.js:693:18)
0|gladys   |     at Async._drainQueue (/home/pi/gladys/node_modules/bluebird/js/release/async.js:133:16)
0|gladys   |     at Async._drainQueues (/home/pi/gladys/node_modules/bluebird/js/release/async.js:143:10)
0|gladys   |     at Immediate.Async.drainQueues (/home/pi/gladys/node_modules/bluebird/js/release/async.js:17:14)
0|gladys   |     at runCallback (timers.js:672:20)
0|gladys   |     at tryOnImmediate (timers.js:645:5)
0|gladys   |     at processImmediate [as _immediateCallback] (timers.js:617:5)


#33

Regarde ta box chat le lien est dedans


#34

merci j’ai reçu l’url et installation a parfaitement fonctionné.
ce module es vraiment géniale bravo!!! :slight_smile:
juste petite question comment faire en sorte que gladys mette la musique depuis spotifay dans un scénario???


#35

Moi j’ai une autre erreur lorsque je clique sur configuration :wink:
ça c’est qui apparaît dans le pm2 logs:
Server Error:
0|gladys | TypeError: Cannot read property ‘createAuthorizeURL’ of null
0|gladys | at Hook.setup (/home/pi/gladys/api/hooks/gladys-spotify/lib/setup.js:22:32)
0|gladys | at Hook.wrapper [as setup] (/home/pi/gladys/node_modules/@sailshq/lodash/lib/index.js:3250:19)
0|gladys | at Object.module.exports [as config] (/home/pi/gladys/api/core/module/module.config.js:9:43)
0|gladys | at Object.config (/home/pi/gladys/api/controllers/ModuleController.js:35:23)
0|gladys | at wrapper (/home/pi/gladys/node_modules/@sailshq/lodash/lib/index.js:3250:19)
0|gladys | at routeTargetFnWrapper (/home/pi/gladys/node_modules/sails/lib/router/bind.js:181:5)
0|gladys | at callbacks (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:164:37)
0|gladys | at param (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:138:11)
0|gladys | at param (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:135:11)
0|gladys | at pass (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:145:5)
0|gladys | at nextRoute (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:100:7)
0|gladys | at callbacks (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:167:11)
0|gladys | at module.exports (/home/pi/gladys/api/policies/checkToken.js:25:12)
0|gladys | at routeTargetFnWrapper (/home/pi/gladys/node_modules/sails/lib/router/bind.js:181:5)
0|gladys | at callbacks (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:164:37)
0|gladys | at param (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:138:11)
0|gladys | at param (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:135:11)
0|gladys | at pass (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:145:5)
0|gladys | at nextRoute (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:100:7)
0|gladys | at callbacks (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:167:11)
0|gladys | at _sendHeaders (/home/pi/gladys/node_modules/sails/lib/hooks/cors/to-prepare-send-headers.js:91:7)
0|gladys | at routeTargetFnWrapper (/home/pi/gladys/node_modules/sails/lib/router/bind.js:181:5)
0|gladys | at callbacks (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:164:37)
0|gladys | at param (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:138:11)
0|gladys | at pass (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:145:5)
0|gladys | at nextRoute (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:100:7)
0|gladys | at callbacks (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:167:11)
0|gladys | at sails.router.bind._middlewareType (/home/pi/gladys/node_modules/sails/lib/hooks/csrf/index.js:148:11)

EDIT: j’ai trouvé en fait j’avais simplement mal orthographié la clé spotify_redirect_url


#36

En fait malgré la correction que j’ai faite, le problème reste le même et j’ai toujours le même rapport d’erreur dans pm2 logs.


#37

vérifie bien les settings, et redémarre Gladys un coup si nécessaire


#38

Tu peux utiliser les méthodes music de gladys

gladys.music.playPlaylist( <uri> );
gladys.music.pause();
gladys.music.play(); 

etc…


#39

J’ai corrigé mon problème dans les paramètres j’avais écris URL au lieu de URI mais maintenant quand j’exécute le script pour lire de la musique, j’ai ça comme erreur dans les pm2 logs: Unhandled rejection WebapiError: Unauthorized


#40

maintenant quand tu clique sur config tu vas recevoir le link d’autorisation tu le colle dans ton navigateur tu suis les instructions et voilà :slight_smile: