Stockage des paramétres

#1

Bonsoir, mon installation étant récente je tatonne pas mal, je fais des boulettes, des tests etc…
Par exemple je viens d’essayer le module caldav et je me suis planté dans l’adresse du calendrier, mon souci c’est que je n’arrive pas à supprimer les mauvais paramètres, donc je voudrais savoir ou ils sont stockés pour pouvoir les effacer à la main.
Merci

#2

Tu n’arrives pas à les supprimer?

Quand tu cliques sur supprimer il ne se passe rien?

Ils sont stocké dans la DB MariaDB “gladys” sur le Raspberry Pi.

#3

Bonjour pierre-gilles, en effet je ne peux pas supprimer certains paramètres en cliquant dessus.
De toute façon ce matin je n’arrive pas à accéder à gladys. :slightly_frowning_face:

#4

Bizarre. Tu n’avais pas redémarré Gladys par hasard entre le moment ou tu avais ouvert l’interface et le moment ou tu essayais de supprimer un paramètre? Il se peut que ta session avait expiré, il est vrai que Gladys 3 n’est pas très pratique sur la gestion des sessions quand on redémarre, c’est un point qui est grandement amélioré dans Gladys 4!

Pour ton problème d’accès à Gladys, tu as plus d’informations dans les logs de Gladys par exemple?

Tu peux les voir avec la commande:

pm2 logs gladys
#5

Voilà mes logs pm2 (j’ai mis seulement les erreurs)

0|gladys   |     at callbacks (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:167:11)
0|gladys   |     at _sendHeaders (/home/pi/gladys/node_modules/sails/lib/hooks/cors/to-prepare-send-headers.js:91:7)
0|gladys   |     at routeTargetFnWrapper (/home/pi/gladys/node_modules/sails/lib/router/bind.js:181:5)
0|gladys   |     at callbacks (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:164:37)
0|gladys   |     at param (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:138:11)
0|gladys   |     at pass (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:145:5)
0|gladys   | Server Error:
0|gladys   | Error: No weather provider available
0|gladys   |     at getWeatherProvider (/home/pi/gladys/api/core/weather/weather.get.js:72:27)
0|gladys   |     at Object.get (/home/pi/gladys/api/core/weather/weather.get.js:53:10)
0|gladys   |     at Object.get (/home/pi/gladys/api/controllers/WeatherController.js:24:8)
0|gladys   |     at wrapper (/home/pi/gladys/node_modules/@sailshq/lodash/lib/index.js:3275:19)
0|gladys   |     at routeTargetFnWrapper (/home/pi/gladys/node_modules/sails/lib/router/bind.js:181:5)
0|gladys   |     at callbacks (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:164:37)
0|gladys   |     at param (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:138:11)
0|gladys   |     at pass (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:145:5)
0|gladys   |     at nextRoute (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:100:7)
0|gladys   |     at callbacks (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:167:11)
0|gladys   |     at module.exports (/home/pi/gladys/api/policies/checkToken.js:4:12)
0|gladys   |     at routeTargetFnWrapper (/home/pi/gladys/node_modules/sails/lib/router/bind.js:181:5)
0|gladys   |     at callbacks (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:164:37)
0|gladys   |     at param (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:138:11)
0|gladys   |     at pass (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:145:5)
0|gladys   |     at nextRoute (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:100:7)
0|gladys   |     at callbacks (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:167:11)
0|gladys   |     at _sendHeaders (/home/pi/gladys/node_modules/sails/lib/hooks/cors/to-prepare-send-headers.js:91:7)
0|gladys   |     at routeTargetFnWrapper (/home/pi/gladys/node_modules/sails/lib/router/bind.js:181:5)
0|gladys   |     at callbacks (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:164:37)
0|gladys   |     at param (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:138:11)
0|gladys   |     at pass (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:145:5)
0|gladys   | Warning: connect.session() MemoryStore is not
0|gladys   | designed for a production environment, as it will leak
0|gladys   | memory, and will not scale past a single process.
0|gladys   | Warning: connect.session() MemoryStore is not
0|gladys   | designed for a production environment, as it will leak
0|gladys   | memory, and will not scale past a single process.
0|gladys   | 
0|gladys   | =*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=
0|gladys   | WARNING: You currently have your default CORS settings configured to allow
0|gladys   | all requests from all origins, with credentials.  This may leave your app
0|gladys   | open to attack by third-party sites!  Consider making your `origins` setting
0|gladys   | more restrictive or setting `credentials` to false, or else make certain that
0|gladys   | none of your routes perform sensitive actions or reveal secure information.
0|gladys   | =*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=
0|gladys   | 
0|gladys   | -------------------------------------------------------
0|gladys   | :: Mon May 06 2019 09:15:34 GMT+0200 (CEST)
0|gladys   | Environment : production
0|gladys   | Port        : 8080
0|gladys   | -------------------------------------------------------

Par contre j’ai réussi à me connecter en local en précisant bien le port dans l’adresse
http://gladys.local:8080
Mais avec mon nom de domaine (j’ai essayé derrière un vpn) ou en local avec le https je n’y arrive pas.

#6

Je ne vois pas dans tes logs d’erreur spécifique à un potentiel problème d’accès…

Si tu y accès en local mais pas avec ton domaine/HTTPS, il y plus un problème au niveau de ta conf Nginx à mon avis!

#7

J’ai regardé les logs de nginx, mais ils sont vides.

#8

J’ai réussi à refaire fonctionner le https simplement en ré-exécutant le script ./enable-ssl-gladys.sh
Par contre j’ai toujours le problème des paramètres ineffaçables.(le paramètre CALDAV_URL)
J’ai pourtant supprimé le module, mis à jour les données, redémarré Gladys mais rien à faire.
De plus quand j’essaie la màj ou de redémarrer Gladys le paramètre CALDAV_PASSWORD réapparait!

#9

C’est vraiment bizarre! Je viens de tester chez moi et ça marche nickel.

Tu peux ouvrir ta console de ton navigateur (Clic droit sur la page => inspecter l’élement => console) et cliquer sur “supprimer” de la variable, et m’envoyer une capture d’écran ?

#10

Bonjour, voilà ce que ça donne

[Edit: photo retiré pour masquer l’URL de ton calendrier]

#11

Mmm je comprends mieux… tu as mis l’URL dans le nom du paramètre.

C’est effectivement un bug dans Gladys dans ce cas précis !

Si tu veux supprimer cette ligne en particulier tu peux aller dans la DB MariaDB du coup, tant que le bug n’est pas résolu tu ne pourras pas le supprimer.

Après bon ça ne change pas grand chose si la ligne reste comme ça chez toi ^^

#12

Quelle couillon je suis! Après je m’étonne que rien ne marche :yum:
Je pense que je me suis trompé quand j’ai essayé le module Forecast et j’ai mis la clé de l’api dans la colonne clé :grin: du coup j’ai tout fait à l’envers

1 Like