[TUTORIEL] Connection de Gladys vers une enceinte bluetooth

Bonjour, je voudrais que Gladys parle ou envoi de la musique vers
une enceinte bluetooth, mais je ne sais pas comment m’y prendre et
par ou commencer.
Quelqu’un peut me dire comment faire ou me guider vers un tuto qui
fonctionne sans probleme svp ?

1000 merci à tous.
Cdlt.

Salut

Tu as dû avoir une suggestion de sujet en tapant ton message sur le forum pour trouver ton bonheur.
Récemment, il y a eu des choses de faites, je t’invite à aller voir ici :

Faudrait d’ailleurs que je revois certaines choses dessus.

J’ai l’impression que j’ai des déconnexion de temps en temps et que Gladys redémarre aussi de temps en temps.

Si lors de la configuration le son saturé pas mal, il faut faire des mises a jour, dans syslog on peut y voir du “skip” niveau bluetoothd il me semble.

Je referais des test a partir d’une version “clean” de Gladys et je ferais un petit script shell qui s’occupe de faire toute la conf dessus.

Merci. Mais je voulais avoir un avis connaisseur avec le moins de galère possible.
et la bimm probleme : j’essaye de rattacher mon enceinte shoqbox

Mon pair est OK
[bluetooth]# pair 00:1D:DF:60:7F:BB
Attempting to pair with 00:1D:DF:60:7F:BB
[CHG] Device 00:1D:DF:60:7F:BB Connected: yes
[CHG] Device 00:1D:DF:60:7F:BB UUIDs: 00001108-0000-1000-8000-00805f9b34fb
[CHG] Device 00:1D:DF:60:7F:BB UUIDs: 0000110b-0000-1000-8000-00805f9b34fb
[CHG] Device 00:1D:DF:60:7F:BB UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device 00:1D:DF:60:7F:BB UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device 00:1D:DF:60:7F:BB UUIDs: 0000111e-0000-1000-8000-00805f9b34fb
[CHG] Device 00:1D:DF:60:7F:BB ServicesResolved: yes
[CHG] Device 00:1D:DF:60:7F:BB Paired: yes
Pairing successful

Mon trust est OK
[bluetooth]# trust 00:1D:DF:60:7F:BB
Changing 00:1D:DF:60:7F:BB trust succeeded

PROBLEME AVEC MON CONNECT
[bluetooth]# connect 00:1D:DF:60:7F:BB
Attempting to connect to 00:1D:DF:60:7F:BB
Failed to connect: org.bluez.Error.Failed
[bluetooth]#

Help svp
Merci.

Tu peux donner les logs dans /var/log/syslog ?

Est-ce que pulseaudio est lancer ?

pulseaudio --start

J’ai déjà eu cette erreur, mais cela venait de pulseaudio

Merci pour ton aide.
quand je lance les logs je n’ai pas accès
et pulseaudio n’est pas connu.

[email protected]:~ $ pulseaudio --start
-bash: pulseaudio: command not found
[email protected]:~ $ /var/log/syslog
-bash: /var/log/syslog: Permission denied

cdlt

Est ce que tu as fait cette partie ?

Installation des paquets :

sudo apt-get install blueman pulseaudio pulseaudio-module-bluetooth

Ajout de l’utilisateur pi dans le groupe lp

Cela permet à l’utilisateur pi de “jouer” avec le bluetooth

sudo usermod -a -G lp pi

Pour avoir les logs de syslog :

sudo cat /var/log/syslog

oui j’avais deja lancer cette partie. Je l’ai relancé et la 1ere fois ca n’a pas duré si longtemps.
et la j’ai un message d’erreur à la fin

Unpacking pulseaudio-module-bluetooth (10.0-1+deb9u1) …
Errors were encountered while processing:
/tmp/apt-dpkg-install-5uuc7E/131-libgl1-mesa-dri_13.0.6-1+rpi2_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]:~ $

C’est grave docteur ?

Il y a eu un soucis dans l’installation des paquets, donc forcément la suite ne fonctionne pas.

Tu as quoi comme modèle de raspberry ?

Tape ces commandes et donnes les retour :

 sudo dpkg -l | grep -i blue

Le retour devrait être

ii  blueman                           2.0.4-1+b4                        armhf        Graphical bluetooth manager
ii  bluez                             5.43-2+rpt2+deb9u2                armhf        Bluetooth tools and daemons
ii  bluez-firmware                    1.2-3+rpt6                        all          Firmware for Bluetooth devices
ii  bluez-obexd                       5.43-2+rpt2+deb9u2                armhf        bluez obex daemon
ii  libbluetooth3:armhf               5.43-2+rpt2+deb9u2                armhf        Library to use the BlueZ Linux Bluetooth stack
ii  pi-bluetooth                      0.1.10                            all          Raspberry Pi 3 bluetooth
ii  pulseaudio-module-bluetooth       10.0-1+deb9u1                     armhf        Bluetooth module for PulseAudio sound server

Vérifier les paquets pulse

sudo dpkg -l | grep -i pulse

Retour

ii  libpulse-mainloop-glib0:armhf     10.0-1+deb9u1                     armhf        PulseAudio client libraries (glib support)
ii  libpulse0:armhf                   10.0-1+deb9u1                     armhf        PulseAudio client libraries
ii  libpulsedsp:armhf                 10.0-1+deb9u1                     armhf        PulseAudio OSS pre-load library
ii  pulseaudio                        10.0-1+deb9u1                     armhf        PulseAudio sound server
ii  pulseaudio-module-bluetooth       10.0-1+deb9u1                     armhf        Bluetooth module for PulseAudio sound server
ii  pulseaudio-utils                  10.0-1+deb9u1                     armhf        Command line tools for the PulseAudio sound server

Après tu peux tenter cela :

  • Désinstallation des paquets
sudo apt-get remove blueman pulseaudio pulseaudio-module-bluetooth --purge

Mise à jour

sudo apt-get update 

Réinstallation des paquets

sudo apt-get install blueman pulseaudio pulseaudio-module-bluetooth

bonjour
Mon Raspberry Pi Carte Mère 3 Model B Quad Core CPU 1.2 GHz 1 Go RAM

j’ai lancé ce que tu m’as demandé
Resultat

[email protected]:~ $ sudo dpkl -l | grep -i blue
sudo: dpkl: command not found
[email protected]:~ $ sudo dpkl -l | grep -i blue
sudo: dpkl: command not found
[email protected]:~ $ ^C
[email protected]:~ $ sudo dpkl -l | grep -i pulse
sudo: dpkl: command not found
[email protected]:~ $ sudo apt-get remove blueman pulsaudio pulseaudio-module-bluetooth -                                                                                                             -purge
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package pulsaudio
[email protected]:~ $ sudo apt-get update
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Get:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15.0 kB]
Hit:3 https://dl.yarnpkg.com/debian stable InRelease
Get:4 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages [11.7                                                                                                              MB]
Fetched 11.7 MB in 46s (253 kB/s)
Reading package lists... Done
[email protected]:~ $ sudo apt-get install blueman pulseaudio pulseaudio-module-bluetooth                                                                                                             Reading package lists... Done
Building dependency tree
Reading state information... Done
blueman is already the newest version (2.0.4-1+b4).
pulseaudio is already the newest version (10.0-1+deb9u1).
pulseaudio-module-bluetooth is already the newest version (10.0-1+deb9u1).
The following packages were automatically installed and are no longer required:
  libarchive13 libdrm-freedreno1 liblzo2-2 libtxc-dxtn-s2tc
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
160 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]

j'ai lancé Y quand meme pour voir . 
patatra
Setting up libxi6:armhf (2:1.7.9-1) ...
Setting up libxcb-present0:armhf (1.12-1) ...
Setting up libsbc1:armhf (1.3-2) ...
Setting up libx265-95:armhf (2.1-2) ...
Setting up libtdb1:armhf (1.3.11-2) ...
Setting up libxinerama1:armhf (2:1.1.3-1+b1) ...
Setting up libxcb-dri2-0:armhf (1.12-1) ...
Setting up libxcb-dri3-0:armhf (1.12-1) ...
Setting up libxcb-glx0:armhf (1.12-1) ...
Setting up libical2:armhf (2.0.0-0.5+b1) ...
Setting up libtwolame0:armhf (0.3.13-2) ...
Setting up libjson-glib-1.0-common (1.2.6-1) ...
Setting up libxcb-render0:armhf (1.12-1) ...
Setting up libopenjp2-7:armhf (2.1.2-1.1+deb9u2) ...
Setting up libasyncns0:armhf (0.8-6) ...
Setting up libx264-148:armhf (2:0.148.2748+git97eaef2-1+rpi1) ...
Setting up glib-networking-common (2.50.0-1) ...
Setting up libxfixes3:armhf (1:5.0.3-1) ...
Processing triggers for mime-support (3.60) ...
Setting up libdrm-amdgpu1:armhf (2.4.74-1) ...
Setting up libdrm-freedreno1:armhf (2.4.74-1) ...
Setting up libwavpack1:armhf (5.0.0-2+deb9u2) ...
Setting up liblcms2-2:armhf (2.8-4+deb9u1) ...
Setting up libdbus-glib-1-2:armhf (0.108-2) ...
Setting up libatspi2.0-0:armhf (2.22.0-6+deb9u1) ...
Setting up libsoxr0:armhf (0.1.2-2) ...
Processing triggers for libglib2.0-0:armhf (2.50.3-2) ...
Setting up libwebrtc-audio-processing1:armhf (0.3-1) ...
Setting up libxshmfence1:armhf (1.2-1) ...
Setting up libllvm3.9:armhf (1:3.9.1-9+rpi1) ...
Setting up libbluetooth3:armhf (5.43-2+rpt2+deb9u2) ...
Setting up libproxy1v5:armhf (0.4.14-2) ...
Setting up libwebpmux2:armhf (0.5.2-1) ...
Setting up libvdpau1:armhf (1.1.1-6) ...
Setting up libgdk-pixbuf2.0-common (2.36.5-2+deb9u2) ...
Setting up glib-networking-services (2.50.0-1) ...
Setting up libdatrie1:armhf (0.2.10-4) ...
Setting up libshine3:armhf (3.1.0-5) ...
Setting up libtxc-dxtn-s2tc:armhf (1.0+git20151227-2) ...
update-alternatives: using /usr/lib/arm-linux-gnueabihf/s2tc/libtxc_dxtn.so to provide /usr/lib/arm-linux-gnueabihf/libtxc_dxtn.so (libtxc-dxtn-arm-linux-gnueabihf) in auto mode
Setting up libglapi-mesa:armhf (13.0.6-1+rpi2) ...
Setting up libspeex1:armhf (1.2~rc1.2-1) ...
Setting up libxvidcore4:armhf (2:1.3.4-1) ...
Setting up libgirepository-1.0-1:armhf (1.50.0-1) ...
Setting up libvpx4:armhf (1.6.1-3+deb9u1) ...
Setting up libopus0:armhf (1.2~alpha2-1) ...
Setting up libva1:armhf (1.7.3-2) ...
Setting up libjson-glib-1.0-0:armhf (1.2.6-1) ...
Setting up libgraphite2-3:armhf (1.3.10-1) ...
Setting up libcroco3:armhf (0.6.11-3) ...
Setting up libxcb-sync1:armhf (1.12-1) ...
Setting up libogg0:armhf (1.3.2-1) ...
Setting up libatk1.0-data (2.22.0-1) ...
Setting up libx11-xcb1:armhf (2:1.6.4-3+deb9u1) ...
Setting up libpixman-1-0:armhf (0.34.0-1) ...
Setting up libmp3lame0:armhf (3.99.5+repack1-9) ...
Setting up gir1.2-glib-2.0:armhf (1.50.0-1) ...
Setting up libdbusmenu-glib4:armhf (12.10.2-2) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...
Segmentation fault
ldconfig: Path `/lib/arm-linux-gnueabihf' given more than once
ldconfig: Path `/usr/lib/arm-linux-gnueabihf' given more than once
/opt/vc/lib:
        libcontainers.so -> libcontainers.so
        libvcsm.so -> libvcsm.so
        libvchiq_arm.so -> libvchiq_arm.so
        libmmal_components.so -> libmmal_components.so
        libbrcmGLESv2.so -> libbrcmGLESv2.so
        libdebug_sym.so -> libdebug_sym.so
        libmmal_core.so -> libmmal_core.so
        libvcos.so -> libvcos.so
        libmmal_vc_client.so -> libmmal_vc_client.so
        libbrcmWFC.so -> libbrcmWFC.so
        libbrcmOpenVG.so -> libbrcmOpenVG.so
        libbcm_host.so -> libbcm_host.so
        libbrcmEGL.so -> libbrcmEGL.so
        libmmal.so -> libmmal.so
        libmmal_util.so -> libmmal_util.so
        libopenmaxil.so -> libopenmaxil.so
        libelftoolchain.so -> libelftoolchain.so
        libdtovl.so -> libdtovl.so
/lib/arm-linux-gnueabihf:
        libnss_mdns6_minimal.so.2 -> libnss_mdns6_minimal.so.2
        libexpat.so.1 -> libexpat.so.1.6.2
        libncursesw.so.5 -> libncursesw.so.5.9
        libdl.so.2 -> libdl-2.24.so
        libsepol.so.1 -> libsepol.so.1
        libnfsidmap.so.0 -> libnfsidmap.so.0.3.0
        libpam_misc.so.0 -> libpam_misc.so.0.82.0
        libgpg-error.so.0 -> libgpg-error.so.0.21.0
        libSegFault.so -> libSegFault.so
        libsystemd.so.0 -> libsystemd.so.0.17.0
        libmemusage.so -> libmemusage.so
        libnss_mdns_minimal.so.2 -> libnss_mdns_minimal.so.2
        libdevmapper.so.1.02.1 -> libdevmapper.so.1.02.1
        libgcc_s.so.1 -> libgcc_s.so.1
        libnss_mdns4.so.2 -> libnss_mdns4.so.2
        libthread_db.so.1 -> libthread_db-1.0.so
        libnsl.so.1 -> libnsl-2.24.so
        libanl.so.1 -> libanl-2.24.so
        libisc-export.so.160 -> libisc-export.so.160.0.0
        libnss_mdns.so.2 -> libnss_mdns.so.2
        libss.so.2 -> libss.so.2.0
        libkeyutils.so.1 -> libkeyutils.so.1.5
        libcom_err.so.2 -> libcom_err.so.2.1
        libresolv.so.2 -> libresolv-2.24.so
        libcap.so.2 -> libcap.so.2.25
        libncurses.so.5 -> libncurses.so.5.9
        libhistory.so.6 -> libhistory.so.6.3
        libreadline.so.5 -> libreadline.so.5.2
        libgcrypt.so.20 -> libgcrypt.so.20.1.6
        libpopt.so.0 -> libpopt.so.0.0.0
        libpam.so.0 -> libpam.so.0.83.1
        libe2p.so.2 -> libe2p.so.2.3
        libpcprofile.so -> libpcprofile.so
        libattr.so.1 -> libattr.so.1.1.0
        libnl-3.so.200 -> libnl-3.so.200.22.0
        libudev.so.0 -> libudev.so.0.13.0
        libBrokenLocale.so.1 -> libBrokenLocale-2.24.so
        libuuid.so.1 -> libuuid.so.1.3.0
        libnss_nisplus.so.2 -> libnss_nisplus-2.24.so
        libtinfo.so.5 -> libtinfo.so.5.9
        libaudit.so.1 -> libaudit.so.1.0.0
        libnss_mdns4_minimal.so.2 -> libnss_mdns4_minimal.so.2
        libblkid.so.1 -> libblkid.so.1.1.0
        libply.so.4 -> libply.so.4.0.0
        libacl.so.1 -> libacl.so.1.1.0
        libfdisk.so.1 -> libfdisk.so.1.1.0
        libiw.so.30 -> libiw.so.30
        libkmod.so.2 -> libkmod.so.2.3.1
        libdbus-1.so.3 -> libdbus-1.so.3.14.15
        libprocps.so.6 -> libprocps.so.6.0.0
        libusb-0.1.so.4 -> libusb-0.1.so.4.4.4
        libsmartcols.so.1 -> libsmartcols.so.1.1.0
        libapparmor.so.1 -> libapparmor.so.1.4.0
        libnss_mdns6.so.2 -> libnss_mdns6.so.2
        libidn.so.11 -> libidn.so.11.6.16
        libreadline.so.6 -> libreadline.so.6.3
        libm.so.6 -> libm-2.24.so
        libusb-1.0.so.0 -> libusb-1.0.so.0.1.0
        libcap-ng.so.0 -> libcap-ng.so.0.0.0
        liblzma.so.5 -> liblzma.so.5.2.2
        librt.so.1 -> librt-2.24.so
        libpamc.so.0 -> libpamc.so.0.82.1
        libply-boot-client.so.4 -> libply-boot-client.so.4.0.0
        libparted.so.2 -> libparted.so.2.0.1
        libwrap.so.0 -> libwrap.so.0.7.6
        libnss_compat.so.2 -> libnss_compat-2.24.so
        libext2fs.so.2 -> libext2fs.so.2.4
        libdns-export.so.162 -> libdns-export.so.162.1.3
        libpthread.so.0 -> libpthread-2.24.so
        libcidn.so.1 -> libcidn-2.24.so
        libreadline.so.7 -> libreadline.so.7.0
        liblzo2.so.2 -> liblzo2.so.2.0.0
        libc.so.6 -> libc-2.24.so
        libselinux.so.1 -> libselinux.so.1
        libbz2.so.1.0 -> libbz2.so.1.0.4
        libmount.so.1 -> libmount.so.1.1.0
        libcryptsetup.so.4 -> libcryptsetup.so.4.7.0
        libply-splash-graphics.so.4 -> libply-splash-graphics.so.4.0.0
        libtirpc.so.1 -> libtirpc.so.1.0.10
        libmnl.so.0 -> libmnl.so.0.2.0
ldconfig: /lib/arm-linux-gnueabihf/ld-2.24.so is the dynamic linker, ignoring

        ld-linux-armhf.so.3 -> ld-2.24.so
        libnss_nis.so.2 -> libnss_nis-2.24.so
        libhistory.so.7 -> libhistory.so.7.0
        libnss_hesiod.so.2 -> libnss_hesiod-2.24.so
        libz.so.1 -> libz.so.1.2.8
        libutil.so.1 -> libutil-2.24.so
        libpcre.so.3 -> libpcre.so.3.13.3
        libglib-2.0.so.0 -> libglib-2.0.so.0.5000.3
        libsysfs.so.2 -> libsysfs.so.2.0.1
        libply-splash-core.so.4 -> libply-splash-core.so.4.0.0
        libudev.so.1 -> libudev.so.1.6.5
        libnl-genl-3.so.200 -> libnl-genl-3.so.200.22.0
        libhistory.so.5 -> libhistory.so.5.2
        libbsd.so.0 -> libbsd.so.0.8.3
        libnss_files.so.2 -> libnss_files-2.24.so
        libaio.so.1 -> libaio.so.1.0.1
        libslang.so.2 -> libslang.so.2.3.1
        libseccomp.so.2 -> libseccomp.so.2.3.1
        libcrypt.so.1 -> libcrypt-2.24.so
        libnss_dns.so.2 -> libnss_dns-2.24.so
/usr/lib/arm-linux-gnueabihf:
Segmentation fault
dpkg: error processing package libc-bin (--configure):
 subprocess installed post-installation script returned error exit status 139
Setting up libepoxy0:armhf (1.3.1-2) ...
Setting up libatk1.0-0:armhf (2.22.0-1) ...
Setting up libsnappy1v5:armhf (1.1.3-3) ...
Setting up rtkit (0.11-4) ...
Setting up bluez-obexd (5.43-2+rpt2+deb9u2) ...
Processing triggers for systemd (232-25+deb9u6) ...
/var/lib/dpkg/info/systemd.postinst: 1: /var/lib/dpkg/info/systemd.postinst: !: not found
/var/lib/dpkg/info/systemd.postinst: 1: /var/lib/dpkg/info/systemd.postinst: Syntax error: end of file unexpected (expecting ")")
dpkg: error processing package systemd (--configure):
 subprocess installed post-installation script returned error exit status 2
Setting up libltdl7:armhf (2.4.6-2) ...
Setting up libatk-bridge2.0-0:armhf (2.22.0-2) ...
Setting up libjack-jackd2-0:armhf (1.9.10+20150825git1ed50c92~dfsg-5) ...
Setting up libdconf1:armhf (0.26.0-2) ...
Setting up libxcomposite1:armhf (1:0.4.4-2) ...
Setting up libzvbi-common (0.2.35-13) ...
Setting up libxcb-shm0:armhf (1.12-1) ...
Setting up libxrender1:armhf (1:0.9.10-1) ...
Setting up libsensors4:armhf (1:3.4.0-4) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up libavahi-client3:armhf (0.6.32-2) ...
Setting up libva-drm1:armhf (1.7.3-2) ...
Setting up libdrm-radeon1:armhf (2.4.74-1) ...
Setting up liborc-0.4-0:armhf (1:0.4.26-2) ...
Setting up libcolord2:armhf (1.3.3-2) ...
Setting up libthai-data (0.1.26-1) ...
Processing triggers for dbus (1.10.26-0+deb9u1) ...
Setting up libxxf86vm1:armhf (1:1.1.4-1) ...
Setting up libzvbi0:armhf (0.2.35-13) ...
Setting up libdrm-nouveau2:armhf (2.4.74-1) ...
Setting up libxft2:armhf (2.3.2-1) ...
Setting up libvorbis0a:armhf (1.3.5-4+deb9u2) ...
Setting up x11-common (1:7.7+19) ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Setting up hicolor-icon-theme (0.15-1) ...
Setting up libgsm1:armhf (1.0.13-4) ...
Setting up libspeexdsp1:armhf (1.2~rc1.2-1) ...
Setting up libxrandr2:armhf (2:1.5.1-1) ...
Setting up libpolkit-gobject-1-0:armhf (0.105-18+deb9u1) ...
Setting up libva-x11-1:armhf (1.7.3-2) ...
Setting up fontconfig (2.11.0-6.7) ...
Regenerating fonts cache... done.
Setting up libcups2:armhf (2.2.1-8+deb9u2) ...
Setting up libcairo2:armhf (1.14.8-1+rpi1) ...
Setting up gir1.2-atk-1.0:armhf (2.22.0-1) ...
Setting up python3-dbus (1.2.4-1) ...
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 34, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python3/debpython/__init__.py", line 8, in <module>
    from pickle import dumps
  File "/usr/lib/python3.5/pickle.py", line 36, in <module>
    import _compat_pickle
  File "<frozen importlib._bootstrap>", line 969, in _find_and_load
  File "<frozen importlib._bootstrap>", line 958, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 673, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 669, in exec_module
  File "<frozen importlib._bootstrap_external>", line 773, in get_code
  File "<frozen importlib._bootstrap_external>", line 484, in _compile_bytecode
ValueError: bad marshal data (invalid reference)
dpkg: error processing package python3-dbus (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up libxdamage1:armhf (1:1.1.4-2+b1) ...
Setting up libavutil55:armhf (7:3.2.10-1~deb9u1+rpt2) ...
Setting up dconf-service (0.26.0-2) ...
Setting up libpolkit-agent-1-0:armhf (0.105-18+deb9u1) ...
Setting up mesa-vdpau-drivers:armhf (13.0.6-1+rpi2) ...
Setting up libgdk-pixbuf2.0-0:armhf (2.36.5-2+deb9u2) ...
g_module_open() failed for /usr/lib/arm-linux-gnueabihf/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so: /usr/lib/arm-linux-gnueabihf/libharfbuzz.so.0: cannot read file data
Setting up libcairo-gobject2:armhf (1.14.8-1+rpi1) ...
Setting up libflac8:armhf (1.3.2-1) ...
Setting up gir1.2-gdkpixbuf-2.0:armhf (2.36.5-2+deb9u2) ...
Setting up libharfbuzz0b:armhf (1.4.2-1) ...
Setting up libthai0:armhf (0.1.26-1) ...
Setting up python3-gi (3.22.0-2) ...
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 34, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python3/debpython/__init__.py", line 8, in <module>
    from pickle import dumps
  File "/usr/lib/python3.5/pickle.py", line 36, in <module>
    import _compat_pickle
  File "<frozen importlib._bootstrap>", line 969, in _find_and_load
  File "<frozen importlib._bootstrap>", line 958, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 673, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 669, in exec_module
  File "<frozen importlib._bootstrap_external>", line 773, in get_code
  File "<frozen importlib._bootstrap_external>", line 484, in _compile_bytecode
ValueError: bad marshal data (invalid reference)
dpkg: error processing package python3-gi (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up libswresample2:armhf (7:3.2.10-1~deb9u1+rpt2) ...
Setting up libxtst6:armhf (2:1.2.3-1) ...
Setting up gtk-update-icon-cache (3.22.11-1+rpi3) ...
Setting up libxcursor1:armhf (1:1.1.14-1+deb9u2) ...
Setting up libpolkit-backend-1-0:armhf (0.105-18+deb9u1) ...
Setting up libgl1-mesa-glx:armhf (13.0.6-1+rpi2) ...
Setting up mesa-va-drivers:armhf (13.0.6-1+rpi2) ...
Setting up libpango-1.0-0:armhf (1.40.5-1) ...
Setting up libice6:armhf (2:1.0.9-2) ...
Setting up python3-cairo (1.10.0+dfsg-5) ...
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 34, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python3/debpython/__init__.py", line 8, in <module>
    from pickle import dumps
  File "/usr/lib/python3.5/pickle.py", line 36, in <module>
    import _compat_pickle
  File "<frozen importlib._bootstrap>", line 969, in _find_and_load
  File "<frozen importlib._bootstrap>", line 958, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 673, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 669, in exec_module
  File "<frozen importlib._bootstrap_external>", line 773, in get_code
  File "<frozen importlib._bootstrap_external>", line 484, in _compile_bytecode
ValueError: bad marshal data (invalid reference)
dpkg: error processing package python3-cairo (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up libvorbisenc2:armhf (1.3.5-4+deb9u2) ...
dpkg: dependency problems prevent configuration of blueman:
 blueman depends on python3-dbus; however:
  Package python3-dbus is not configured yet.
 blueman depends on python3-gi; however:
  Package python3-gi is not configured yet.
 blueman depends on python3-cairo; however:
  Package python3-cairo is not configured yet.

dpkg: error processing package blueman (--configure):
 dependency problems - leaving unconfigured
Setting up libtheora0:armhf (1.1.1+dfsg.1-14) ...
Setting up dconf-gsettings-backend:armhf (0.26.0-2) ...
Setting up libnotify4:armhf (0.7.7-2) ...
Setting up libsm6:armhf (2:1.2.2-1+b1) ...
Setting up gir1.2-notify-0.7:armhf (0.7.7-2) ...
Setting up libavresample3:armhf (7:3.2.10-1~deb9u1+rpt2) ...
Setting up gsettings-desktop-schemas (3.22.0-1) ...
Setting up libgtk-3-common (3.22.11-1+rpi3) ...
Setting up libvdpau-va-gl1:armhf (0.4.2-1) ...
Setting up gir1.2-freedesktop:armhf (1.50.0-1) ...
Setting up policykit-1 (0.105-18+deb9u1) ...
Removed /run/systemd/system/polkit.service.
polkit.service is a disabled or a static unit not running, not starting it.
Setting up at-spi2-core (2.22.0-6+deb9u1) ...
Setting up libavcodec57:armhf (7:3.2.10-1~deb9u1+rpt2) ...
dpkg: dependency problems prevent configuration of python3-gi-cairo:
 python3-gi-cairo depends on python3-gi (= 3.22.0-2); however:
  Package python3-gi is not configured yet.
 python3-gi-cairo depends on python3-cairo (>= 1.10.0+dfsg-3~exp2); however:
  Package python3-cairo is not configured yet.

dpkg: error processing package python3-gi-cairo (--configure):
 dependency problems - leaving unconfigured
Setting up libpangoft2-1.0-0:armhf (1.40.5-1) ...
Setting up libsndfile1:armhf (1.0.27-3) ...
Setting up va-driver-all:armhf (1.7.3-2) ...
Setting up glib-networking:armhf (2.50.0-1) ...
Setting up vdpau-driver-all:armhf (1.1.1-6) ...
Setting up libpangoxft-1.0-0:armhf (1.40.5-1) ...
Setting up libsoup2.4-1:armhf (2.56.0-2+deb9u2) ...
Setting up libsoup-gnome2.4-1:armhf (2.56.0-2+deb9u2) ...
Setting up libpangocairo-1.0-0:armhf (1.40.5-1) ...
Setting up libpulse0:armhf (10.0-1+deb9u1) ...
Setting up gir1.2-pango-1.0:armhf (1.40.5-1) ...
Setting up librest-0.7-0:armhf (0.8.0-2) ...
Setting up libpulse-mainloop-glib0:armhf (10.0-1+deb9u1) ...
Setting up librsvg2-2:armhf (2.40.16-1) ...
Setting up libpulsedsp:armhf (10.0-1+deb9u1) ...
Setting up pulseaudio-utils (10.0-1+deb9u1) ...
Setting up libdbusmenu-gtk3-4:armhf (12.10.2-2) ...
Setting up libasound2-plugins:armhf (1.1.1-1) ...
Setting up librsvg2-common:armhf (2.40.16-1) ...
Setting up adwaita-icon-theme (3.22.0-1+deb9u1) ...
update-alternatives: using /usr/share/icons/Adwaita/cursor.theme to provide /usr/share/icons/default/index.theme (x-cursor-theme) in auto mode
Setting up pulseaudio (10.0-1+deb9u1) ...
Adding user pulse to group audio
Setting up gnome-icon-theme (3.12.0-2) ...
update-alternatives: using /usr/share/icons/gnome/scalable/places/debian-swirl.svg to provide /usr/share/icons/gnome/scalable/places/start-here.svg (start-here.svg) in auto mode
Setting up libgtk-3-0:armhf (3.22.11-1+rpi3) ...
/usr/lib/arm-linux-gnueabihf/libgtk-3-0/gtk-query-immodules-3.0: error while loading shared libraries: /usr/lib/arm-linux-gnueabihf/libharfbuzz.so.0: cannot read file data
Setting up libgtk-3-bin (3.22.11-1+rpi3) ...
Setting up pulseaudio-module-bluetooth (10.0-1+deb9u1) ...
Setting up notification-daemon (3.20.0-1) ...
Setting up libindicator3-7:armhf (0.5.0-3) ...
Setting up gir1.2-gtk-3.0:armhf (3.22.11-1+rpi3) ...
Setting up libappindicator3-1:armhf (0.4.92-4+b2) ...
Setting up gir1.2-appindicator3-0.1:armhf (0.4.92-4+b2) ...
Processing triggers for dbus (1.10.26-0+deb9u1) ...
Processing triggers for libgdk-pixbuf2.0-0:armhf (2.36.5-2+deb9u2) ...
g_module_open() failed for /usr/lib/arm-linux-gnueabihf/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so: /usr/lib/arm-linux-gnueabihf/libharfbuzz.so.0: cannot read file data
Errors were encountered while processing:
 libc-bin
 systemd
 python3-dbus
 python3-gi
 python3-cairo
 blueman
 python3-gi-cairo
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]:~ $

J’ai refait les commandes mains not found

[email protected]:~ $ sudo dpkl -l | grep -i blue                                        sudo: dpkl: command not found
[email protected]:~ $ sudo dpkl -l | grep -i pulse                                       sudo: dpkl: command not found
[email protected]:~ $

Pense à mettre les balises pour les codes… ça pique les noeils :slight_smile:

Sinon c’est dpkg et non dpkl :stuck_out_tongue:

Attention à ta syntaxe, des erreurs de frappes :

[email protected]:~ $ sudo apt-get remove blueman pulsaudio pulseaudio-module-bluetooth - -purge
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package pulsaudio

C’est pulseaudio et non pulsaudio :stuck_out_tongue:

On voit que pulseaudio et son module bluetooth était déjà présent

pulseaudio is already the newest version (10.0-1+deb9u1).
pulseaudio-module-bluetooth is already the newest version (10.0-1+deb9u1).

Est-ce que cette commande fonctionne maintenant

pulseaudio --start

Pour vérifier si le process tourne :

ps aux | grep -i pulseaudio

Devrais te retourner ceci :

[email protected]:~ $ ps aux | grep -i pulse
pi       15138  4.5  0.9  94264  8776 ?        Sl   20:07   0:00 pulseaudio --start
pi       15141  0.0  0.0   4372   556 pts/0    S+   20:07   0:00 grep --color=auto -i pulse

Si tu as bien le process pulseaudio, tu peux réssayer de te connecter sur ton enceinte :slight_smile:

Resultat

[email protected]:~ $ pulseaudio --start
[email protected]:~ $ ps aux | grep -i pulseaudio
pi        5450  0.0  0.9  94216  8916 ?        Sl   18:13   0:01 /usr/bin/pulseau                                                                                                             dio --start --log-target=syslog
pi        6595  0.0  0.0   4372   552 pts/0    S+   19:14   0:00 grep --color=aut                                                                                                             o -i pulseaudio

ok je retente.

Bonjour et bonne année 2019.
Hier j’ai réussi à connecter mon enceinte bluetooth avant de partir en soirée.
Et ce matin, impossible de me connecter sur mon interface Gladys ou sur Putty.
Aucune réponse du rpi.

Y a t-il qqch à faire sans tout devoir réinstaller ?
Merci

Bonjour j’arrive à connecter mon enceinte bluetooth mais impossible de faire sortir le son de gladys dessus alors quand je branche mon raspberry sur ma tv en HDMI le son sort correctement.

Avez vous un solution ?