[TUTORIEL] - Passage de Gladys en HTTPS via Let's Encrypt

tutoriel

#61

Très bon tutoriel, d’une simplicité tellement s’est bien expliqué :clap::+1:

mit en place sur mon rpi en no-ip c’est le top.

Merci :slight_smile:


#62

Bonjour tous le monde salut @Maegfea

Gladys V3.11.6

Voila j’ai une Freebox V6 et je ne peux pas rediriger le port 443 car les seuls ports que je peux rediriger commence à 16384 auriez-vous une idée ?

Merci par avance

@phoenix3472 Yann


#63

hello @phoenix3472,
Désolé pour le temps de réponse.
As-tu trouvé la réponse à ta question ?
Si non, n’hésite pas à me le dire on avisera, la Freebox Revolution devrait savoir gérer cela.


#64

Merci pour ce tuto très clair !


#65

Bonjour @Maegfea et meilleur voeux,

Non alors non je n’ai pas trouvé de réponse la seul chose que je sais c’est que mon adresse ip public est partagé avec d’autre abonné et c’est pour ça que je ne peux plus rediriger les ports en dessous de 16384.

Voila et merci si t’a une réponse


#66

:thinking: C’est pas possible ça


#67

Salut @VonOx

Ben apriori si regarde ça STP

Merci


#68

Les salauds :grin:

Ils fixent les ports du coup tu l’a dans le c**


#69

Hé bien oui c’est ça @VonOx alors il y a une solution de contournement mais je risque d’être plus vulnérable sur internet si je demande une ip que pour moi

Merci de ta réponse rapide


#70

Marche nickel pour moi.
Merci beaucoup pour le tuto super clair.
Tiboys


#71

@phoenix3472 mince j’avais jamais vu ca chez eux :confused:
Je te dirais que malheureusement tu auras pas le choix pour avoir cet accès extérieur, j’en connais pas d’autre en tout cas.


#72

Bonjour à tous,

Je viens d’installer récemment gladys, je voulais passer en HTTPS pour un accès de l’extérieur, mais je suis confronté à plusieurs problème. j’espère que vous pourrez m’aider.

  • Sur ma freebox, j’ai redirigé le port 443 et le 80 sur l’IP de Gladys
  • j’ai crée un DNS sur le site duckdns.org

après cette étape,

  • sudo nano /etc/nginx/snippets/self-signed.conf
  • et après avoir remplacer les certificats avec mon nom de domaine
    j’ai le message ci-dessous.

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: name.duckdns.org
    Type: unauthorized
    Detail: Invalid response from
    http://name.duckdns.org/.well-known/acme-challenge/McXAdF29HON8XegJzoL3_i_a6r3OFNlp00N4srQMke8
    [MON IP PUBLIC]: “\n\n\n<meta
    http-”

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address.

  • Your account credentials have been saved in your Certbot
    configuration directory at /etc/letsencrypt. You should make a
    secure backup of this folder now. This configuration directory will
    also contain certificates and private keys obtained by Certbot so
    making regular backups of this folder is ideal.

si je continue avec la derniere étape : sudo service nginx start
j’ai le message ci-dessous

Job for nginx.service failed because the control process exited with error code.
See “systemctl status nginx.service” and “journalctl -xe” for details.

je continue a y accéder sans le httpS et avec le port 8080

Merci d’avance


#73

Bonjour,

Je viens de suivre ton tuto @Maegfea et j’ai un message avec une ligne rouge

Obtaining a new certificate
Performing the following challenges:
http-01 challenge for NOM_DE_DOMAINE.ovh
Waiting for verification…
Challenge failed for domain NOM_DE_DOMAINE.ovh
http-01 challenge for NOM_DE_DOMAINE.ovh
Cleaning up challenges
Some challenges have failed.
IMPORTANT NOTES:

  • The following errors were reported by the server:
    Domain: NOM_DE_DOMAINE.ovh
    Type: unauthorized
    Detail: Invalid response from http://www.NOM_DE_DOMAINE.ovh [IPX.X.X.X]:
    “<html xml:lang=“fr-FR” lang=“fr-FR”>\n<head>\n<title
    qtlid=“28806”>Félicitations ! Votre domaine a bien été créé chez
    OVH !</”

si je fait par la suite:

sudo nano /etc/nginx/snippets/self-signed.conf

J’ai rien qui s’affiche dans le tableau, aucune ligne.
Et bien sûr plus rien ne fonctionne.
J’ai un nom de domaine de chez OVH et j’ai lu plus haut que Damdam avait du installer ddclient, ce que j’ai fait. Mais après je ne sais pas quoi mettre dans les réglages.
On me demande le dns, le login, mot de passe,…
Je ne sais pas où aller chercher tous ça, j’ai regardé sur le site OVH, J’ai plein d’info mais je ne sais pas laquelle prendre.
Merci.


#74

Salut, ton domaine ovh pointe bien sur l’ip de ton raspi ?


#75

Il faut que ton domaine pointe vers l’ip de ta box et de ta box une redirection vers le raspberry


#76

Merci @VonOx, tu vas me retrouver sur tout les tutoriels!!

Voici ce que j’ai fait sur le Manager de OVH sur mon nom de domaine:

DynHOST vous permet de faire pointer un sous-domaine vers une adresse IP dynamique qui sera mise à jour dans votre zone DNS à chaque changement de celle-ci.

DynHost: mon nom de domaine
Cible l’adresse IP fixe de ma box SFR

Maintenant sur ma box SFR, je choisi quoi?

Merci de vos infos.


#77

Tu va dans Nat et tu crée la redirection

Port en entrée 443 redirige vers le port 443 de ton raspberry


#78

Merci @VonOx c’est une info que je n’avais pas.
Pour les clients OVH, il faut installer ddclient.
Et configurer le fichier ddclient.conf

sudo nano /etc/ddclient.conf

Mais il y a tout ca de paramètre:
Est ce que j’ai fait ce qu’il faut?

daemon=600 # check every 600 seconds
syslog=yes # log update msgs to syslog
mail=root # mail all msgs to root
mail-failure=root # mail failed update msgs to root
pid=/var/run/ddclient.pid # record PID in file.
cache=/tmp/ddclient.cache # Cache file
### Select one of these options to determine your IP address
## via hardware interface (if you don’t have a router/firewall)
#use=if, if=eth0
## via our CheckIP server
use=web, web=checkip.dyndns.com/, web-skip=“l’adresse Ip de ma box”
## from the status page for a linksys router/firewall
#use=linksys, fw=linksys, fw-login=admin, fw-password=admin
## from a FW status page
#fw-login=admin, fw-password=XXXXXX
#use=fw, fw=192.168.1.254/status.htm, fw-skip=‘IP Address’
## Enter your Ovh DynHost username and password here
login=“mon login” # your Ovh DynHost username
password="mon password " # your Ovh DynHost password
## This section requires no changes unless you need to set a default proxy server
## or you need to bypass your proxy server (because it interferes with the updates)
protocol=dyndns2 # default protocol
server=www.ovh.com # default server
#server:8245=members.dyndns.org # default server (bypassing proxies)
#proxy=fasthttp.sympatico.ca:80 # default proxy
## Default options for Dynamic/Static DNS Hosts
#mx= # default MX host (leave undefined by default)
#backupmx=NO # MX host is primary MX? (leave undefined by default)
#wildcard=YES # add wildcard CNAME?
## Dynamic DNS hosts go here
mon-domaine.ovh
## Static DNS hosts go here
#static=yes, your-static-host.dyndns.org,another-static-host.dyndns.org
## Custom DNS hosts go here
#custom=yes, your-domain.top-level,your-other-domain.top-level

Sur le manager d’OVH, il faut juste que je fasse le DynHost vers l’adresse IP de ma box ou il faut aussi je fasse une redirection vers mon IP?
Car pour l’instant, j’accède à Gladys mais le https est en rouge et rayé.
J’ai suivi ce lien pour que Chrome valide le certificat.

J’espère que toutes mes questions permettront d’aider d’autre personne néophyte comme moi.


#79

Ton ip publique donc celle de ta box.

Faut pas tout mélanger, tu as cet avertissement car le certificat que tu utilise est auto signé, il n’est pas certifié pas une autorité. ( pour ça tu peux utiliser let’s encrypt)


#80

J’ai suivi le tuto donc installer let’s encrypt comme indiqué.
J’ai bien les bonnes lignes dans mon fichier self-signed.conf.
C’est pour ça que je ne comprend pas ce qui cloche.