[TUTORIEL] - Passage de Gladys en HTTPS via Let's Encrypt

tutoriel

#81

Tu peux donner le contenu juste pour être sûr ?


#82

ssl_certificate /etc/ssl/certs/nginx-selfsigned.crt;
ssl_certificate_key /etc/ssl/private/nginx-selfsigned.key;
ssl_certificate /etc/letsencrypt/live/mon domaine.ovh/fullchain.pem;
ssl_certificate_key /etc/letsencrypt/live/mon domaine.ovh/privkey.pem;


#83

Faut mettre en commentaire les lignes qui utilisent le self signed (les 2 premières) tu rajoute un # devant


#84

Oui pardon, elles sont bien en commentaire.
Par contre, est ce qu’il y a quelque chose qui s’affiche lorsque l’on redémarre le service Nginx? Car chez moi je n’ai rien?


#85

Qui s’affiche, c’est à dire ? Dans la console ?


#86

Salut, tu le redémarre comment ?

Perso je fais avec cette commande moi sudo systemctl restart nginx et si ya erreur il te dit où regarder


#87

@VonOx, oui dans la console?
@Jean34, j’ai faits ta commande et voila le résultat:

Job for nginx.service failed because the control process exited with error code.
See “systemctl status nginx.service” and “journalctl -xe” for details.

Après avoir fait la commande de Jean34, si je faits:

sudo service nginx start
Maintenant, j’ai le même résultat que la commande de Jean.


#88

Et que dit les logs ?


#89

[email protected]:~ $ pm2 logs
[TAILING] Tailing last 15 lines for [all] processes (change the value with --lines option)
/home/pi/.pm2/pm2.log last 15 lines:
PM2 | [2019-03-17 14:15:06] PM2 log: App [gladys] with id [0] and pid [1462], exited with code [0] via signal [SIGINT]
PM2 | [2019-03-17 14:15:06] PM2 log: Starting execution sequence in -fork mode- for app name:gladys id:0
PM2 | [2019-03-17 14:15:06] PM2 log: App name:gladys id:0 online
PM2 | [2019-03-17 16:40:42] PM2 log: App [gladys] with id [0] and pid [1491], exited with code [0] via signal [SIGINT]
PM2 | [2019-03-17 16:40:42] PM2 log: Starting execution sequence in -fork mode- for app name:gladys id:0
PM2 | [2019-03-17 16:40:42] PM2 log: App name:gladys id:0 online
PM2 | [2019-03-23 21:14:20] PM2 log: App [gladys] with id [0] and pid [1729], exited with code [0] via signal [SIGINT]
PM2 | [2019-03-23 21:14:20] PM2 log: Starting execution sequence in -fork mode- for app name:gladys id:0
PM2 | [2019-03-23 21:14:20] PM2 log: App name:gladys id:0 online
PM2 | [2019-03-26 19:20:58] PM2 log: App [gladys] with id [0] and pid [14817], exited with code [0] via signal [SIGINT]
PM2 | [2019-03-26 19:20:58] PM2 log: Starting execution sequence in -fork mode- for app name:gladys id:0
PM2 | [2019-03-26 19:20:58] PM2 log: App name:gladys id:0 online
PM2 | [2019-03-26 21:53:24] PM2 log: App [gladys] with id [0] and pid [18989], exited with code [0] via signal [SIGINT]
PM2 | [2019-03-26 21:53:24] PM2 log: Starting execution sequence in -fork mode- for app name:gladys id:0
PM2 | [2019-03-26 21:53:24] PM2 log: App name:gladys id:0 online
/home/pi/.pm2/logs/gladys-error-0.log last 15 lines:
0|gladys | at pass (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:145:5)
0|gladys | at nextRoute (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:100:7)
0|gladys | at callbacks (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:167:11)
0|gladys | at module.exports (/home/pi/gladys/api/policies/checkToken.js:4:12)
0|gladys | at routeTargetFnWrapper (/home/pi/gladys/node_modules/sails/lib/router/bind.js:181:5)
0|gladys | at callbacks (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:164:37)
0|gladys | at param (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:138:11)
0|gladys | at pass (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:145:5)
0|gladys | at nextRoute (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:100:7)
0|gladys | at callbacks (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:167:11)
0|gladys | at _sendHeaders (/home/pi/gladys/node_modules/sails/lib/hooks/cors/to-prepare-send-headers.js:91:7)
0|gladys | at routeTargetFnWrapper (/home/pi/gladys/node_modules/sails/lib/router/bind.js:181:5)
0|gladys | at callbacks (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:164:37)
0|gladys | at param (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:138:11)
0|gladys | at pass (/home/pi/gladys/node_modules/@sailshq/express/lib/router/index.js:145:5)
/home/pi/.pm2/logs/gladys-out-0.log last 15 lines:
0|gladys | House : checkUsersPresence


#90

Voici ce que j’ai en partie lorsque je regarde systemctl

● nginx.service loaded failed failed A high performance web server and a reverse proxy server
pm2-pi.service loaded active running PM2 process manager
raspi-config.service loaded active exited LSB: Switch to ondemand cpu governor (unless shift key is pressed)
rc-local.service loaded active exited /etc/rc.local Compatibility
● resize2fs_once.service not-found active exited resize2fs_once.service


#91

Voilà c’était ces logs qu’il fallait (pour ça que je n’ai pas répondu hier) …

Bon déjà tu as un probleme dans ton nginx.conf, faute de frappe où autre, faut que tu regarde ou au pire poste le contenu du fichier ici.
Ensuite resize2fs_once.service not-found active exited resize2fs_once.service peut être que je dit une connerie mais on dirait que ta carte sd commence à rendre l’âme. mais bon essais déjà de corriger ton nginx.conf ensuite tu verras :wink:


#92

Merci @Jean34, ça va être vite fait pour le fichier nginx.conf car il y a rien dedans.
Comment se fait se?
Pour la carte SD, elle est neuve.


#93

Je viens de re-suivre la procédure pour passer en https, après avoir fait

sudo ./enable-ssl-gladys.sh

Voici ce que j’obtiens:

Using new configuration in Nginx
ln: failed to create symbolic link ‘/etc/nginx/sites-enabled/gladys-ssl’: File exists
rm: cannot remove ‘/etc/nginx/sites-enabled/gladys’: No such file or directory
Restarting Nginx
Job for nginx.service failed because the control process exited with error code.
See “systemctl status nginx.service” and “journalctl -xe” for details.
HTTPS is now active on Gladys ! Congrats :slight_smile:

Après avoir continué et fait:

sudo git clone https://github.com/certbot/certbot /opt/letsencrypt

J’ai obtenu:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator standalone, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for mon-domaine.ovh
Waiting for verification…
Challenge failed for domain mon-domaine.ovh
http-01 challenge for mon-domaine.ovh
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:

  • The following errors were reported by the server:

Domain: mon-domaine.ovh
Type: connection
Detail: unknownHost :: No valid IP addresses found for mon-domaine.ovh

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address. Additionally, please check that
your computer has a publicly routable IP address and that no
firewalls are preventing the server from communicating with the
client. If you’re using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided.

Je ne comprend pas, j’abandonne pour l’instant, j’ia toujours la même erreur:

● nginx.service loaded failed failed

Mon fichier nginx.conf est vide
Je n’ai plus accès à Gladys.
Je vais refaire une installe complète à neuf.
J’espère que pour la V4 , il y aura une procédure plus simple pour passer en https (n’est ce pas @pierre-gilles?)


#94

A la base Gladys est prévue pour rester da s le réseau local… Donc c’est à toi de mettre les mains dans le cambouis pour mettre ta achine en réseau publique. Mais c’est faisable, je l’avais fait au tout début avant de prendre la gateway


#95

Yes ce sera le cas :slight_smile:


#96

@Tlse-vins bon bah je t’ai dit une connerie plus haut, je n’avais pas vu cette info…


#97

Pas de problème @Jean34, j’avais vue le topic sur la V4.


#98

Bonjour, il semblerait que ce cron pose quelques problèmes de nginx qui ne redémarre pas, je suggère le script suivant :

0 3 * * * /opt/letsencrypt/certbot-auto renew; /etc/init.d/nginx stop; /etc/init.d/nginx start

ou même

0 3 * * * /opt/letsencrypt/certbot-auto renew; /etc/init.d/nginx reload 

Un avis ?


#99

Je complète pour dire que sous debian, le package certbot est désormais installable depuis apt-get et, pour le coup, est à jour sur les évolutions de hashable de clé.