Hallo zusammen ![]()
Gladys Assistant 5.1.2 ist verfügbar! Eine Version, die sich auf ein häufig diskutiertes Thema konzentriert: die Größe der Datenbank. Sie können jetzt auf einen Blick sehen, welche Geräte den Speicher füllen und wie viel Platz jede Funktion belegt ![]()
Seite „Geräte“: Erkennen Sie übermäßig kommunikative Geräte
Manche Geräte senden ihren Status alle paar Sekunden (z. B. eine Steckdose, die kontinuierlich ihre Leistung meldet). Wenn die Historie aktiviert ist, können sie allein den größten Teil Ihrer Datenbank ausmachen, ohne dass Sie dies benötigen.
Die Seite Geräte zeigt sie jetzt an:
- Ein Banner zeigt an, wie viele Geräte „übermäßig kommunikativ“ sind und welchen Anteil sie an der Historie der letzten 24 Stunden haben.
- Eine Schaltfläche ermöglicht es, nur diese Geräte anzuzeigen, die ein Schild „Übermäßig kommunikativ“ tragen. Beim Überfahren des Schildes sehen Sie die Anzahl der gespeicherten Zustände und die betroffenen Funktionen.
- Ein Gerät wird markiert, wenn eine seiner Funktionen mindestens 1.440 Zustände in 24 Stunden speichert, also im Durchschnitt mindestens einen Zustand pro Minute.
- Eine neue Sortierung „Die Kommunikativsten zuerst“ sortiert alle Ihre Geräte nach der Anzahl der gespeicherten Zustände in den letzten 24 Stunden.
Die Größe der Historie jeder Funktion
Auf der Seite eines Geräts zeigt Gladys neben dem Schalter „Zustandshistorie speichern?“ jetzt die Anzahl der gespeicherten Zustände für jede Funktion und eine Schätzung des belegten Platzes an.
Sie wissen also sofort, welche Funktion sich lohnt, um sie zu historisieren, und welche viel Platz für wenig Nutzen beansprucht. Wenn Sie die Historie einer Funktion deaktivieren, werden ihre Zustände aus der Datenbank gelöscht und die Zahl wird aktualisiert.
Das ist auf den Geräteseiten der Integrationen (Zigbee2mqtt, MQTT, externe Integrationen…) verfügbar.
Gladys-Updates: Klarere Fehler
Wenn das Update von Gladys das neue Docker-Image nicht herunterladen konnte, blieb die Fehlermeldung vage. Gladys zeigt jetzt die eigentliche Ursache an:
- Nicht genug Speicherplatz: Die Meldung sagt es klar und erklärt, wie man Platz freimacht (z. B. mit
docker image prune -a, das Bilder löscht, die kein Container verwendet). - Zu langer Download: Er wird nach 15 Minuten abgebrochen, ohne etwas an Ihrer Installation zu ändern.
- Anderer Fehler: Der von Docker zurückgesendete Fehler wird unverändert angezeigt, um ihn diagnostizieren zu können (und ihn uns im Forum mitzuteilen, falls nötig
).
Sicherheit
- Die Standorthistorie eines Benutzers und die API, die ihn als anwesend in einem Haus meldet, sind nun nur noch dem Benutzer selbst oder einem Administrator vorbehalten.
Projektseite
- Das Repository hat jetzt eine
MAINTAINERS.md-Datei und einenCODEOWNERS, und die Release-Workflows sind getrennt. - Die von der CI verwendeten Drittanbieter-GitHub-Aktionen sind auf eine bestimmte Version gepinnt, und die Berechtigungen der Jobs sind auf das Notwendigste reduziert.
Aktualisieren
Das Update erfolgt wie gewohnt über Einstellungen → System, oder automatisch, wenn Sie automatische Updates aktiviert haben.
Die vollständige Liste der Änderungen: Release v5.1.2 · GladysAssistant/Gladys · GitHub
Zögern Sie nicht, uns mitzuteilen, was Sie auf Ihrer Installation finden: Welche Geräte sind bei Ihnen am kommunikativsten? ![]()
Und vielen Dank an alle, die weiterhin Feedback geben ![]()




