Gladys ya no se conecta a nada

¡Hola!
Esta mañana tuve un pequeño corte de electricidad en mi casa y desde el reinicio Gladys no quiere conectarse a nada.
Ya sea Gladys Plus o Open Weather, etc..


He intentado reiniciar el contenedor, reiniciar el rpi3.

Hice un ping a Google (8.8.8.8) en el rpi, todo está bien.

Tengo la sensación de que Gladys ha preferido encerrarse en sí misma.

¿Alguna idea para ayudarme?

¡Gracias de antemano!

¿has reiniciado el raspberry pi?

@cce66

Sí, desafortunadamente nada

¿Qué te da « ip addr show docker0 »?

Según tu idea @cce66 intenté hacer el ping en el contenedor

No entiendo mucho

Parece que no viene de docker o del pi, sino más bien de gladys.

¿Del lado de la red está todo bien :thinking: @pierre-gilles ¿tienes alguna idea de lo que podría causar esto a nivel de Node.js?

@spenceur ¿tienes más información en los logs de gladys?

docker logs gladys

Javais deja check effectivement
Tengo muchos errores con telegram, supongo que la API no puede conectarse.
Open Weather así como el calendario, etc.

Pero nada más

2022-02-12T11:57:52+0100 <error> calendar.syncUserCalendars.js:34 (CalDAVHandler.syncUserCalendars) Error: Bad status: 501
    at exports.XMLHttpRequest.request.onreadystatechange (/src/server/services/caldav/node_modules/dav-request/dav.js:3424:27)
    at exports.XMLHttpRequest.dispatchEvent (/src/server/services/caldav/node_modules/xmlhttprequest/lib/XMLHttpRequest.js:591:25)
    at setState (/src/server/services/caldav/node_modules/xmlhttprequest/lib/XMLHttpRequest.js:610:14)
    at IncomingMessage.<anonymous> (/src/server/services/caldav/node_modules/xmlhttprequest/lib/XMLHttpRequest.js:447:13)
    at IncomingMessage.emit (events.js:412:35)
    at endReadableNT (internal/streams/readable.js:1334:12)
    at processTicksAndRejections (internal/process/task_queues.js:82:21)
2022-02-12T11:57:52+0100 <error> index.js:52 (Timeout.syncAllUsers [as _onTimeout]) NotFoundError: CALDAV_FAILED_REQUEST_CALENDARS
    at CalDAVHandler.syncUserCalendars (/src/server/services/caldav/lib/calendar/calendar.syncUserCalendars.js:35:11)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (internal/process/task_queues.js:95:5)
    at async Promise.map.concurrency (/src/server/services/caldav/index.js:45:13)
2022-02-12T11:57:53+0100 <warn> message.connect.js:19 (TelegramBot.<anonymous>) Telegram polling error, code = EFATAL, message = EFATAL: Error: getaddrinfo EAI_AGAIN api.telegram.org
2022-02-12T11:57:59+0100 <warn> message.connect.js:19 (TelegramBot.<anonymous>) Telegram polling error, code = EFATAL, message = EFATAL: Error: getaddrinfo EAI_AGAIN api.telegram.org
2022-02-12T11:00:04+0100 <error> index.js:77 (Object.get) Error: getaddrinfo EAI_AGAIN api.openweathermap.org
    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:71:26) {
  errno: -3001,
  code: 'EAI_AGAIN',
  syscall: 'getaddrinfo',
  hostname: 'api.openweathermap.org',
 [...]
2022-02-12T08:43:07+0100 <warn> gateway.forwardDeviceStateToGoogleHome.js:41 (sendCurrentState) Gladys Gateway: Unable to forward google home reportState
2022-02-12T08:43:07+0100 <warn> gateway.forwardDeviceStateToGoogleHome.js:42 (sendCurrentState) Error: getaddrinfo EAI_AGAIN api.gladysgateway.com
    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:71:26) {
  errno: -3001,
  code: 'EAI_AGAIN',
  syscall: 'getaddrinfo',
  hostname: 'api.gladysgateway.com',
  config: {
    url: 'https://api.gladysgateway.com/google/report_state',
[...]

0 log cuando intento iniciar sesión en gladys, eso no ayuda ^^’

Parece más un problema de resolución DNS.
¿Puedes intentar hacer ping a google.com desde el RPI y desde el contenedor docker?

Vale, entonces el ping de red funciona, pero cuando haces un ping a 8.8.8.8 estás pingueando la dirección IP y luego hay que hacer un ping a www.google.com para ver si la configuración DNS está bien. Si no lo está, OpenWeather no podrá funcionar porque hace su solicitud a una dirección DNS (www.openweather) y no a una dirección IP.

Sí, problemas de DNS (lo que vemos en los registros de Gladys)

¿Qué devuelve « docker network inspect bridge »?

@cce66 es el host, no el bridge en gladys

Puedes intentar cambiar el DNS en Docker

/etc/docker/daemon.json

{
    "dns": ["9.9.9.9", "8.8.8.8"]
}

Quad9 y Google

Y reinicias el Pi

¡Es efectivamente un problema DNS relacionado con el host, aparentemente, sin relación con Gladys en mi opinión!

¡Hola! Bueno, efectivamente no lo había pensado, pero efectivamente mi NAS también se apagó y no se reinició correctamente.
Por lo tanto, mis contenedores tampoco, entre otros adguard.
Después de que @cicoub13 volviera, reflexioné, pero no tuve tiempo de responderles :smiley:

Gracias a ustedes y efectivamente no tenía nada que ver con gladys ^^’

Sí, me pasa con Pi-hole :sweat_smile: