Hola, como validación para mi migración de HA a Gladys, he comenzado a instalar una plataforma de prueba.
He instalado en un mini PC una Ubuntu Server (ya tengo un servidor de archivos con Ubuntu-server). He instalado Docker y Gladys según lo indicado en: Installation avec Docker | Gladys Assistant He notado que podría ser pertinente señalar en esta documentación que es deseable, para el particionamiento del sistema operativo base, crear una partición separada para /var si es posible generosa, en cambio la partición /home no necesita ser tan grande como un NAS. He podido conectarme a Gladys y crear mi cuenta local, ¡gracias a la documentación!
Luego instalé AdGuardHome siguiendo de nuevo las indicaciones de: adguard/adguardhome - Docker Image Todo parece haber ido bien, pero no del todo en realidad.
Al consultar Docker:
moi@mamachine:~$ sudo docker ps
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
d9a23ec27f14 adguard/adguardhome "/opt/adguardhome/Ad…" 40 seconds ago Up 3 seconds adguardhome
b21791a177ff gladysassistant/gladys:v5 "docker-entrypoint.s…" 18 hours ago Up 3 minutes gladys
Todo parece ir bien, pero no puedo conectarme a http://mi_ip_local:3000 (el navegador no lo logra).
Al mirar más de cerca los registros de instalación, encuentro:
moi@mamachine:~$ sudo docker run --name adguardhome
--restart unless-stopped
-v /my/own/workdir:/opt/adguardhome/work
-v /my/own/confdir:/opt/adguardhome/conf
-p 53:53/tcp -p 53:53/udp
-p 67:67/udp -p 68:68/udp
-p 80:80/tcp -p 443:443/tcp -p 443:443/udp -p 3000:3000/tcp
-p 853:853/tcp
-p 784:784/udp -p 853:853/udp -p 8853:8853/udp
-p 5443:5443/tcp -p 5443:5443/udp
-d adguard/adguardhome
d9a23ec27f14785f589c5e9e0ade5aa3c3f08bda22189492597d7857bedcc78a
docker: Error response from daemon: failed to set up container networking: driver failed programming external connectivity on endpoint adguardhome (6ba91471a3e357a25892af051cc5b96d43c30a1decaa09c0ca72bda48f6ce2f6): failed to bind host port 0.0.0.0:53/tcp: address already in use
Run 'docker run --help' for more information
Hay un mensaje de error que parece indicar que el puerto 53 ya está en uso. ¿Un problema de redirección de puertos?
De antemano, gracias por sus luces.
