Bonjour, En guise de validation pour ma migration de HA vers Gladys, j’ai commencé à installer une plateforme de test.
J’ai installé dans un mini pc une ubuntu server (j’ai déjà un serveur de fichiers avec Ubuntu-server). J’ai installé docker et Gladys tel qu’indiqué dans : Installation avec Docker | Gladys Assistant J’ai noté qu’il pourrait être pertinent de signaler dans cette doc qu’il est souhaitable pour le partitionnement de l’OS de base de créer une partition séparée pour /var si possible copieuse, par contre la partition /home n’a pas besoin d’être aussi grande que un nas. J’ai pu me connecter à Gladys et y créer mon compte local, merci la doc!
J’ai ensuite installé adguardhome là encore en suivant les indiications de : adguard/adguardhome - Docker Image Tout semble s’être bien passé mais pas totalement en fait.
En interrogeant docker :
moi@mamachine:~$ sudo docker ps
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
d9a23ec27f14 adguard/adguardhome "/opt/adguardhome/Ad…" 40 seconds ago Up 3 seconds adguardhome
b21791a177ff gladysassistant/gladys:v5 "docker-entrypoint.s…" 18 hours ago Up 3 minutes gladys
Tout semble bien aller mais je ne peux me connecter sur http://mon_ip_locale:3000 (le navigateur n’y arrive pas).
En regardant de plus près les traces d’installation je trouve :
moi@mamachine:~$ sudo docker run --name adguardhome
--restart unless-stopped
-v /my/own/workdir:/opt/adguardhome/work
-v /my/own/confdir:/opt/adguardhome/conf
-p 53:53/tcp -p 53:53/udp
-p 67:67/udp -p 68:68/udp
-p 80:80/tcp -p 443:443/tcp -p 443:443/udp -p 3000:3000/tcp
-p 853:853/tcp
-p 784:784/udp -p 853:853/udp -p 8853:8853/udp
-p 5443:5443/tcp -p 5443:5443/udp
-d adguard/adguardhome
d9a23ec27f14785f589c5e9e0ade5aa3c3f08bda22189492597d7857bedcc78a
docker: Error response from daemon: failed to set up container networking: driver failed programming external connectivity on endpoint adguardhome (6ba91471a3e357a25892af051cc5b96d43c30a1decaa09c0ca72bda48f6ce2f6): failed to bind host port 0.0.0.0:53/tcp: address already in use
Run 'docker run --help' for more information
Il y a un message d’erreur qui semble dire que le port 53 est déjà utilisé. Un problème de redirection de port?
D’avance merci pour vos lumières.
