Erledigt: zigbee2mqtt Absturz

Hallo,

nach dem Update 4.62 funktioniert nichts mehr :frowning:

Die Webseite zigbee2mqtt ist nicht mehr erreichbar.

docker images
REPOSITORY               TAG       IMAGE ID       CREATED         SIZE
gladysassistant/gladys   v4        d052f365771b   3 days ago      1.41GB
koenkk/zigbee2mqtt       2.4.0     7706f8947dde   3 months ago    192MB
nodered/node-red         3.1       85c60175d24a   5 months ago    559MB
koenkk/zigbee2mqtt       1.42.0    b9ab0b017b28   9 months ago    120MB
koenkk/zigbee2mqtt       latest    b9ab0b017b28   9 months ago    120MB
containrrr/watchtower    latest    e7dd50d07b86   22 months ago   14.7MB
eclipse-mosquitto        2         97ac6de756a3   2 years ago     13.3MB
eclipse-mosquitto        2.0.15    2b1de2694efa   2 years ago     13.3MB
docker ps
CONTAINER ID   IMAGE                          COMMAND                  CREATED         STATUS                    PORTS      NAMES
914acaeb7a22   gladysassistant/gladys:v4      "docker-entrypoint.s…"   6 hours ago     Up 11 minutes                        gladys
939ff965522a   containrrr/watchtower:latest   "/watchtower --clean…"   22 months ago   Up 11 minutes (healthy)   8080/tcp   watchtower
c61d905371cc   eclipse-mosquitto:2.0.15       "/docker-entrypoint.…"   2 years ago     Up 11 minutes                        eclipse-mosquitto
7ae91e628a97   eclipse-mosquitto:2.0.15       "/docker-entrypoint.…"   2 years ago     Up 11 minutes                        gladys-z2m-mqtt
docker run koenkk/zigbee2mqtt
Using '/app/data' as data directory
Creating configuration file...
Starting Zigbee2MQTT without watchdog.
[2025-09-26 06:56:00] info:     z2m: Logging to console, file (filename: log.log)
[2025-09-26 06:56:00] info:     z2m: Starting Zigbee2MQTT version 1.42.0 (commit #861cba6)
[2025-09-26 06:56:00] info:     z2m: Starting zigbee-herdsman (2.1.9)
[2025-09-26 06:56:00] error:    zh:zstack:znp: Failed to determine if path is valid: 'Error: ENOENT: no such file or directory, lstat '/dev/ttyACM0''
[2025-09-26 06:56:00] info:     zh:zstack:znp: Opening SerialPort with {"path":"/dev/ttyACM0","baudRate":115200,"rtscts":false,"autoOpen":false}
[2025-09-26 06:56:00] error:    z2m: Error while starting zigbee-herdsman
[2025-09-26 06:56:00] error:    z2m: Failed to start zigbee
[2025-09-26 06:56:00] error:    z2m: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
[2025-09-26 06:56:00] error:    z2m: Exiting...
[2025-09-26 06:56:00] error:    z2m: Error: Error: No such file or directory, cannot open /dev/ttyACM0

Und der Link zur Dokumentation ist ein 404.
Das Problem ist also /dev/ttyACM0.
Ich ändere die YAML-Datei in /dev/ttyUSB0

docker start -ai zigbee2mqtt
Using '/app/data' as data directory
Starting Zigbee2MQTT without watchdog.
[2025-09-26 09:09:00] info:     z2m: Logging to console, file (filename: log.log)
[2025-09-26 09:09:00] info:     z2m: Starting Zigbee2MQTT version 1.42.0 (commit #861cba6)
[2025-09-26 09:09:00] info:     z2m: Starting zigbee-herdsman (2.1.9)
[2025-09-26 09:09:01] info:     zh:zstack:znp: Opening SerialPort with {"path":"/dev/ttyUSB0","baudRate":115200,"rtscts":false,"autoOpen":false}
[2025-09-26 09:09:01] info:     zh:zstack:znp: Serialport opened
[2025-09-26 09:09:01] info:     z2m: zigbee-herdsman started (resumed)
[2025-09-26 09:09:01] info:     z2m: Coordinator firmware version: '{"meta":{"maintrel":1,"majorrel":2,"minorrel":7,"product":1,"revision":20210120,"transportrev":2},"type":"zStack3x0"}'
[2025-09-26 09:09:01] info:     z2m: Currently 0 devices are joined.
[2025-09-26 09:09:01] info:     z2m: Zigbee: disabling joining new devices.
[2025-09-26 09:09:02] info:     z2m: Connecting to MQTT server at mqtt://localhost
[2025-09-26 09:09:02] error:    z2m: MQTT error: connect ECONNREFUSED ::1:1883
[2025-09-26 09:09:02] error:    z2m: MQTT failed to connect, exiting... (connect ECONNREFUSED ::1:1883)
[2025-09-26 09:09:02] info:     z2m: Stopping zigbee-herdsman...
[2025-09-26 09:09:03] error:    z2m: MQTT error: connect ECONNREFUSED ::1:1883
[2025-09-26 09:09:04] error:    z2m: MQTT error: connect ECONNREFUSED ::1:1883
[2025-09-26 09:09:05] error:    z2m: MQTT error: connect ECONNREFUSED ::1:1883
[2025-09-26 09:09:06] error:    z2m: MQTT error: connect ECONNREFUSED ::1:1883
[2025-09-26 09:09:07] error:    z2m: MQTT error: connect ECONNREFUSED ::1:1883
[2025-09-26 09:09:08] error:    z2m: MQTT error: connect ECONNREFUSED ::1:1883
[2025-09-26 09:09:09] error:    z2m: MQTT error: connect ECONNREFUSED ::1:1883
[2025-09-26 09:09:10] error:    z2m: MQTT error: connect ECONNREFUSED ::1:1883
[2025-09-26 09:09:11] error:    z2m: MQTT error: connect ECONNREFUSED ::1:1883
[2025-09-26 09:09:11] info:     zh:controller: Wrote coordinator backup to '/app/data/coordinator_backup.json'
[2025-09-26 09:09:11] info:     zh:zstack:znp: closing
[2025-09-26 09:09:11] info:     zh:zstack:znp: Port closed
[2025-09-26 09:09:11] info:     z2m: Stopped zigbee-herdsman

Ich ändere die YAML-Datei, indem ich mqtt://localhost durch mqtt://meine_ip:1883 ersetze

docker start -ai zigbee2mqtt
Using '/app/data' as data directory
Starting Zigbee2MQTT without watchdog.
[2025-09-26 11:10:34] info:     z2m: Logging to console, file (filename: log.log)
[2025-09-26 11:10:34] info:     z2m: Starting Zigbee2MQTT version 1.42.0 (commit #861cba6)
[2025-09-26 11:10:34] info:     z2m: Starting zigbee-herdsman (2.1.9)
[2025-09-26 11:10:35] info:     zh:zstack:znp: Opening SerialPort with {"path":"/dev/ttyUSB0","baudRate":115200,"rtscts":false,"autoOpen":false}
[2025-09-26 11:10:35] info:     zh:zstack:znp: Serialport opened
[2025-09-26 11:10:35] info:     z2m: zigbee-herdsman started (resumed)
[2025-09-26 11:10:35] info:     z2m: Coordinator firmware version: '{"meta":{"maintrel":1,"majorrel":2,"minorrel":7,"product":1,"revision":20210120,"transportrev":2},"type":"zStack3x0"}'
[2025-09-26 11:10:35] info:     z2m: Currently 0 devices are joined.
[2025-09-26 11:10:35] info:     z2m: Zigbee: disabling joining new devices.
[2025-09-26 11:10:35] info:     z2m: Connecting to MQTT server at mqtt://x.x.x.x:1883
[2025-09-26 11:10:35] error:    z2m: MQTT error: Connection refused: Not authorized
[2025-09-26 11:10:35] error:    z2m: MQTT failed to connect, exiting... (Connection refused: Not authorized)
[2025-09-26 11:10:35] info:     z2m: Stopping zigbee-herdsman...
[2025-09-26 11:10:36] error:    z2m: MQTT error: Connection refused: Not authorized
[2025-09-26 11:10:37] error:    z2m: MQTT error: Connection refused: Not authorized
[2025-09-26 11:10:38] error:    z2m: MQTT error: Connection refused: Not authorized
[2025-09-26 11:10:39] error:    z2m: MQTT error: Connection refused: Not authorized
[2025-09-26 11:10:40] error:    z2m: MQTT error: Connection refused: Not authorized
[2025-09-26 11:10:41] error:    z2m: MQTT error: Connection refused: Not authorized
[2025-09-26 11:10:42] error:    z2m: MQTT error: Connection refused: Not authorized
[2025-09-26 11:10:44] error:    z2m: MQTT error: Connection refused: Not authorized
[2025-09-26 11:10:45] error:    z2m: MQTT error: Connection refused: Not authorized
[2025-09-26 11:10:45] info:     zh:controller: Wrote coordinator backup to '/app/data/coordinator_backup.json'
[2025-09-26 11:10:45] info:     zh:zstack:znp: closing
[2025-09-26 11:10:45] info:     zh:zstack:znp: Port closed
[2025-09-26 11:10:45] info:     z2m: Stopped zigbee-herdsman

Jetzt wird es mir langsam zu viel :frowning:

Habt ihr eine Idee, wie man das alles lösen kann?

Danke!

PS, ich habe mehrmals neu gestartet, falls das hilft…

PS die Seite zigbee2mqtt ist in der Dokumentation nicht mehr aktuell

Hallo, das solltest du auf keinen Fall tun, die Konfiguration war gut.

Dabei handelt es sich um eine Zuordnung des Pfads innerhalb des Docker-Containers, die sich nie ändert.

Falls dein USB-Stick den Port gewechselt hat, musst du das in der Zigbee2mqtt-Integration in Gladys ändern, aber du solltest niemals die Dateien auf der Festplatte bearbeiten :smiley:

Ich sehe, dass das Modell des Zigbee-Dongles in Gladys nicht ausgewählt ist, ist das normal?

Bearbeitung: Außerdem verstehe ich nicht, was du mit all diesen Befehlen machst, das solltest du nicht tun, wenn du eine von Gladys verwaltete Installation hast… :sweat_smile:

Ich wollte ein paar Sachen vorher ausprobieren -_-
Ich habe alles wieder zurückgesetzt.

Ja, ich finde meinen Schlüssel nicht in der Liste…

lsusb
Bus 002 Gerät 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Gerät 003: ID 0bda:c821 Realtek Semiconductor Corp. Bluetooth Radio
Bus 001 Gerät 002: ID 1a86:7523 QinHeng Electronics CH340 serial converter
Bus 001 Gerät 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Ich starte neu und:
bc4b85e98c0e koenkk/zigbee2mqtt:2.6.1 "docker-entrypoint.s…" 30 Minuten her Up Weniger als eine Sekunde gladys-z2m-zigbee2mqtt
startet alle 20-30 Sekunden neu

Dann lohnt es sich nicht, weiter zu suchen. Wenn dein Schlüssel nicht angezeigt wird, kann Zigbee2mqtt nicht funktionieren!

Du kannst mehrere Dinge versuchen: den Schlüssel aus- und wieder einstecken, den Mini-PC neu starten (auch wenn du das anscheinend schon gemacht hast), aber der Schlüssel muss angezeigt werden.

Das Problem ist, dass sie von lsusb gut erkannt wird und alles seit einiger Zeit funktioniert hat…
und wenn ich mich nicht irre, zeigte Gladys nur die Schlüssel an, die sie sehen konnte, oder?

Der Portwechsel ändert nichts, lsusb erkennt sie immer noch, aber nichts Besonderes in Gladys.

Ach entschuldige, wir haben uns missverstanden, ich dachte, du siehst den Schlüssel nicht mit lusb.

Wie hast du Gladys gestartet? Mit dem Befehl von der Website? Hast du den Docker Run nicht verändert?

Soweit ich mich erinnere, gab es keinen speziellen Befehl.

Wie kann man den beim Start ausgeführten Befehl wiederfinden?

Das kommt wirklich ungelegen, ich fahre übers Wochenende weg :frowning:

Ich habe dir eine PN mit dem Rückgabewert von docker inspect /gladys geschickt.

Der Docker-Inspect sieht gut aus, der Container hat Zugriff auf /dev:/dev, um die USB-Ports zu sehen.

Kannst du schnell für einen Call verfügbar sein, um das gemeinsam zu lösen?

Falls ja, schicke ich dir einen Link privat.

Das war ein DNS-Auflösungsproblem…
Keine Verbindung zu Gladys!

Vielen Dank!

Gut, dass es jetzt funktioniert, wir haben gut daran getan, uns anzurufen, um das gemeinsam zu debuggen, das ist oft viel einfacher! :grin:

Schönes Wochenende!