Gladys v3.9.0, première bêta!


#1

Salut à tous,

Pour ceux qui ne l’ont pas vu sur Twitter, je travaille tout ce week-end sur la sortie de Gladys v3.9.0 + du module Z-Wave nouvelle génération. J’ai posté tout mon avancement sur ce feed Twitter =>

Hier soir, j’ai sorti un première release en version beta pour Gladys. Attention, c’est du bêta, il peut y avoir des petites erreurs. N’installez cette bêta que si vous êtes sur de vous!

Si vous avez installé Gladys via l’image Raspbian officielle, pour passer à Gladys v3.9.0 il vous faut:

  • Placez vous dans le dossier /home/pi de votre Raspberry Pi.
  • Executez la commande :
curl -SLs https://raw.githubusercontent.com/GladysProject/gladys-update/master/v2/update-gladys-beta.sh | bash

C’est tout !

Pour ceux qui ont installé Gladys manuellement, il faut puller les changements et réinstaller les dépendances.

Pour ceux qui ont installé Gladys via Docker, il y a un nouveau tag “v3.9.0” de l’image Docker.

J’attends vos retours avec impatience, je ferais un point dans la journée et je l’espère une release officielle très bientôt !


#2

Bonjour,
Je viens d’installer la 3.9.0. Aucun problème avec le cURL tout s’est bien installé et redémarré.
Je viens poser malgré tout quelques questions pour voir tester ensuite.
Avec les capteurs zWave on peut jouer sur la sensibility. Est il possible de configurer pour qu’un capteur remonte la température toutes les 900 sec même s’il n’y a pas de changement ? Si on met 0 dans la sensibility et le timer à 900 sec ça ne doit pas remonter les températures même si la variation est minime ?
En tout cas beau travail pour la partie zWave tout est plus clair, et beaucoup de scénarios peuvent découler de cette release…


#3

Hello @pierre-gilles,

Evolutions très intéressantes, merci :slight_smile:

J’ai ouvert 2 issues github :

  • Modification du mot de passe impossible : rien ne se passe lors du clic sur le bouton de mise à jour
  • Graphiques des devices : la liste déroulante n’affiche plus les devices, j’ai essenttiellement de champs à blanc. A moins que ce soit voulu et que dorénavant ce soit les deviceType qui sont affichés ? Auquel cas, il faut que je leur attribut un nom systématiquement.

Sinon, j’ai testé les modifications de mon compte utilisateurs tout fonctionne à merveille (prénom, nom, mail, genre, langue et temps de préparation).

Méthode de mise à jour :

  • git pull
  • yarn upgrade

Résolution du problème de mise à jour du mot de passe : grunt buildProd


#4

Tu as pris la nouvelle branche pour tester ? :slight_smile: Je n’ai pas encore mergé volontairement en attendant que Gladys v3.9.0 soit sortie officiellement

Tu peux féliciter @MathieuA pour le boulot sur le Z-Wave :raised_hands:

mm là dessus je ne suis pas expert Z-wave je ne saurais pas te dire…

Je t’ai répondu sur Github, tu as oublié de faire grunt buildProd en mettant à jour manuellement. ( ne s’applique pas aux mise à jour automatique )

Merci pour la remonté! je vais changer ça


#5

Yes, mince… j’ai complètement oublié de le faire. Je te confirme que c’est bon après passage de la commande et redémarrage :slight_smile:

Merci !


#6

je viens de faire la mise à jour aucun problème parfait encore merci pour ce magnifique travail::dog2::dog2: