Hallo, als Validierung für meine Migration von HA zu Gladys habe ich begonnen, eine Testplattform zu installieren.
Ich habe auf einem Mini-PC eine Ubuntu-Server-Installation durchgeführt (ich habe bereits einen Dateiserver mit Ubuntu-Server). Ich habe Docker und Gladys installiert, wie in der Anleitung beschrieben: Installation avec Docker | Gladys Assistant Ich habe festgestellt, dass es sinnvoll wäre, in dieser Dokumentation darauf hinzuweisen, dass es wünschenswert ist, beim Partitionieren des Basissystems eine separate Partition für /var zu erstellen, wenn möglich großzügig, die Partition /home jedoch nicht so groß wie ein NAS sein muss. Ich konnte mich bei Gladys anmelden und mein lokales Konto erstellen, danke der Dokumentation!
Anschließend habe ich AdGuardHome installiert, wieder nach den Anweisungen von: adguard/adguardhome - Docker Image Alles scheint gut gelaufen zu sein, aber nicht ganz.
Bei der Abfrage von Docker:
moi@mamachine:~$ sudo docker ps
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
d9a23ec27f14 adguard/adguardhome "/opt/adguardhome/Ad…" 40 seconds ago Up 3 seconds adguardhome
b21791a177ff gladysassistant/gladys:v5 "docker-entrypoint.s…" 18 hours ago Up 3 minutes gladys
Alles scheint gut zu laufen, aber ich kann mich nicht auf http://meine_lokale_ip:3000 verbinden (der Browser schafft es nicht).
Bei genauerer Betrachtung der Installationsprotokolle finde ich:
moi@mamachine:~$ sudo docker run --name adguardhome
--restart unless-stopped
-v /my/own/workdir:/opt/adguardhome/work
-v /my/own/confdir:/opt/adguardhome/conf
-p 53:53/tcp -p 53:53/udp
-p 67:67/udp -p 68:68/udp
-p 80:80/tcp -p 443:443/tcp -p 443:443/udp -p 3000:3000/tcp
-p 853:853/tcp
-p 784:784/udp -p 853:853/udp -p 8853:8853/udp
-p 5443:5443/tcp -p 5443:5443/udp
-d adguard/adguardhome
d9a23ec27f14785f589c5e9e0ade5aa3c3f08bda22189492597d7857bedcc78a
docker: Error response from daemon: failed to set up container networking: driver failed programming external connectivity on endpoint adguardhome (6ba91471a3e357a25892af051cc5b96d43c30a1decaa09c0ca72bda48f6ce2f6): failed to bind host port 0.0.0.0:53/tcp: address already in use
Run 'docker run --help' for more information
Es gibt eine Fehlermeldung, die besagt, dass Port 53 bereits verwendet wird. Ein Problem mit der Portweiterleitung?
Vielen Dank im Voraus für Ihre Hilfe.
