Problème connexion à MQTT après mise à jour de mosquitto par watchtower

Aucune idée, c’est toi qui a programmé ton flow Node-RED :smiley: Il faut débugger côté Node-RED voir si tout ce que tu as programmé fonctionne bien

Rajoute des logs dans Node-RED, fais des tests à la main, ce genre de choses :slight_smile:

je vais essayé de creuser sur nodered mais je suis dubitatif, mqtt est mis a jour et c est nodered qui buggerai ?

sur mes flow j ai dejà des pts de controle a quasi chaque node et sans erreur remontée et avec une remontée correct des data vers le dashboard integre nodered (les data sont les memes)
je vais essayé de crer un autre flow avec mqtt et d autres data, on va voir

C’est une proposition ! Tiens nous au courant des différents tests que tu fais, n’oublie pas de tester tous les cas que je t’ai listé ici : Problème connexion à MQTT après mise à jour de mosquitto par watchtower - #14 par pierre-gilles

1 Like

Je me rappelle que j’avais eu ce problème et j’avais du modifier le password des deux cotés puis revenir au password d’origine des deux cotés et ensuite cela avait fonctionné à nouveau mais est-ce la solution ? Peut-être des password par défaut mis suite maj coté gladys ou coté mqtt

ok, pas de pb, mais je vais aller lentement ! retraité avec des petits pb de santé et pleins d occupation, je n ai plus les memes niveaux de productivité que par le passé mais j ai tous mes neurones…

Bonjour,

Je viens de passer en MQTT 2.0.16 et ça m’a cassé les mises à jour de certains topics.

Les messages sont publiés depuis nodred et le problème concerne une mise à jour de plusieurs topics en simultané.

Mon erreur venait du paramétrage des publications MQTT dans nodered, j’avais configuré un QoS à 2 alors que je n’en faisais rien. Après passage du QoS à 0, ça refonctionne.

Je ne suis pas certains que ce soit le même problème que toi.

Salut à tous !

J’ai eu d’autres échos que les intégrations Zigbee2mqtt / et MQTT ne fonctionnaient plus lors d’une nouvelle installation.

J’ai fais le test par moi même, et j’arrive au même résultat, sur une installation fraîche, l’installation ne marche plus:

 configureContainer.js:26 (MqttHandler.configureContainer) MQTT broker Docker container is being configured...
 configureContainer.js:43 (MqttHandler.configureContainer) Writting default eclipse-mosquitto configuration...
 installContainer.js:35 (MqttHandler.installContainer) Creating container...
 installContainer.js:43 (MqttHandler.installContainer) MQTT broker successfully installed as Docker container
 installContainer.js:63 (MqttHandler.installContainer) MQTT saving configuration
 installContainer.js:73 (MqttHandler.installContainer) MQTT installed
 connect.js:50 (MqttClient.<anonymous>) Error while connecting to MQTT - Error: Connection refused: Not authorized

De ce que je lis sur internet, il y a vraiment des soucis avec la 2.0.16 de Mosquitto.

Je vais tester de tenter de fixer l’image à la 2.0.15 dans Gladys pour voir si ça fixerait bien le souci

1 Like

Bonne nouvelle, la 2.0.15 est bien fonctionnelle :white_check_mark:

J’ai fais une PR :

Je vous tiens au courant quand c’est live en production

3 Likes

@PhilippeMA
bonjour,
j etais en effet sur mon node mqtt nodered en qos 2.
et moi aussi je suis passé en 0, et en plus version mqtt 5 (alors qu auparavant 3.1.1) (apparemment les versions mqtt dans le node nodered ne correspondent pas a celles de mosquitto (pourquoi ?).
au final, pour le moment cela refonctionne, mais j attend un peu avant d enteriner la solution car j aimais du recul et essayer avec de nouveaux script nodered . l effet de bord de la maj mqtt-mosquitto sur nodered et indirectement gladys me parait bizarre. peut etre une nouvelle maj mqtt a venir si trop de pb constatés ?

La version de Mosquitto est désormais fixé à 2.0.15 dans Gladys Assistant v4.26.1:

Le container sera mis automatiquement à jour, néanmoins, pour les nouveaux utilisateurs, où ceux qui ont écrasé leur fichier de configuration, il faudra peut-être re-enregistrer le mot de passe MQTT dans Gladys pour que Gladys re-écrase le fichier de configuration.

Merci pour vos retours :pray:

1 Like

Le MQTT était cassé pour moi depuis hier aussi.
Bien qu’étant en 4.26.1 cela ne fonctionnait toujours pas en rentrant du boulot aujourd’hui.
J’ai dû retaper mon mot de passe MQTT et sauvegarder la configuration (comme indiqué par GBoulvin plus haut) pour que cela refonctionne.

Idem pour moi.
Il m’a fallu une sauvegarde de configuration coté intégration MQTT pour que tout rentre en ordre

Idem pour moi …

ça ne m’étonne pas, la version 2.0.16 a visiblement un bug sur la génération du fichier de conf, c’est possible que votre précédent fichier ait été écrasé et qu’il faille le re-générer :slight_smile:

On aura plus le souci à l’avenir si on reste sur des versions « fixe » comme là avec une mise à jour manuelle en testant chaque version.

1 Like

hello,
pour ma part passage en 4.26.1 sans vrai pb du coté gladys.
un premier temps où mes features de device mqtt ne s actualisaient pas .
puis j ai eté dans noderedfaire un retropedalage des modifs que j avais testés suite à cette maj mqtt.
et suite à ce retropedalage tout est revenu dans l ordre dans gladys sans avoir à refaire la config.

1 Like

Bonjour,

J’ai également un bug du broker MQTT Gladys depuis Aout (dernière remontée d’un capteur de température). Je ne m’étais pas aperçu de l’arrêt de connexion car j’utilise Gladys pour gérer les jours Tempo essentiellement.

J’ai donc testé l’arrêt du broker depuis Gladys mais la page de configuration MQTT revient toujours sur les paramètres configurés : Switch, id et mdp activés.
J’ai désactivé le service MQTT dans les paramètres de Gladys mais même résultat.

Du coup j’ai stoppé le conteneur Mosquitto, mais résultat identique.

J’ai redémarré mon pi et le conteneur Gladys mais rien n’y fait, impossible de modifier les paramètres Mqtt, id, mdp dans Gladys.

C’est comme si la page de configuration MQTT de Gladys était complètement buguée.

Je n’ai pas essayé de lancer un conteneur Mosquitto car je trouve bien pratique de configurer le broker MQTT depuis Gladys.

Toutes les manips ont été effectuées en version 4.31.

Il nous faudra des logs et screen pour essayer de te débloquer

ok merci, je posterai ce soir les éléments

1 Like

@Fabic

Tu dois être sous firefox peut-être, si c’est le cas essaie de faire la manip sous chrome ou opéra (i l y a un problème récurent d’auto-complétion à la volée des champs sous firefox)

1 Like

@cce66 , merci beaucoup, ça a fonctionné tout de suite sous chromium!

1 Like