What to do after getting to command line?

Hi, so when I let Gladys installation/setup occur, it then asks for my default Rasbian username and password. After this it drops me at the command line. What am I supposed to do next? The PI isn’t picked up by the router so the web interface doesn’t load.

I also tried unsuccessfully to add my wifi details into the wpa_supplicant.conf file but that didn’t seem to do much good either.



do you have this issue with v4 raspbian version of gladys or another version ?

I remember I had an issue with the Wifi when I installed the gladys image. I modified /etc/network/interfaces like this :

auto wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Let me know if this solution help you.

Sorry, I’m not sure I understood. I tried auto wlan0 on the pi command line but that didn’t work, and then hooked the SD card to my PC but have no folder structure live you’ve specified.

Could you please clarify how and where I input these commands?


The /etc/network/interface file is accessible from your ssh session. You have to add the line that I mentionned.
I rewritted my gladys image to reproduce the issue and validate this fix but…without success. My new gladys image works perfectly without any modification :smiley:

So, could you try this :

  • rewritte Gladys image on your SD card
  • Put the wpa_supplicant.conf file at the root of your sd card

You can use this template :

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

  • plug the sd card on your PI
  • power on.

If you connect an hdmi, you should see your IP address (“My IP Address is X.X.X.X”), or an error message above the login. In my case :

Now you can access to Gladys from a browser. https://gladys.local or https://X.X.X.X

If after this, if your Pi doesn’t catch an ip address, try to see if there is an error message during the boot and share it.