Gladys 3.8.1 disponible en beta!


#41

@piznel C’est à dire ?


#42

J’ai créé un scénario dont le code est le suivant :
trigger:

title: test1
condition_template: house == 1 && mode == 9
active: 1
code: house-mode-changed
user: 1
conditions: []
actions:

  • code: deviceType.exec
    params:
    value: ‘ON’
    devicetype: ‘49’
    Le devicetype 49 est une lampe milight, qui fonctionne correctement depuis la page device.
    J’ai alors le message d’erreur suivant en déclenchant le scénario :

Par contre, en remplaçant dans le script du scénario le “ON” du champ “value” par “1”, ça marche.


#43

Ah c’est bizarre ça, tu as créé comment ce scénario ? avec l’interface graphique ou avec l’éditeur de texte ? je ne vois pas d’ou vient ce “ON” !


#44

Avec l’interface graphique.


#45

Serial et RFLink
J’ai voulu tester le module RFLink d’@isokar avec la béta.
Ayant un second Arduino en USB, j’ai donc du installer Serial. (Pas sûr que ce soit obliger avec RFLink seul ?)
RFLink communique à 57600 bauds par défaut.
Hors, le module Serial fait passer le port Serial à 9600 : je vois dans les logs les symboles cabalistiques caractéristiques d’une vitesse pas bonne.
Du coup, nouvel essai en passant manuellement la vitesse à 57600 :
image
Après cela, j’ai ça dans les logs, après avoir passer le module RFLink en mode apprentissage :
image
Cette fois, c’est lisible, mais toujours pas compris par le module. mais c’est déjà ça ! :slight_smile:
Pour moi, la chaîne est conforme à RFLink.
N’étant pas fort en Node.JS, je ne vois rien qui cloche dans le code du module… A moins que le pb vienne d’ailleurs ?
Merci d’avance !


#46

Si tu n’utilise que le module RFLink, il se suffit à lui même, pas besoin de Serial.

Après si tu veux installer les 2, il faut les versions qui gèrent ces 2 paramètres :

Pour RFLink, le paramètre est créé par défaut à l’installation du module.

Mais pour Serial, il faut installer une version modifié, pour ça ; sinon, le module prend la main sur le module RFLink (d’où le changement de vitesse du port) :

@isokar, tu n’a pas encore fait de PR avec cette modif sur le module à @pierre-gilles ?


#47

Si si, mais ça va finir dans un nouveau module tout ça ! :slight_smile: Au lieu d’avoir deux modules radioemitter + serial, on a fusionné les deux dans un module, gladys-radio. J’ai pas encore eu le temps de communiquer dessus !


#48

Merci.
Et concernant le pb d’importation dans Gladys, avec le message d’erreur de JSON ?


#49

@Pti_Nico t’as répondu pour ça, le message est interprété par Gladys serial hors là c’est le module RFlink qui doit interpréter le message


#50

Ah, ok, ça modifie le baudrate et prends la main sur le flux.
Je vais donc Essayer le Serial qu’il a indiqué.
Merci :slight_smile:


#51

Pétez pas tous, car j’utilise le module Serial pour piloter mon anneau LED qui est connecté à un arduino. :open_mouth:


#52

Tkt! C’est un module supplémentaire, pas une modification :slight_smile:


#53

Bonjour @pierre-gilles ,
Je rencontre un problème de focus sous chrome, W7 :
image
Comme tu peux le voir, la souris pointe sur le curseur de “Test-multilevel”, mais le focus est sur le curseur de “Test-hygro”, ce qui rend assez compliqué le réglage fin.
Suis-je le seul à rencontrer ce problème ?
Merci


#54

j’ai moi même le soucis sous Safari et Chrome cependant je n’ai pas installer la Bêta et suis encore en 3.8


#55

Hello ! Le problème date surement d’avant, je n’ai pas touché à ça :slight_smile:

J’ai créé une issue GitHub =>


#56

Bonjour,

Dans le cas d’un devicetype multilevel qui n’est pas un capteur, on a ça :slight_smile:
image
On ne voit pas la valeur en la modifiant avec les flèches.

Thx !


#57

Alors ça devrait être réglé, j’ai fais une modification récemment qui élargit la taille de la modal, je sais plus si ça été intégré dans la 3.8.1 ou si c’est pour après… par curiosité tu as quel résolution d’écran ?


#58

La résolution est de 1680x1050.


#59

Hello,

Top le boulot, faut que je test ca.

Pour les Zones apparaissant dans la map, j’ai fais ca chez moi, j’ai pas de soucis avec le zoom, faut que je regarde ce que j’avais fait, ca date et j’avais jamais fait de PR, j’ai meme fait un bouton pour afficher le parcous d’un utilisateur, je voulais faire une timeline pour gérer la notion de range (déplacement entre 6h et 10h tel jour…) mais j’ai jamais fini le dev.


#60

Je pense que la nouvelle box device a un peu de mal à se mettre à jour, comparé à la page Devices.
Même en rafraîchissant.
J’ai pas les mêmes valeurs…