Hello, As a validation for my migration from HA to Gladys, I started installing a test platform.
I installed Ubuntu Server on a mini PC (I already have a file server with Ubuntu-server). I installed Docker and Gladys as indicated in: Installation avec Docker | Gladys Assistant I noted that it might be relevant to mention in this documentation that it is desirable for the base OS partitioning to create a separate partition for /var if possible large enough, on the other hand the /home partition does not need to be as large as a NAS. I was able to connect to Gladys and create my local account, thanks to the documentation!
I then installed AdGuardHome again following the instructions at: adguard/adguardhome - Docker Image Everything seems to have gone well but not entirely in fact.
When querying Docker:
me@my_machine:~$ sudo docker ps
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
d9a23ec27f14 adguard/adguardhome "/opt/adguardhome/Ad…" 40 seconds ago Up 3 seconds adguardhome
b21791a177ff gladysassistant/gladys:v5 "docker-entrypoint.s…" 18 hours ago Up 3 minutes gladys
Everything seems to be going well but I cannot connect to http://my_local_ip:3000 (the browser can’t reach it).
Looking more closely at the installation logs, I find:
me@my_machine:~$ sudo docker run --name adguardhome
--restart unless-stopped
-v /my/own/workdir:/opt/adguardhome/work
-v /my/own/confdir:/opt/adguardhome/conf
-p 53:53/tcp -p 53:53/udp
-p 67:67/udp -p 68:68/udp
-p 80:80/tcp -p 443:443/tcp -p 443:443/udp -p 3000:3000/tcp
-p 853:853/tcp
-p 784:784/udp -p 853:853/udp -p 8853:8853/udp
-p 5443:5443/tcp -p 5443:5443/udp
-d adguard/adguardhome
d9a23ec27f14785f589c5e9e0ade5aa3c3f08bda22189492597d7857bedcc78a
docker: Error response from daemon: failed to set up container networking: driver failed programming external connectivity on endpoint adguardhome (6ba91471a3e357a25892af051cc5b96d43c30a1decaa09c0ca72bda48f6ce2f6): failed to bind host port 0.0.0.0:53/tcp: address already in use
Run 'docker run --help' for more information
There is an error message that seems to say that port 53 is already in use. A port redirection issue?
Thanks in advance for your insights.
