Mise en place configuration développement

Bonjour/Bonsoir ou comme j’aime dire Bonjoir

j’ai voulus me mettre une configuration de développement mais j’ai une soucis, j’ai suivis les doc mais j’ai cette erreur

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! gladys-server@ postinstall: `node ./cli/install_service_dependencies.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the gladys-server@ postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/jerome/.npm/_logs/2022-05-13T19_27_53_059Z-debug.log

et comme je débute en node.js je ne comprends pas trop l’erreur et je voudrais franchement apporter mon aide au projet

1 Like

Hello,

Tu as mis tous le log ? J’ai l’impresssion qu’il manque des choses :slight_smile:

Mets bien la commande et l’output où il y a les errreurs :slight_smile:

donc je voulais pas polluer mais voici le output


> gladys-server@ postinstall /home/jerome/git/gladys/server
> node ./cli/install_service_dependencies.js

2022-05-13T21:27:33+0200 <info> install_service_dependencies.js:21 () Installing dependencies in folder /home/jerome/git/gladys/server/services/bluetooth
prebuild-install info begin Prebuild-install version 5.3.5
prebuild-install info looking for cached prebuild @ /home/jerome/.npm/_prebuilds/91abd0-usb-v1.6.3-node-v83-linux-x64.tar.gz
prebuild-install http request GET https://github.com/tessel/node-usb/releases/download/v1.6.3/usb-v1.6.3-node-v83-linux-x64.tar.gz
prebuild-install http 404 https://github.com/tessel/node-usb/releases/download/v1.6.3/usb-v1.6.3-node-v83-linux-x64.tar.gz
prebuild-install WARN install No prebuilt binaries found (target=14.19.2 runtime=node arch=x64 libc= platform=linux)
../libusb/libusb/os/linux_udev.c:40:10: fatal error: libudev.h: Aucun fichier ou dossier de ce type
   40 | #include <libudev.h>
      |          ^~~~~~~~~~~
compilation terminated.
make: *** [libusb.target.mk:150 : Release/obj.target/libusb/libusb/libusb/os/linux_udev.o] Erreur 1
gyp ERR! build error 
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:194:23)
gyp ERR! stack     at ChildProcess.emit (events.js:400:28)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:285:12)
gyp ERR! System Linux 5.10.0-14-amd64
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /home/jerome/git/gladys/server/services/bluetooth/node_modules/usb
gyp ERR! node -v v14.19.2
gyp ERR! node-gyp -v v5.1.0
gyp ERR! not ok 
npm WARN gladys-bluetooth@1.0.0 No repository field.
npm WARN gladys-bluetooth@1.0.0 No license field.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: usb@1.6.3 (node_modules/usb):
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: usb@1.6.3 install: `prebuild-install --verbose || node-gyp rebuild`
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1

2022-05-13T21:27:37+0200 <info> install_service_dependencies.js:21 () Installing dependencies in folder /home/jerome/git/gladys/server/services/caldav
npm WARN gladys-caldav@ No description
npm WARN gladys-caldav@ No repository field.
npm WARN gladys-caldav@ No license field.

2022-05-13T21:27:38+0200 <info> install_service_dependencies.js:21 () Installing dependencies in folder /home/jerome/git/gladys/server/services/ewelink
npm WARN gladys-ewelink@1.0.1 No description
npm WARN gladys-ewelink@1.0.1 No repository field.
npm WARN gladys-ewelink@1.0.1 No license field.

2022-05-13T21:27:39+0200 <info> install_service_dependencies.js:21 () Installing dependencies in folder /home/jerome/git/gladys/server/services/example
npm WARN gladys-example@ No repository field.
npm WARN gladys-example@ No license field.

2022-05-13T21:27:40+0200 <info> install_service_dependencies.js:21 () Installing dependencies in folder /home/jerome/git/gladys/server/services/google-actions
npm WARN google-actions@1.0.0 No description
npm WARN google-actions@1.0.0 No repository field.
npm WARN google-actions@1.0.0 No license field.

2022-05-13T21:27:40+0200 <info> install_service_dependencies.js:21 () Installing dependencies in folder /home/jerome/git/gladys/server/services/mqtt
npm WARN gladys-mqtt@ No description
npm WARN gladys-mqtt@ No repository field.
npm WARN gladys-mqtt@ No license field.

2022-05-13T21:27:42+0200 <info> install_service_dependencies.js:21 () Installing dependencies in folder /home/jerome/git/gladys/server/services/openweather
npm WARN gladys-openweather@ No description
npm WARN gladys-openweather@ No repository field.
npm WARN gladys-openweather@ No license field.

2022-05-13T21:27:43+0200 <info> install_service_dependencies.js:21 () Installing dependencies in folder /home/jerome/git/gladys/server/services/philips-hue
npm WARN gladys-hue@1.0.0 No description
npm WARN gladys-hue@1.0.0 No repository field.
npm WARN gladys-hue@1.0.0 No license field.

2022-05-13T21:27:43+0200 <info> install_service_dependencies.js:21 () Installing dependencies in folder /home/jerome/git/gladys/server/services/rtsp-camera
npm WARN gladys-rtsp-camera@1.0.0 No description
npm WARN gladys-rtsp-camera@1.0.0 No repository field.
npm WARN gladys-rtsp-camera@1.0.0 No license field.

2022-05-13T21:27:44+0200 <info> install_service_dependencies.js:21 () Installing dependencies in folder /home/jerome/git/gladys/server/services/tasmota
npm WARN gladys-tasmota@1.0.0 No description
npm WARN gladys-tasmota@1.0.0 No repository field.
npm WARN gladys-tasmota@1.0.0 No license field.

2022-05-13T21:27:45+0200 <info> install_service_dependencies.js:21 () Installing dependencies in folder /home/jerome/git/gladys/server/services/telegram
npm WARN gladys-telegram@ No description
npm WARN gladys-telegram@ No repository field.
npm WARN gladys-telegram@ No license field.

2022-05-13T21:27:46+0200 <info> install_service_dependencies.js:21 () Installing dependencies in folder /home/jerome/git/gladys/server/services/tp-link
npm WARN gladys-tplink@1.0.0 No description
npm WARN gladys-tplink@1.0.0 No repository field.
npm WARN gladys-tplink@1.0.0 No license field.

2022-05-13T21:27:47+0200 <info> install_service_dependencies.js:21 () Installing dependencies in folder /home/jerome/git/gladys/server/services/usb
npm WARN gladys-usb@ No description
npm WARN gladys-usb@ No repository field.
npm WARN gladys-usb@ No license field.

2022-05-13T21:27:48+0200 <info> install_service_dependencies.js:21 () Installing dependencies in folder /home/jerome/git/gladys/server/services/xiaomi
npm WARN gladys-xiaomi@ No description
npm WARN gladys-xiaomi@ No repository field.
npm WARN gladys-xiaomi@ No license field.

2022-05-13T21:27:49+0200 <info> install_service_dependencies.js:21 () Installing dependencies in folder /home/jerome/git/gladys/server/services/zigbee2mqtt
npm WARN gladys-zigbee2mqtt@1.0.0 No description
npm WARN gladys-zigbee2mqtt@1.0.0 No repository field.
npm WARN gladys-zigbee2mqtt@1.0.0 No license field.

2022-05-13T21:27:50+0200 <info> install_service_dependencies.js:21 () Installing dependencies in folder /home/jerome/git/gladys/server/services/zwave
grep: /usr/*/include/value_classes: Aucun fichier ou dossier de ce type
gyp: Call to 'grep -r GetTypeNameFromEnum /usr/*/include/value_classes | wc -l' returned exit status 0 while in binding.gyp. while trying to load binding.gyp
gyp ERR! configure error 
gyp ERR! stack Error: `gyp` failed with exit code: 1
gyp ERR! stack     at ChildProcess.onCpExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:351:16)
gyp ERR! stack     at ChildProcess.emit (events.js:400:28)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:285:12)
gyp ERR! System Linux 5.10.0-14-amd64
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /home/jerome/git/gladys/server/services/zwave/node_modules/openzwave-shared
gyp ERR! node -v v14.19.2
gyp ERR! node-gyp -v v5.1.0
gyp ERR! not ok 
npm WARN gladys-zwave@ No description
npm WARN gladys-zwave@ No repository field.
npm WARN gladys-zwave@ No license field.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! openzwave-shared@1.6.2 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the openzwave-shared@1.6.2 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/jerome/.npm/_logs/2022-05-13T19_27_53_017Z-debug.log
2022-05-13T21:27:53+0200 <warn> install_service_dependencies.js:27 () Error: Command failed: cd /home/jerome/git/gladys/server/services/zwave && npm install --unsafe-perm
grep: /usr/*/include/value_classes: Aucun fichier ou dossier de ce type
gyp: Call to 'grep -r GetTypeNameFromEnum /usr/*/include/value_classes | wc -l' returned exit status 0 while in binding.gyp. while trying to load binding.gyp
gyp ERR! configure error 
gyp ERR! stack Error: `gyp` failed with exit code: 1
gyp ERR! stack     at ChildProcess.onCpExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:351:16)
gyp ERR! stack     at ChildProcess.emit (events.js:400:28)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:285:12)
gyp ERR! System Linux 5.10.0-14-amd64
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /home/jerome/git/gladys/server/services/zwave/node_modules/openzwave-shared
gyp ERR! node -v v14.19.2
gyp ERR! node-gyp -v v5.1.0
gyp ERR! not ok 
npm WARN gladys-zwave@ No description
npm WARN gladys-zwave@ No repository field.
npm WARN gladys-zwave@ No license field.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! openzwave-shared@1.6.2 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the openzwave-shared@1.6.2 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/jerome/.npm/_logs/2022-05-13T19_27_53_017Z-debug.log

    at checkExecSyncError (child_process.js:790:11)
    at execSync (child_process.js:863:15)
    at /home/jerome/git/gladys/server/cli/install_service_dependencies.js:23:5
    at Array.forEach (<anonymous>)
    at Object.<anonymous> (/home/jerome/git/gladys/server/cli/install_service_dependencies.js:20:13)
    at Module._compile (internal/modules/cjs/loader.js:1085:14)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1114:10)
    at Module.load (internal/modules/cjs/loader.js:950:32)
    at Function.Module._load (internal/modules/cjs/loader.js:790:12)
    at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:75:12) {
  status: 1,
  signal: null,
  output: [
    null,
    <Buffer 0a 3e 20 6f 70 65 6e 7a 77 61 76 65 2d 73 68 61 72 65 64 40 31 2e 36 2e 32 20 70 72 65 69 6e 73 74 61 6c 6c 20 2f 68 6f 6d 65 2f 6a 65 72 6f 6d 65 2f ... 220 more bytes>,
    <Buffer 67 72 65 70 3a 20 2f 75 73 72 2f 2a 2f 69 6e 63 6c 75 64 65 2f 76 61 6c 75 65 5f 63 6c 61 73 73 65 73 3a 20 41 75 63 75 6e 20 66 69 63 68 69 65 72 20 ... 1382 more bytes>
  ],
  pid: 386988,
  stdout: <Buffer 0a 3e 20 6f 70 65 6e 7a 77 61 76 65 2d 73 68 61 72 65 64 40 31 2e 36 2e 32 20 70 72 65 69 6e 73 74 61 6c 6c 20 2f 68 6f 6d 65 2f 6a 65 72 6f 6d 65 2f ... 220 more bytes>,
  stderr: <Buffer 67 72 65 70 3a 20 2f 75 73 72 2f 2a 2f 69 6e 63 6c 75 64 65 2f 76 61 6c 75 65 5f 63 6c 61 73 73 65 73 3a 20 41 75 63 75 6e 20 66 69 63 68 69 65 72 20 ... 1382 more bytes>
}
/home/jerome/git/gladys/server/cli/install_service_dependencies.js:31
      throw e;
      ^

Error: Command failed: cd /home/jerome/git/gladys/server/services/zwave && npm install --unsafe-perm
grep: /usr/*/include/value_classes: Aucun fichier ou dossier de ce type
gyp: Call to 'grep -r GetTypeNameFromEnum /usr/*/include/value_classes | wc -l' returned exit status 0 while in binding.gyp. while trying to load binding.gyp
gyp ERR! configure error 
gyp ERR! stack Error: `gyp` failed with exit code: 1
gyp ERR! stack     at ChildProcess.onCpExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:351:16)
gyp ERR! stack     at ChildProcess.emit (events.js:400:28)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:285:12)
gyp ERR! System Linux 5.10.0-14-amd64
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /home/jerome/git/gladys/server/services/zwave/node_modules/openzwave-shared
gyp ERR! node -v v14.19.2
gyp ERR! node-gyp -v v5.1.0
gyp ERR! not ok 
npm WARN gladys-zwave@ No description
npm WARN gladys-zwave@ No repository field.
npm WARN gladys-zwave@ No license field.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! openzwave-shared@1.6.2 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the openzwave-shared@1.6.2 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/jerome/.npm/_logs/2022-05-13T19_27_53_017Z-debug.log

    at checkExecSyncError (child_process.js:790:11)
    at execSync (child_process.js:863:15)
    at /home/jerome/git/gladys/server/cli/install_service_dependencies.js:23:5
    at Array.forEach (<anonymous>)
    at Object.<anonymous> (/home/jerome/git/gladys/server/cli/install_service_dependencies.js:20:13)
    at Module._compile (internal/modules/cjs/loader.js:1085:14)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1114:10)
    at Module.load (internal/modules/cjs/loader.js:950:32)
    at Function.Module._load (internal/modules/cjs/loader.js:790:12)
    at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:75:12) {
  status: 1,
  signal: null,
  output: [
    null,
    Buffer(270) [Uint8Array] [
       10,  62,  32, 111, 112, 101, 110, 122, 119,  97, 118, 101,
       45, 115, 104,  97, 114, 101, 100,  64,  49,  46,  54,  46,
       50,  32, 112, 114, 101, 105, 110, 115, 116,  97, 108, 108,
       32,  47, 104, 111, 109, 101,  47, 106, 101, 114, 111, 109,
      101,  47, 103, 105, 116,  47, 103, 108,  97, 100, 121, 115,
       47, 115, 101, 114, 118, 101, 114,  47, 115, 101, 114, 118,
      105,  99, 101, 115,  47, 122, 119,  97, 118, 101,  47, 110,
      111, 100, 101,  95, 109, 111, 100, 117, 108, 101, 115,  47,
      111, 112, 101, 110,
      ... 170 more items
    ],
    Buffer(1432) [Uint8Array] [
      103, 114, 101, 112,  58,  32,  47, 117, 115, 114,  47,  42,
       47, 105, 110,  99, 108, 117, 100, 101,  47, 118,  97, 108,
      117, 101,  95,  99, 108,  97, 115, 115, 101, 115,  58,  32,
       65, 117,  99, 117, 110,  32, 102, 105,  99, 104, 105, 101,
      114,  32, 111, 117,  32, 100, 111, 115, 115, 105, 101, 114,
       32, 100, 101,  32,  99, 101,  32, 116, 121, 112, 101,  10,
      103, 121, 112,  58,  32,  67,  97, 108, 108,  32, 116, 111,
       32,  39, 103, 114, 101, 112,  32,  45, 114,  32,  71, 101,
      116,  84, 121, 112,
      ... 1332 more items
    ]
  ],
  pid: 386988,
  stdout: Buffer(270) [Uint8Array] [
     10,  62,  32, 111, 112, 101, 110, 122, 119,  97, 118, 101,
     45, 115, 104,  97, 114, 101, 100,  64,  49,  46,  54,  46,
     50,  32, 112, 114, 101, 105, 110, 115, 116,  97, 108, 108,
     32,  47, 104, 111, 109, 101,  47, 106, 101, 114, 111, 109,
    101,  47, 103, 105, 116,  47, 103, 108,  97, 100, 121, 115,
     47, 115, 101, 114, 118, 101, 114,  47, 115, 101, 114, 118,
    105,  99, 101, 115,  47, 122, 119,  97, 118, 101,  47, 110,
    111, 100, 101,  95, 109, 111, 100, 117, 108, 101, 115,  47,
    111, 112, 101, 110,
    ... 170 more items
  ],
  stderr: Buffer(1432) [Uint8Array] [
    103, 114, 101, 112,  58,  32,  47, 117, 115, 114,  47,  42,
     47, 105, 110,  99, 108, 117, 100, 101,  47, 118,  97, 108,
    117, 101,  95,  99, 108,  97, 115, 115, 101, 115,  58,  32,
     65, 117,  99, 117, 110,  32, 102, 105,  99, 104, 105, 101,
    114,  32, 111, 117,  32, 100, 111, 115, 115, 105, 101, 114,
     32, 100, 101,  32,  99, 101,  32, 116, 121, 112, 101,  10,
    103, 121, 112,  58,  32,  67,  97, 108, 108,  32, 116, 111,
     32,  39, 103, 114, 101, 112,  32,  45, 114,  32,  71, 101,
    116,  84, 121, 112,
    ... 1332 more items
  ]
}
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! gladys-server@ postinstall: `node ./cli/install_service_dependencies.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the gladys-server@ postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/jerome/.npm/_logs/2022-05-13T19_27_53_059Z-debug.log

et voici le fichier log (désolé je sais pas joindre un fichier ici

347 timing stage:rollbackFailedOptional Completed in 33ms
348 silly install runPostinstallTopLevelLifecycles
349 silly build gladys-server@
350 info linkStuff gladys-server@
351 silly linkStuff gladys-server@ has /home/jerome/git/gladys as its parent node_modules
352 silly install gladys-server@
353 info lifecycle gladys-server@~install: gladys-server@
354 silly postinstall gladys-server@
355 info lifecycle gladys-server@~postinstall: gladys-server@
356 verbose lifecycle gladys-server@~postinstall: unsafe-perm in lifecycle true
357 verbose lifecycle gladys-server@~postinstall: PATH: /usr/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/jerome/git/gladys/server/node_modules/.bin:/sbin:/usr/sbin:/usr/local/sbin:/home/jerome/.local/bin:/home/jerome/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/snap/bin
358 verbose lifecycle gladys-server@~postinstall: CWD: /home/jerome/git/gladys/server
359 silly lifecycle gladys-server@~postinstall: Args: [ '-c', 'node ./cli/install_service_dependencies.js' ]
360 silly lifecycle gladys-server@~postinstall: Returned: code: 1  signal: null
361 info lifecycle gladys-server@~postinstall: Failed to exec postinstall script
362 verbose stack Error: gladys-server@ postinstall: `node ./cli/install_service_dependencies.js`
362 verbose stack Exit status 1
362 verbose stack     at EventEmitter.<anonymous> (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:332:16)
362 verbose stack     at EventEmitter.emit (events.js:400:28)
362 verbose stack     at ChildProcess.<anonymous> (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
362 verbose stack     at ChildProcess.emit (events.js:400:28)
362 verbose stack     at maybeClose (internal/child_process.js:1088:16)
362 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:296:5)
363 verbose pkgid gladys-server@
364 verbose cwd /home/jerome/git/gladys/server
365 verbose Linux 5.10.0-14-amd64
366 verbose argv "/usr/bin/node" "/usr/bin/npm" "install"
367 verbose node v14.19.2
368 verbose npm  v6.14.17
369 error code ELIFECYCLE
370 error errno 1
371 error gladys-server@ postinstall: `node ./cli/install_service_dependencies.js`
371 error Exit status 1
372 error Failed at the gladys-server@ postinstall script.
372 error This is probably not a problem with npm. There is likely additional logging output above.
373 verbose exit [ 1, true ]

si il faut les fichier je les partage je peu pas le paste directement ici

Tu polluras jamais :smiley: Mieux vaut trop que pas assez :wink:

Ok je vois moi aussi j’ai déjà eu ce problème. C’est de la merde mdr ! Mais je pense que ce que tu peux faire c’est:

npm install -g node-gyp
sudo npm-install -g node-gyp

Je suis plus sur mais c’est ce truc qui fout la merde essaye les deux commandes :slight_smile:

bon j’ai fais un mix de tes 2 commandes

sudo sudo npm install -g node-gyp

et résultat ça marche pas le npm install :frowning:

sudo sudo pas possible ca :smiley:

Hum si quelqu’un d’autre sait, je sèche sur ce coup c’est vraiment une erreur de merde pour le coup …

Ca vient du service Z-Wave visiblement, est-ce que tu as installé open-zwave sur ta machine?

2 options:

  • Soit tu essaie d’installer open-zwave sur ta machine, tu peux t’inspirer de ce qu’on fait dans le Dockerfile: Gladys/Dockerfile at master · GladysAssistant/Gladys · GitHub

  • Soit tu décide d’ignorer l’installation du service Zwave (il sera non fonctionnel, mais bon en local pour développer c’est pas gênant), ce que tu peux faire en rajoutant dans le dossier server un fichier .env avec comme contenu:

INSTALL_SERVICES_SILENT_FAIL=true

:slight_smile:

Pour info, le service Z-Wave nous embête pas mal, car il est basé sur Open-Zwave, une lib qui n’est plus maintenue, qui est en C++ et pose très souvent problème lors de l’installation !

On a un membre de la communauté qui essaie de nous faire passer à ZwaveJS, une autre lib plus moderne, et maintenue, mais c’est beaucoup de boulot :slight_smile:

en regardant de plus près dans les log je confirme que c’est bien openzwave qui pose problème pourtant celui-ci est bien installer, donc je ne comprends pas trop. et sinon avec la variable d’environnement ça marche merci encore

1 Like

Openzwave 1.6?