Nouvelle image Rapbian Gladys & nouveau process de mise à jour!

Salut à tous,

Depuis pas mal de temps, la mise à jour Gladys était douloureuse pour mal d’entre vous du fait de la compilation de la lib “bcrypt” sur vos Raspberry Pi.

J’ai donc entièrement repensé le process de mise à jour afin que ce soit plus stable et plus rapide :slight_smile:

J’ai détaillé tout le nouveau process dans un article sur le blog, et publié une nouvelle image Raspbian:

J’attends vos retours là dessus!

Bonjour.
J’ai suivi toute la procédure. J’arrive à me connecter via ssh sur le pi. Je peux aller sur la page d’accueil via http mais plus via https.
via http, si je clique sur configuration ca me dit que configuration est en erreur pour tous mes modules installés.
Cdt.

@lagoa : tu as bien relancé le script /home/pi/enable-ssl-gladys.sh pour activer le HTTPS ?

Sinon, pour tes modules au pire re-installe les tous un par un ça ne perd pas leur config :wink: ( ça me fait penser qu’un bouton réinstaller/mettre à jour ne serait pas de trop… )

ah effectivement il y a un problème avec le SSL… je mets à jour l’image et je la republie!

Pour toi, il suffit de modifier le fichier de conf: /etc/nginx/sites-available/gladys-ssl, remplace la ligne:

  location ~ ^/(fonts|hooks|min|img|js|styles|templates)/  {
    root /home/pi/gladys/node_modules/gladys/www;

Par

  location ~ ^/(fonts|hooks|min|img|js|styles|templates)/  {
    root /home/pi/gladys/www;

Et fais

sudo service nginx restart

heu je suis en train de télécharger l’image ca met 1 heure et ton poste 22 mn.
La version porte le même numéro ou pas? Je re-telecharge?
Pourquoi tu ne met pas une fonction de mise a jour directement dans Gladys sur l’interface web? Même avec une iframe distante que tu pourrais maitriser. Enfin je dit ca… c’est pas moi qui te donnerai des conseils, juste des idées pour participer humblement. J’aime ton projet, ton investissement et ton boulot, alors je m’efforce a t’encourrager. :wink:

@marrodeur: Je suis entrain d’uploader :slight_smile: Il reste 3 minutes d’upload! Attend une seconde !

l’image s’appelera gladys-3.5.1-rev1.img.zip

Pour la mise à jour depuis gladys en one clikck, je ne comprend pas ton principe de l’iframe, mais il y avait une fonction automatique par le passé, que j’ai désactivé car en cas de bug l’utilisateur était un peu dépourvu, là ou en passant par un script, l’utilisateur voit les logs, et en quelque sorte ça “l’éduque” à faire des maj en CLI, et donc à comprendre comment ça fonctionne sous le capot :slight_smile:

Je verrais en fonction de la stabilité si je réactive les majs en one click depuis l’interface gladys

Bon, problème avec la nouvelle image rev1, quelque chose n’a pas du fonctionner de mon côté… Je ne l’ai pas uploadé au final. J’essaie de corriger, en attendant l’image actuelle fonctionne en HTTP, et en HTTPS en faisant la modif juste au dessus :slight_smile:

J’essaie d’uploader l’image corrigée today ou demain

L’iframe c’était juste une idée: afficher une page distante sur une appli local, comme ca tu maitrise les commandes de mise a jour pour chaque version.

ok merci pierre-gilles; je ferais cela demain; dodo là.
et gg pour ce super projet

alors du coup j’ai essayé ta manip mais toujours pas de connection en htpps

bon du coup j’ai continué; il fallait que de mon côté j’exécute le script enable ssh. C’est fait. Connection OK. Demain je désinstalle et réinstalle les modules pour voir si ça règle le pb de configuration.
A++

Pour infos, en faisant mise à jour des données j’ai qd meme ca comme erreur :slight_smile:

En désinstallant et réinstallant les modules la configuration se passe bien. Par contre, la mise à jour toujours même erreur.

Vas dans le dossier “/home/pi/gladys” et fais:

node init.js

Et retest :slight_smile:

Ca me donne cela comme erreur :slight_smile:

Tu n’es pas dans le bon dossier, il faut être dans le dossier gladys, hors là tu es dans le dossier “home/pi”

Après connection ssh sur /home/pi; j’ai fait node /home/pi/gladys/init.js.
Ca a marché à part l’erreur ci-dessous et toujours erreur si je fait « mettre à jour » via gladys

ok; j’avais un peu raté mes alias sur cd; après correction, en allant dans le rep gladys et en faisant node init.js ca marche.
La mise à jour se passe sans erreur via paramètre.
J’ai quand même cette erreur no brain file detected lors de l’init :slight_smile:

Le coup du brain file, cela doit être au premier démarrage, via pm2 je vois bien brain file saved with success et gladys me répond via le chat.