Problème activation du service Zigbee2mqtt

Bonjour Je viens d’installer GA, et d’intégrer Zigbee2mqtt.

Les services sont démarrés mais le lien entre MQTT et ZIGBEE2MQT ne s’établi pas.

Que puis-je faire ?

Ma congif :

Raspberry pi 4

Dongle Zigbee : RASPBEEII - PHOSCON - Passerelle universelle Raspberry Pi Zigbee RaspBee II

Merci pour votre aide

Salut,

Sais tu redémarrer le pi en ligne de commande ?

sudo reboot

J’ai déjà effectué plusieurs fois cette commande :thinking:

Tu as essayé de désactivé zigbee2mqtt, attendre 3,4mn et le réactiver, tu attends et si tu as encore des croix rouge il nous faudra des logs.

Bonjour, je pense que tu fais référence au dongle ConBee II. Si c’est le cas, il est en mode expérimental avec la librairie zigbee2mqtt que l’on utilise.

Et la solution est ici : Zigbee2mqtt avec le conbee II : Erreur - #9 by VonOx

Oui, j’ai également fait ces manip.

Toujours problème malgré l’ajout de adapter: deconz!

Est-ce que tu peux nous donner les logs du container gladys-z2m-zigbee2mqtt ?

docker logs gladys-z2m-zigbee2mqtt

Rassure moi le “!” ne fait pas partie de la configuration ? Car sur tes 2 posts on le retrouve

Zigbee2MQTT:error 2021-06-23 20:15:24: Error while starting zigbee-herdsman

Zigbee2MQTT:error 2021-06-23 20:15:24: Failed to start zigbee

Zigbee2MQTT:error 2021-06-23 20:15:24: Check Frequently asked questions | zigbee2mqtt.io for possible solutions

Zigbee2MQTT:error 2021-06-23 20:15:24: Exiting…

Zigbee2MQTT:error 2021-06-23 20:15:24: undefined

gv

Pour info ma RaspBee II est connectée sur le connecteur GPIO du Rpi 4, donc pas sur un port USB, comme (peut-être) attendu par GA.
Est-ce le problème?

Ah oui, effectivement. La liste des connecteurs zigbee compatibles est ici (et je ne vois pas le tien) Supported adapters | zigbee2mqtt.io

Je vais le rajouter à la documentation de Gladys

Je pensais que, tout comme la ConBee II USB, elle était expérimentale, mais fonctionnait.
Faut-il que j’achète un nouvel adaptateur? Le mien va t’il être bientôt compatible GA?

Merci pour l’aide que tu m’as déjà apportée.

Sorry, je viens de comprendre…
Non, les ! exprimaient mon agacement, pour ne pas écrire autre chose :grinning:

Je viens de récupérer le lien entre MQTT et ZIGBEE2MQT

Capture

Pour information, j’ai :

Activer le port série du Raspberry pour communiquer avec un module externe

sudo raspi-config

Interfacing options

Serial

Étapes supplémentaires pour activer le port série des Raspberry Pi 3, 4 et plus.

Lien de la manip : Activer le port série TTL du Raspberry Pi et vérifier qu’il fonctionne. (raspberry-pi.fr)

1 Like

Ça n’est pas fait automatiquement ? @cicoub13

Apparemment non.
Il faut savoir que j’ai testé successivement Jeedom, Home Assistant, et Gladys Assistant ; les deux derniers avec la même carte SD, que j’ai fini par formater avant de réinstaller l’image GA.

1 Like