Dashboard - Evolutions / Bugs / etc

Il doit y avoir un décalage de quelques secondes entre l’heure de ton Raspberry Pi et l’heure de ton ordinateur sur lequel tu affiches Gladys. Ainsi, dans l’UI, il pense que la valeur a été créé dans le futur, et par conséquent, affiche “dans quelque secondes”.

Après, je suis d’accord, c’est pas terrible. On peut rajouter un check sur la date retournée par le Raspberry Pi.

J’ajoute une issue github:

https://github.com/GladysAssistant/Gladys/issues/887

9 messages ont été scindés en un nouveau sujet : Lenteur parfois sur dashboard Gladys Plus

Je n’avais pas encore utilisé Gladys sur une tablette, uniquement sur un pc et sur le téléphone et je me rends compte que l’affichage du dashboard est le même que sur mobile.
Je perd les 3 colonnes qui sont sur une seul.
Pourtant l’affichage et suffisamment grand, beaucoup plus que sur mobile.

Y a t-il pas un paramètre à modifier pour choisir l’affichage ?

l’issue viens du composant BoxColumn qui as en classe : col-lg-4, faudrait rajouter les différents cas, ou voir si un col-md-4 serait suffisant pour l’affichage.

du coup si t’es pas en media query lg t’aura tout sur une seule colonne (le lg doit être vers 1160px si c’est les style standard, si t’as tablette est en 1024 c’est mort ^^)

Merci de ton retour, j’ai changé la résolution de mon écran et c’est bonne j’ai les 3 colonnes.

A post was split to a new topic: Inversion caméra ( miroir )

Bonsoir a tous,
Je viens de constater un petit bug sur le dashboard. J’ai créé deux dashboard , l’un avec l’affichage et l’autre avec des commandes. Le premier à 3 colonnes et 2 lignes, le deuxième à également 3 colonnes et 2 lignes. Quand je passe de l’un à l’autre, la fenêtre qui se trouve 2eme ligne colonne de gauche n’est pas rafraichit et, affiche la fenêtre 2eme ligne colonne de gauche de l’autre tableau, pour remettre en ordre je rafraichis la page web par la commande du navigateur( j’espère être clair). Ça me le fait sur Firefox et aussi sur Chrome. Est ce que quelqu’un a ce problème?

Tu as un screenshot du bug? (ou mieux, une petite vidéo?)

Merci pour ton retour :slight_smile:

Salut tout le monde,

Petit retour suite à la dernière mise à jour en 4.5. Il arrivait encore parfois que je me retrouve avec des box en erreur sur le Dashboard quand le réseau chez moi était saturé. Depuis cette version et les améliorations de performances de @pierre-gilles, plus aucune erreur. Quand le réseau est chargé, la box met juste un peu plus longtemps à charger mais finit toujours par s’afficher. Beau boulot une fois de plus ! :muscle:

Génial ! N’hésite pas si jamais tu as de nouveau des soucis, comme tu as pu voir la dernière fois je me suis battu jusqu’au bout du bug aha :smiley:

1 Like

Enfin j’ai pu faire une vidéo mais la qualité n’est pas terrible, mais tu devrais voir le probleme. Mais j’ai encore un soucis, comment je te l’envoie?
Merci :thinking:

Tu fais un glissé déposé en réponse sur le forum

Je crois pas que le forum accepte les vidéos, par contre tu peux uploader la vidéo sur un service genre streamable (pas besoin de login), et copier le lien ici, le forum ouvrira la vidéo quand même :slight_smile:

Merci Pierre Gilles
Voici le lien de la video,bugdashboard.
je refais des tests, supprimer les fenêtres des 2 dashboard, et les recréer, le défaut persiste, mais rajouté une troisième ligne et et le défaut agit aussi sur la troisième ,mais le bug agit uniquement sur la colonne de gauche. Si tu veux d’autres tests je reste à ta disposition :blush:

Ok merci @Psoy, c’est très clair avec une vidéo !

J’ai créé une issue Github pour garder une trace du bug:

On va corriger ça :slight_smile:

Ah oui sympa le bug :sweat_smile:

:+1: merci et bon courage

Bonjour à tous,
Pour information, je rencontré le même soucis que @Psoy ,mais à plus grande échelle, les 3 colonnes sont impactées et la majorité des boxs. Fait plusieurs essai avec 5 dashboards, exactement identique. Le refresh résout bien le problème également, mais une fois passé en plein écran impossible de refresh donc obligation de retirer le plein écran.

1 Like

@Psoy @Terdious J’ai identifié et corrigé le bug, c’est dans une PR et ça sera dispo dans la prochaine release de Gladys Assistant! :slight_smile:

La PR:

1 Like

Salut @pierre-gilles !!

Toujours dans la rapidité !!
Je profite de ce post pour t’envoyer mes félicitations pour cette v4.5, j’ai pu prendre un tout petit peu de temps pour regarder la multitude d’éléments ajoutés !! C’est ce qu’on appel une grosse MAJ ^^
Tous mes compliments aux devs et à toi !! Le multi dashboard est tout simplement super et d’un pratique inimaginable de mon côté. J’en ai rêvé, tu l’as fait :wink::wink: Et les divers ajouts dans les scènes commencent à permettre de faire pratiquement tout ce que l’on souhaite !!

Merci !!

1 Like